summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-09-20 22:58:00 +0000
committerMarinus Schraal <foser@gentoo.org>2004-09-20 22:58:00 +0000
commit476ea46cd406a6c65c071b47d0f9f78f2f3352a2 (patch)
tree10a527d44383a892d3c0697456a2f33638acd75e /sys-apps
parentadded ewarn about ipv6 use flag (diff)
downloadhistorical-476ea46cd406a6c65c071b47d0f9f78f2f3352a2.tar.gz
historical-476ea46cd406a6c65c071b47d0f9f78f2f3352a2.tar.bz2
historical-476ea46cd406a6c65c071b47d0f9f78f2f3352a2.zip
fresh release
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hal/ChangeLog9
-rw-r--r--sys-apps/hal/Manifest6
-rw-r--r--sys-apps/hal/files/digest-hal-0.2.981
-rw-r--r--sys-apps/hal/files/hald5
-rw-r--r--sys-apps/hal/hal-0.2.98.ebuild80
5 files changed, 95 insertions, 6 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index ba441dc912b1..66f34cf6b605 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.3 2004/09/18 22:24:14 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.4 2004/09/20 22:58:00 foser Exp $
+
+*hal-0.2.98 (21 Sep 2004)
+
+ 21 Sep 2004; foser <foser@gentoo.org> hal-0.2.98.ebuild :
+ New release, fix up the init script to work with the new pid handling
+ Update dbus dep to keep hal-dev-manager working
+ Add libcap dep
18 Sep 2004; Travis Tilley <lv@gentoo.org> hal-0.2.97.ebuild:
added ~amd64 keyword
diff --git a/sys-apps/hal/Manifest b/sys-apps/hal/Manifest
index 0b6074918f81..f94a3e311e0f 100644
--- a/sys-apps/hal/Manifest
+++ b/sys-apps/hal/Manifest
@@ -1,5 +1,7 @@
-MD5 4320264e990583b237c1ee112b164ad9 ChangeLog 679
+MD5 7ff8e4f8281c8ba67398557c20fad8da hal-0.2.98.ebuild 1927
+MD5 6df3f6bf9050de6828dfe5bbec52e17f ChangeLog 909
MD5 731695e9263a5a2e1eeba290b36078d5 metadata.xml 219
MD5 18d89d8976e9422f0ee10e92d8e7885f hal-0.2.97.ebuild 1745
-MD5 64604f44ef01969d79901597c7dd4386 files/hald 588
+MD5 b220e30fa677e5589866474f1f362ffa files/hald 548
MD5 9ba9094143c1d09db466d61bb7d7b3d5 files/digest-hal-0.2.97 63
+MD5 72d398ab014b2630043ef2a4d9990e2f files/digest-hal-0.2.98 63
diff --git a/sys-apps/hal/files/digest-hal-0.2.98 b/sys-apps/hal/files/digest-hal-0.2.98
new file mode 100644
index 000000000000..7eaa6f7cc441
--- /dev/null
+++ b/sys-apps/hal/files/digest-hal-0.2.98
@@ -0,0 +1 @@
+MD5 cc289e50e00330032604e02392ffde3a hal-0.2.98.tar.gz 1221966
diff --git a/sys-apps/hal/files/hald b/sys-apps/hal/files/hald
index 8711523cfb89..f9bc944de847 100644
--- a/sys-apps/hal/files/hald
+++ b/sys-apps/hal/files/hald
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/files/hald,v 1.1 2004/08/17 21:01:52 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/files/hald,v 1.2 2004/09/20 22:58:00 foser Exp $
depend() {
@@ -14,7 +14,6 @@ start() {
ebegin "Starting Hardware Abstraction Layer daemon"
start-stop-daemon --start -q --exec /usr/sbin/hald
- echo `/sbin/pidof hald` > /var/run/hald.pid
eend $?
@@ -24,7 +23,7 @@ stop() {
ebegin "Stopping Hardware Abstraction Layer daemon"
- start-stop-daemon --stop -q --pidfile /var/run/hald.pid
+ start-stop-daemon --stop -q --pidfile /var/run/hald/hald.pid
eend $?
diff --git a/sys-apps/hal/hal-0.2.98.ebuild b/sys-apps/hal/hal-0.2.98.ebuild
new file mode 100644
index 000000000000..d24fbbfe41c6
--- /dev/null
+++ b/sys-apps/hal/hal-0.2.98.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.2.98.ebuild,v 1.1 2004/09/20 22:58:00 foser Exp $
+
+inherit eutils debug python
+
+DESCRIPTION="Hardware Abstraction Layer"
+HOMEPAGE="http://www.freedesktop.org/Software/hal"
+
+SRC_URI="http://freedesktop.org/~david/dist/${P}.tar.gz"
+LICENSE="GPL-2 | AFL-2.0"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.2.2
+ >=sys-apps/dbus-0.22-r1
+ dev-libs/expat
+ sys-fs/udev
+ sys-apps/hotplug
+ sys-libs/libcap"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+
+ # FIXME : docs
+ econf \
+ --enable-fstab-sync \
+ --enable-hotplug-map \
+ --disable-doxygen-docs \
+ --disable-docbook-docs \
+ --with-pid-file=/var/run/hald/hald.pid \
+ || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ # initscript
+ exeinto /etc/init.d/
+ doexe ${FILESDIR}/hald
+
+ # place our pid file
+ keepdir /var/run/hald
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+
+}
+
+pkg_preinst() {
+
+ enewgroup haldaemon || die "Problem adding haldaemon group"
+ enewuser haldaemon -1 /bin/false /dev/null haldaemon || die "Problem adding haldaemon user"
+
+}
+
+pkg_postinst() {
+
+ # make sure the permissions on the pid dir are alright & after preinst
+ chown haldaemon:haldaemon /var/run/hald
+
+ ewarn "Enabled in this ebuild by default is the usage of fstab-sync"
+ ewarn "that will create mount rules for non-existing devices in"
+ ewarn "fstab if needed, mount points will be created in /media."
+ ewarn "This functionality alters /etc/fstab runtime on the filesystem"
+ ewarn "and might have unforseen side-effects."
+ echo
+ einfo "The HAL daemon needs to be running for certain applications to"
+ einfo "work. Suggested is to add the init script to your start-up"
+ einfo "scripts, this should be done like this :"
+ einfo "\`rc-update add hald default\`"
+
+}