summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-05-04 15:16:01 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-05-04 15:16:01 +0000
commit5252041f0a8e51b0b23e30dca382befb79dca666 (patch)
tree2c78102877efe44dd0364b6cc9d7fa83541f203e /sys-apps
parentfollow up: perms update (diff)
downloadhistorical-5252041f0a8e51b0b23e30dca382befb79dca666.tar.gz
historical-5252041f0a8e51b0b23e30dca382befb79dca666.tar.bz2
historical-5252041f0a8e51b0b23e30dca382befb79dca666.zip
General fixes. Fix for bug #91431.
Package-Manager: portage-2.0.51.21
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sandbox/ChangeLog7
-rw-r--r--sys-apps/sandbox/Manifest10
-rw-r--r--sys-apps/sandbox/files/digest-sandbox-1.2.51
-rw-r--r--sys-apps/sandbox/sandbox-1.2.5.ebuild99
4 files changed, 112 insertions, 5 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index 34b214253483..16a43d017706 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.9 2005/05/03 11:21:04 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.10 2005/05/04 15:16:00 azarah Exp $
+
+*sandbox-1.2.5 (04 May 2005)
+
+ 04 May 2005; Martin Schlemmer <azarah@gentoo.org> +sandbox-1.2.5.ebuild:
+ General fixes. Fix for bug #91431.
*sandbox-1.2.4 (03 May 2005)
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index a168556c2fcb..a0ed49c98e17 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -1,18 +1,20 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 ad9dd0f6bf1d6a38d3e03b394c0966f3 ChangeLog 1369
+MD5 f9810a7a07c6fb7493d54776bafcbba6 ChangeLog 1514
MD5 968e2965b0b6f620634dae6d28d8b4c4 metadata.xml 455
MD5 7ed1125d24e2a98b0832f84d9ab637da sandbox-1.2.4.ebuild 2145
+MD5 d5439e4defda1bd92bc1540821f807ee sandbox-1.2.5.ebuild 2599
MD5 3c85f7c72e45afadde1025fc0ef3a205 sandbox-1.2.2.ebuild 2235
MD5 734eba450db4538f0e38ee876d28dacc sandbox-1.2.3.ebuild 2145
MD5 608cba289865ac916fb83ba5dc9daa2f files/digest-sandbox-1.2.4 66
+MD5 54b60d2b6f5d3b74312b47c02e3f169e files/digest-sandbox-1.2.5 66
MD5 fb651b249c3214a6d0fa321e1d419e07 files/digest-sandbox-1.2.2 66
MD5 bf2c5f346fcc11659401c9240b1b8db9 files/digest-sandbox-1.2.3 66
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCd1/n1ZcsMnZjRyIRAjkPAJ955XVGXc5CIyh4pzTJiM8dpODmrQCcCrpB
-fDbjCWAu0Gp/SoBBW/8vajE=
-=Hr4o
+iD8DBQFCeOh+1ZcsMnZjRyIRAv1cAJ9+TvK+IgqDV0jrJvT28Y4tTaYVrACbB1X7
+BOi6N9T5bEZ9KrnYfyR/yhU=
+=mE7F
-----END PGP SIGNATURE-----
diff --git a/sys-apps/sandbox/files/digest-sandbox-1.2.5 b/sys-apps/sandbox/files/digest-sandbox-1.2.5
new file mode 100644
index 000000000000..bd94a7de2c45
--- /dev/null
+++ b/sys-apps/sandbox/files/digest-sandbox-1.2.5
@@ -0,0 +1 @@
+MD5 46da10934739b14cd9999d6f52227dca sandbox-1.2.5.tar.bz2 221605
diff --git a/sys-apps/sandbox/sandbox-1.2.5.ebuild b/sys-apps/sandbox/sandbox-1.2.5.ebuild
new file mode 100644
index 000000000000..40ddc613063d
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-1.2.5.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.5.ebuild,v 1.1 2005/05/04 15:16:00 azarah Exp $
+
+#
+# don't monkey with this ebuild unless contacting portage devs.
+# period.
+#
+
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~azarah/sandbox/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+#KEYWORDS=" alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 s390 sh sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+RESTRICT="multilib-pkg-force"
+
+DEPEND="virtual/libc"
+
+check_multilib() {
+ has_m32
+ if [ "$?" == 0 ] ; then
+ einfo "Found valid multilib environment."
+ einfo "Building with multilib support."
+ export MULTILIB="1"
+ else
+ ewarn "No valid multilib environment found!"
+ ewarn "Building without multilib support. If"
+ ewarn "you want to have multilib support,"
+ ewarn "emerge gcc with \"multilib\" in your"
+ ewarn "useflags."
+ fi
+}
+
+src_unpack() {
+ if has_multilib_profile ; then
+ for ABI in $(get_install_abis); do
+ unpack ${A}
+ cd ${WORKDIR}
+ einfo "Unpacking sandbox for ABI=${ABI}..."
+ mv ${S} ${S%/}-${ABI} || die "failed moving \$S to ${ABI}"
+ done
+ else
+ unpack ${A}
+ fi
+}
+
+src_compile() {
+ filter-lfs-flags #90228
+ if has_multilib_profile ; then
+ OABI="${ABI}"
+ export CFLAGS="${CFLAGS} -DSB_HAVE_64BIT_ARCH"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ einfo "Configuring sandbox for ABI=${ABI}..."
+ econf --libdir="/usr/$(get_libdir)" || die "econf failed for ${ABI}"
+ einfo "Building sandbox for ABI=${ABI}..."
+ emake || {
+ if [[ ${ABI} == "x86" ]] ; then
+ echo
+ eerror "Building failed for ABI=x86!. This usually means a broken"
+ eerror "multilib setup. Please fix that before filling a bugreport"
+ eerror "against sandbox."
+ echo
+ fi
+ die "emake failed for ${ABI}"
+ }
+ done
+ ABI="${OABI}"
+ else
+ if useq amd64 ; then
+ check_multilib
+ export HAVE_64BIT_ARCH="${MULTILIB}"
+ fi
+ econf || die "econf failed"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ if has_multilib_profile; then
+ OABI="${ABI}"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ einfo "Installing sandbox for ABI=${ABI}..."
+ make DESTDIR="${D}" install || die "make install failed for ${ABI}"
+ done
+ ABI="${OABI}"
+ else
+ make install DESTDIR="${D}" || die "einstalled failed"
+ fi
+}