summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-23 04:40:20 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-23 04:40:20 +0000
commitaa948608a05b6019833b007ae898a77be0295e91 (patch)
tree8c1618f8bfa38eb929668eb3cf9f172ef135d3d6 /sys-apps
parentsys-apps/coreutils-6.10-r1 and higher now provides /bin/mktemp (diff)
downloadhistorical-aa948608a05b6019833b007ae898a77be0295e91.tar.gz
historical-aa948608a05b6019833b007ae898a77be0295e91.tar.bz2
historical-aa948608a05b6019833b007ae898a77be0295e91.zip
old
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/coreutils-6.10.ebuild147
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-6.106
-rw-r--r--sys-apps/mktemp/Manifest24
3 files changed, 12 insertions, 165 deletions
diff --git a/sys-apps/coreutils/coreutils-6.10.ebuild b/sys-apps/coreutils/coreutils-6.10.ebuild
deleted file mode 100644
index 2f71e6f7b852..000000000000
--- a/sys-apps/coreutils/coreutils-6.10.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-6.10.ebuild,v 1.1 2008/01/23 00:07:06 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs autotools
-
-PATCH_VER="1.0"
-DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
-HOMEPAGE="http://www.gnu.org/software/coreutils/"
-SRC_URI="ftp://alpha.gnu.org/gnu/coreutils/${P}.tar.lzma
- mirror://gnu/${PN}/${P}.tar.lzma
- mirror://gentoo/${P}.tar.lzma
- mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2
- http://dev.gentoo.org/~vapier/dist/${P}-patches-${PATCH_VER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="acl nls selinux static xattr"
-
-RDEPEND="selinux? ( sys-libs/libselinux )
- acl? ( sys-apps/acl )
- xattr? ( sys-apps/attr )
- nls? ( >=sys-devel/gettext-0.15 )
- !net-mail/base64
- >=sys-libs/ncurses-5.3-r5"
-DEPEND="${RDEPEND}
- app-arch/lzma-utils
- >=sys-devel/automake-1.10.1
- >=sys-devel/autoconf-2.61
- >=sys-devel/m4-1.4-r1"
-
-pkg_setup() {
- # fixup expr for #123342
- if [[ $(/bin/expr a : '\(a\)') != "a" ]] ; then
- if [[ -x /bin/busybox ]] ; then
- ln -sf /bin/busybox /bin/expr
- else
- eerror "Your expr binary appears to be broken, please fix it."
- eerror "For more info, see http://bugs.gentoo.org/123342"
- die "your expr is broke"
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- EPATCH_SUFFIX="patch" \
- PATCHDIR="${WORKDIR}/patch" \
- EPATCH_EXCLUDE="001_all_coreutils-gen-progress-bar.patch" \
- epatch
-
- # Since we've patched many .c files, the make process will try to
- # re-build the manpages by running `./bin --help`. When doing a
- # cross-compile, we can't do that since 'bin' isn't a native bin.
- # Also, it's not like we changed the usage on any of these things,
- # so let's just update the timestamps and skip the help2man step.
- touch man/*.1
- # There's no reason for this crap to use the private version
- sed -i 's:__mempcpy:mempcpy:g' lib/*.c
-
- AT_M4DIR="m4" eautoreconf
-}
-
-src_compile() {
- if ! type -p cvs > /dev/null ; then
- # Fix issues with gettext's autopoint if cvs is not installed,
- # bug #28920.
- export AUTOPOINT="/bin/true"
- fi
-
- local myconf=""
- [[ ${USERLAND} == "GNU" ]] || myconf="${myconf} --bindir=/usr/libexec/gnu"
- if echo "#include <regex.h>" | $(tc-getCPP) > /dev/null ; then
- myconf="${myconf} --without-included-regex"
- fi
-
- # cross-compile workaround #177061
- [[ ${CHOST} == *-linux* ]] && export fu_cv_sys_stat_statvfs=yes
-
- use static && append-ldflags -static
- # kill/uptime - procps
- # groups/su - shadow
- # hostname - net-tools
- econf \
- --enable-install-program="arch" \
- --enable-no-install-program="groups,hostname,kill,su,uptime" \
- --enable-largefile \
- $(use_enable nls) \
- $(use_enable acl) \
- $(use_enable xattr) \
- $(use_enable selinux) \
- ${myconf} \
- || die "econf"
- emake || die "emake"
-}
-
-src_test() {
- # Non-root tests will fail if the full path isnt
- # accessible to non-root users
- chmod -R go-w "${WORKDIR}"
- chmod a+rx "${WORKDIR}"
- addwrite /dev/full
- export RUN_EXPENSIVE_TESTS="yes"
- #export FETISH_GROUPS="portage wheel"
- make -k check || die "make check failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- rm -f "${D}"/usr/lib/charset.alias
- dodoc AUTHORS ChangeLog* NEWS README* THANKS TODO
-
- insinto /etc
- newins src/dircolors.hin DIR_COLORS || die
-
- # workaround bug in build system where `group` does not
- # work with --enable-no-install-program configure option
- rm "${D}"/usr/bin/groups "${D}"/usr/share/man/man1/groups.1 || die
-
- if [[ ${USERLAND} == "GNU" ]] ; then
- cd "${D}"/usr/bin
- dodir /bin
- # move critical binaries into /bin (required by FHS)
- local fhs="cat chgrp chmod chown cp date dd df echo false ln ls
- mkdir mknod mv pwd rm rmdir stty sync true uname"
- mv ${fhs} ../../bin/ || die "could not move fhs bins"
- # move critical binaries into /bin (common scripts)
- local com="basename chroot cut dir dirname du env expr head mkfifo
- readlink seq sleep sort tail touch tr tty vdir wc yes"
- mv ${com} ../../bin/ || die "could not move common bins"
- # create a symlink for uname in /usr/bin/ since autotools require it
- local x
- for x in ${com} uname ; do
- dosym /bin/${x} /usr/bin/${x} || die
- done
- else
- # For now, drop the man pages, collides with the ones of the system.
- rm -rf "${D}"/usr/share/man
- fi
-}
-
-pkg_postinst() {
- ewarn "Make sure you run 'hash -r' in your active shells."
-}
diff --git a/sys-apps/coreutils/files/digest-coreutils-6.10 b/sys-apps/coreutils/files/digest-coreutils-6.10
deleted file mode 100644
index a4d8efaddf26..000000000000
--- a/sys-apps/coreutils/files/digest-coreutils-6.10
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 46e83f0013134e1edf2f0c0495a9dc53 coreutils-6.10-patches-1.0.tar.bz2 10046
-RMD160 7de54627e3abdef594dc786af441db0206c8dff5 coreutils-6.10-patches-1.0.tar.bz2 10046
-SHA256 6e5fc6be92f932a9c4b2c04d8f008a66bb6b12eae608b8bf629cbe0b0eb1bafd coreutils-6.10-patches-1.0.tar.bz2 10046
-MD5 23582a4e8b21e837cfbafbc3834a8a4b coreutils-6.10.tar.lzma 3746908
-RMD160 7b3f7ae0f92fa3f04ab0b7fc0bbc22430a392a0b coreutils-6.10.tar.lzma 3746908
-SHA256 8b05bba1b2726a164e444c314e3f359604b58216be704bed8f2e028449cc6204 coreutils-6.10.tar.lzma 3746908
diff --git a/sys-apps/mktemp/Manifest b/sys-apps/mktemp/Manifest
index 1f9c882aef1c..10a779c878e1 100644
--- a/sys-apps/mktemp/Manifest
+++ b/sys-apps/mktemp/Manifest
@@ -6,14 +6,14 @@ MD5 d50b086073fbeed6e63cb96d3d949dde files/mktemp-1.5-build.patch 232
RMD160 241e03fa9bf59e834b58ae4f5faf6a2ccf376dbb files/mktemp-1.5-build.patch 232
SHA256 93cd28e5802eb5d4bbd4f786618a78eebfd8b133d4c7e656c73314269e02381d files/mktemp-1.5-build.patch 232
DIST mktemp-1.5.tar.gz 70529 RMD160 a2fa93592e1d362aa0882a70ea494cc45da48dab SHA1 aa001fd61d13bbf128dc58ca4dc6d83311435bae SHA256 cdd1506b5bc85697723961db525f2ff57548e5ba3977a56c110220a0ff28bf75
-EBUILD mktemp-1.5.ebuild 794 RMD160 a0c1d4d49cf4f01b787b4910b229660f8fb86dc6 SHA1 ccb771334ccacc27de09537626279ba87dc86aa3 SHA256 73f54bd82817a727d7c6f7807d0ef06132d85c502988e68fe5a70b651efe7148
-MD5 b5c6aa2987bfc5e5fabad7b484ffd115 mktemp-1.5.ebuild 794
-RMD160 a0c1d4d49cf4f01b787b4910b229660f8fb86dc6 mktemp-1.5.ebuild 794
-SHA256 73f54bd82817a727d7c6f7807d0ef06132d85c502988e68fe5a70b651efe7148 mktemp-1.5.ebuild 794
-MISC ChangeLog 1106 RMD160 3d14887c5ae53c98526cf7c0ae13987f4d2e92c5 SHA1 140943d1712849b34701b20ea62e553122e6e7eb SHA256 830c83f44f41c92283363b63be34b4109be022fc87aa92fdffeb9db0101b67ee
-MD5 7e771c391ec755e4312257b36dfeb959 ChangeLog 1106
-RMD160 3d14887c5ae53c98526cf7c0ae13987f4d2e92c5 ChangeLog 1106
-SHA256 830c83f44f41c92283363b63be34b4109be022fc87aa92fdffeb9db0101b67ee ChangeLog 1106
+EBUILD mktemp-1.5.ebuild 841 RMD160 ac10f3b7a5f929fdfcceb7da83f131e51d384abd SHA1 e362676bb297c00491c2472a6f4eb03f79bbe8ac SHA256 338ffd5dff7fdb733a8fbe25de3640575d9fdd0caafdcbbc38141921e7e9f510
+MD5 af3266245cbb2a41b5462ee946d3d0c8 mktemp-1.5.ebuild 841
+RMD160 ac10f3b7a5f929fdfcceb7da83f131e51d384abd mktemp-1.5.ebuild 841
+SHA256 338ffd5dff7fdb733a8fbe25de3640575d9fdd0caafdcbbc38141921e7e9f510 mktemp-1.5.ebuild 841
+MISC ChangeLog 1252 RMD160 edbd36d3556c2762a2f7c5335bc47de6d496e2a3 SHA1 54a198736c8c141fe9389e0fe9ca294ff76f45bd SHA256 ebbf27d6fd4a9e0c41ae2c31db3d9ed3ad38673e5c43016714a532470f69c83b
+MD5 fe2e8f413661b0290e6e8097f70010da ChangeLog 1252
+RMD160 edbd36d3556c2762a2f7c5335bc47de6d496e2a3 ChangeLog 1252
+SHA256 ebbf27d6fd4a9e0c41ae2c31db3d9ed3ad38673e5c43016714a532470f69c83b ChangeLog 1252
MISC metadata.xml 164 RMD160 f43cbec30b7074319087c9acffdb9354b17b0db3 SHA1 9c213f5803676c56439df3716be07d6692588856 SHA256 f5f2891f2a4791cd31350bb2bb572131ad7235cd0eeb124c9912c187ac10ce92
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
RMD160 f43cbec30b7074319087c9acffdb9354b17b0db3 metadata.xml 164
@@ -22,9 +22,9 @@ MD5 1e3bdeeef7d1009630df02ea86d078d5 files/digest-mktemp-1.5 229
RMD160 98c8b91ba5992a30e583cc8ff8fcafa9777981d9 files/digest-mktemp-1.5 229
SHA256 8428a92bf3b00ee2250307402c7b743e3e9417cbc0b97318f0d95db668fc9a0a files/digest-mktemp-1.5 229
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2.2 (GNU/Linux)
+Version: GnuPG v2.0.7 (GNU/Linux)
-iD8DBQFGBpJu3og80iZgVQgRAgqGAKCYPuDOG1e84yKytujhDeamfn6a2QCfQNPz
-otWAwJKQ3LwT0JpGKyVZ0Xg=
-=negi
+iD8DBQFHlsW/j9hvisErhMIRAhvWAKDaDdDlvHnLzEL6owPRE6fXSzFrLwCbBR03
+UQ6q2aIhviiAoPHuINlE6DA=
+=UOln
-----END PGP SIGNATURE-----