summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-10-09 14:23:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-10-09 14:23:21 +0000
commit0ffa420d317eeecdc3cc2e9dc6b56a5ef5de5f66 (patch)
treef1b5ab420b36841fb3ed4ddcf330fd71b0457461 /sys-auth
parentMask pam_keystore. (diff)
downloadhistorical-0ffa420d317eeecdc3cc2e9dc6b56a5ef5de5f66.tar.gz
historical-0ffa420d317eeecdc3cc2e9dc6b56a5ef5de5f66.tar.bz2
historical-0ffa420d317eeecdc3cc2e9dc6b56a5ef5de5f66.zip
Initial import, thanks to Alexander Tratsevskiy in bug #285765. Masked missing some documentation on how to actually make use of this.
Package-Manager: portage-2.2_rc44/cvs/Linux x86_64
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_keystore/ChangeLog11
-rw-r--r--sys-auth/pam_keystore/Manifest14
-rw-r--r--sys-auth/pam_keystore/metadata.xml5
-rw-r--r--sys-auth/pam_keystore/pam_keystore-0.1.3.ebuild31
4 files changed, 61 insertions, 0 deletions
diff --git a/sys-auth/pam_keystore/ChangeLog b/sys-auth/pam_keystore/ChangeLog
new file mode 100644
index 000000000000..eced655a1408
--- /dev/null
+++ b/sys-auth/pam_keystore/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-auth/pam_keystore
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_keystore/ChangeLog,v 1.1 2009/10/09 14:23:21 flameeyes Exp $
+
+*pam_keystore-0.1.3 (09 Oct 2009)
+
+ 09 Oct 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +pam_keystore-0.1.3.ebuild, +metadata.xml:
+ Initial import, thanks to Alexander Tratsevskiy in bug #285765. Masked
+ missing some documentation on how to actually make use of this.
+
diff --git a/sys-auth/pam_keystore/Manifest b/sys-auth/pam_keystore/Manifest
new file mode 100644
index 000000000000..12e568e1fdd5
--- /dev/null
+++ b/sys-auth/pam_keystore/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST pam_keystore-0.1.3.tar.bz2 5894 RMD160 4b66977d255848a449ade60fc76795abc6e716ca SHA1 8f200accba4af55b44b8a59a79cc1b562c11f0ad SHA256 edc8bafd89cc8e5a18b23ce521beaba250fcfd4a53d8c2bdab4d17b77058f493
+EBUILD pam_keystore-0.1.3.ebuild 812 RMD160 8f0f447ef291f3d9193a8337dff40f6287139648 SHA1 4d0db90c445b2362572dc1091eddabbfa4dbeca1 SHA256 2714b105895955119ff57f8b0ae486a67f690a31201a155d050bba70abcd0204
+MISC ChangeLog 494 RMD160 728dc0a9bfb42a1b1849c74bfdc08a5b01f86188 SHA1 462ce1b613a8b9d91400520ff2eab23c9f8ce5be SHA256 6da44301f1a83a00467200cb65f63de4035b05dca1b89e222973d17315b2ef9d
+MISC metadata.xml 156 RMD160 2c189dc76268bd055cf073cecc00befee4f87384 SHA1 4620c7d8101354075c5e4d489335742719bff83f SHA256 21ca0f798be096fadf091a72155c33fa62c7be911d4c900ff518e59dd4f60173
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.11 (GNU/Linux)
+
+iEYEARECAAYFAkrPR0sACgkQAiZjviIA2Xj67wCeOOWEEpnmEGHHwQRBecR/1Xy2
+Pf8AoKVdZSpsyM/1EBQcuUTN5JPaQsuj
+=HCSd
+-----END PGP SIGNATURE-----
diff --git a/sys-auth/pam_keystore/metadata.xml b/sys-auth/pam_keystore/metadata.xml
new file mode 100644
index 000000000000..81ada335fc94
--- /dev/null
+++ b/sys-auth/pam_keystore/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pam</herd>
+</pkgmetadata>
diff --git a/sys-auth/pam_keystore/pam_keystore-0.1.3.ebuild b/sys-auth/pam_keystore/pam_keystore-0.1.3.ebuild
new file mode 100644
index 000000000000..8b575ed34457
--- /dev/null
+++ b/sys-auth/pam_keystore/pam_keystore-0.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_keystore/pam_keystore-0.1.3.ebuild,v 1.1 2009/10/09 14:23:21 flameeyes Exp $
+
+inherit pam toolchain-funcs
+
+DESCRIPTION="Keeps a login and the password the user in the kernel"
+HOMEPAGE="http://www.calculate-linux.org/pam_keystore"
+SRC_URI="ftp://ftp.calculate.ru/pub/calculate/${PN}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND="virtual/pam
+ >=sys-apps/keyutils-1.1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD_D="$(tc-getCC) -shared ${LDFLAGS}" \
+ CFLAGS="-fPIC ${CFLAGS}" \
+ SHARE= \
+ || die "make failed"
+}
+
+src_install() {
+ dopammod pam_keystore.so || die
+ newdoc README README.ru || die
+}