summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-09-03 06:19:03 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-09-03 06:19:03 +0000
commit56fd6466473f9fd6af8b4cb6d9a414e7e34afa3e (patch)
tree0f54e9cfa64e844a897c73a011ec5a97caf6e6fa /sys-boot/colo/files
parentcorrect sdk download url, closes 62663 (diff)
downloadhistorical-56fd6466473f9fd6af8b4cb6d9a414e7e34afa3e.tar.gz
historical-56fd6466473f9fd6af8b4cb6d9a414e7e34afa3e.tar.bz2
historical-56fd6466473f9fd6af8b4cb6d9a414e7e34afa3e.zip
New colo revision, cleaned up older revisions, Marked 1.11 stable.
Diffstat (limited to 'sys-boot/colo/files')
-rw-r--r--sys-boot/colo/files/colo-1.4-gentoo.patch81
-rw-r--r--sys-boot/colo/files/colo-1.6-gentoo.patch36
-rw-r--r--sys-boot/colo/files/default.boot.example2
-rw-r--r--sys-boot/colo/files/default.colo25
-rw-r--r--sys-boot/colo/files/digest-colo-1.101
-rw-r--r--sys-boot/colo/files/digest-colo-1.131
-rw-r--r--sys-boot/colo/files/digest-colo-1.41
-rw-r--r--sys-boot/colo/files/digest-colo-1.61
-rw-r--r--sys-boot/colo/files/digest-colo-1.81
-rw-r--r--sys-boot/colo/files/digest-colo-1.91
-rw-r--r--sys-boot/colo/files/menu-linux.colo9
11 files changed, 35 insertions, 124 deletions
diff --git a/sys-boot/colo/files/colo-1.4-gentoo.patch b/sys-boot/colo/files/colo-1.4-gentoo.patch
deleted file mode 100644
index 2f07715d078a..000000000000
--- a/sys-boot/colo/files/colo-1.4-gentoo.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-diff -Naurp boot-loader-1.4.orig/chain/Makefile boot-loader-1.4/chain/Makefile
---- boot-loader-1.4.orig/chain/Makefile 2004-03-28 16:48:37.000000000 -0500
-+++ boot-loader-1.4/chain/Makefile 2004-04-03 03:06:52.337184944 -0500
-@@ -12,7 +12,7 @@ OBJS= chain.o\
- serial.o\
- start.o\
-
--MIPSFLAGS= -mno-abicalls -fno-pic -EL -mips2 -mcpu=r5000
-+MIPSFLAGS= -mno-abicalls -fno-pic -G 0 -mips4 -mabi=32 -mtune=r5000
-
- CFLAGS= -Wall -Wstrict-prototypes -fomit-frame-pointer -O2 -fno-builtin -nostdlib $(MIPSFLAGS)
- ASFLAGS= $(MIPSFLAGS)
-diff -Naurp boot-loader-1.4.orig/chain/src/start.S boot-loader-1.4/chain/src/start.S
---- boot-loader-1.4.orig/chain/src/start.S 2004-03-28 16:25:38.000000000 -0500
-+++ boot-loader-1.4/chain/src/start.S 2004-04-03 03:37:01.898089872 -0500
-@@ -18,7 +18,7 @@
-
- _start: la sp, __stack - 16
- lui gp, %hi(_gp)
-- bal chain
-+ jal chain
- addiu gp, %lo(_gp)
-
- b .
-diff -Naurp boot-loader-1.4.orig/stage1/Makefile boot-loader-1.4/stage1/Makefile
---- boot-loader-1.4.orig/stage1/Makefile 2004-03-28 11:06:07.000000000 -0500
-+++ boot-loader-1.4/stage1/Makefile 2004-04-03 03:07:24.047364264 -0500
-@@ -15,7 +15,7 @@ OBJS= init.o\
- fast.o\
- start.o\
-
--MIPSFLAGS= -mno-abicalls -fno-pic -EL -mips2 -mcpu=r5000
-+MIPSFLAGS= -mno-abicalls -fno-pic -G 0 -mips4 -mabi=32 -mtune=r5000
-
- CFLAGS= -Wall -Wstrict-prototypes -fomit-frame-pointer -O2 -fno-builtin -nostdlib $(MIPSFLAGS)
- ASFLAGS= $(MIPSFLAGS)
-diff -Naurp boot-loader-1.4.orig/stage1/src/start.S boot-loader-1.4/stage1/src/start.S
---- boot-loader-1.4.orig/stage1/src/start.S 2004-03-28 11:06:07.000000000 -0500
-+++ boot-loader-1.4/stage1/src/start.S 2004-04-03 03:35:24.893836760 -0500
-@@ -16,16 +16,16 @@
-
- la sp, __stack - 16
- lui gp, %hi(_gp)
-- bal cpu_init
-+ jal cpu_init
- addiu gp, %lo(_gp)
-
-- bal stage1
-+ jal stage1
- nop
-
-- bal loader
-+ jal loader
- subu sp, v0, 16
-
-- b fatal
-+ j fatal
- nop
-
- .org 0x200
-@@ -36,7 +36,7 @@
-
- 1: la sp, __stack - 16
- lui gp, %hi(_gp)
-- b exception
-+ j exception
- addiu gp, %lo(_gp)
-
- .org 0x280
-diff -Naurp boot-loader-1.4.orig/stage2/Makefile boot-loader-1.4/stage2/Makefile
---- boot-loader-1.4.orig/stage2/Makefile 2004-03-28 14:30:52.000000000 -0500
-+++ boot-loader-1.4/stage2/Makefile 2004-04-03 03:07:39.687986528 -0500
-@@ -32,7 +32,7 @@ OBJS= main.o\
- launch.o\
- start.o\
-
--MIPSFLAGS= -mno-abicalls -fno-pic -EL -mips2 -mcpu=r5000
-+MIPSFLAGS= -mno-abicalls -fno-pic -G 0 -mips4 -mabi=32 -mtune=r5000
-
- CFLAGS= -Wall -Wstrict-prototypes -fomit-frame-pointer -O2 -fno-builtin -nostdlib $(MIPSFLAGS)
- ASFLAGS= $(MIPSFLAGS)
diff --git a/sys-boot/colo/files/colo-1.6-gentoo.patch b/sys-boot/colo/files/colo-1.6-gentoo.patch
deleted file mode 100644
index ee1df65e4809..000000000000
--- a/sys-boot/colo/files/colo-1.6-gentoo.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- INSTALL.orig 2004-04-21 01:18:46.000000000 -0400
-+++ INSTALL 2004-04-21 01:20:09.000000000 -0400
-@@ -8,11 +8,11 @@ possible to use the original Cobalt boot
- loader - chain mode. This does away with the risk of trashing your unit,
- though it extends the time required to boot.
-
--Just copy 'chain.bin' to your boot directory, rename into 'vmlinux' and gzip
-+Just copy 'colo-chain.elf' to your boot directory, rename into 'vmlinux' and gzip
- it to 'vmlinux.gz'
-
- cp -f /boot/vmlinux.gz /boot/backup.gz
-- cp chain.bin /boot/vmlinux
-+ cp colo-chain.elf /boot/vmlinux
- gzip -9 /boot/vmlinux
- reboot
-
-@@ -82,7 +82,7 @@ Step 4 - install the new boot loader
- Write the new boot loader into the Flash. Don't interrupt the programming
- process or you will probably land up with a unit that doesn't boot!
-
-- flash-tool -w boot.bin
-+ flash-tool -w colo-rom-image.bin
-
- If for any reason programming fails you might just be able to write the
- original boot loader back into the Flash
---- README.shell.orig 2004-04-21 01:23:51.000000000 -0400
-+++ README.shell 2004-04-21 01:24:02.000000000 -0400
-@@ -11,7 +11,7 @@ If no SPACE character is detected the bo
- using the default script :-
-
- mount
-- -script /boot/default.boot
-+ -script /boot/default.colo
- load /boot/vmlinux.gz
- execute
-
diff --git a/sys-boot/colo/files/default.boot.example b/sys-boot/colo/files/default.boot.example
deleted file mode 100644
index 4419cf0775fc..000000000000
--- a/sys-boot/colo/files/default.boot.example
+++ /dev/null
@@ -1,2 +0,0 @@
-mount
-ls
diff --git a/sys-boot/colo/files/default.colo b/sys-boot/colo/files/default.colo
new file mode 100644
index 000000000000..676a038388d1
--- /dev/null
+++ b/sys-boot/colo/files/default.colo
@@ -0,0 +1,25 @@
+#:CoLo:#
+
+# Turn on the serial port
+-serial on
+
+# Generate a menu to select the appropriate kernel image on the LCD Screen
+# Format is:
+# menu "<message>" <time out> <menu text 1> <menu option 1> <menu text 2> <menu option 2> ...
+#
+# Where <menu text> is the item displayed, and <menu option> is the item
+# that the text corresponds to. When a menu item is selected, the env variable
+# {menu-option} gets set to the value of <menu option>.
+#
+# Please note, no sample script has been provided for a backup script (linuxold).
+# You will need to create one yourself if you require this.
+menu "colo-@COLOVER@" 100 Linux linux Linux-OLD linuxold
+
+# Loads the corresponding script depending on the selected value from the menu
+-load /boot/menu-{menu-option}.colo
+-script
+
+# Incase of failure, return to the menu
+load /boot/default.colo
+script
+
diff --git a/sys-boot/colo/files/digest-colo-1.10 b/sys-boot/colo/files/digest-colo-1.10
deleted file mode 100644
index d7b975652691..000000000000
--- a/sys-boot/colo/files/digest-colo-1.10
+++ /dev/null
@@ -1 +0,0 @@
-MD5 6e2ba1d2826fb51ce18cab3bc29aee91 colo-1.10.tar.gz 211446
diff --git a/sys-boot/colo/files/digest-colo-1.13 b/sys-boot/colo/files/digest-colo-1.13
new file mode 100644
index 000000000000..35fbf6d33823
--- /dev/null
+++ b/sys-boot/colo/files/digest-colo-1.13
@@ -0,0 +1 @@
+MD5 7ca79ea71d1d19b5699d5455752a6293 colo-1.13.tar.gz 225232
diff --git a/sys-boot/colo/files/digest-colo-1.4 b/sys-boot/colo/files/digest-colo-1.4
deleted file mode 100644
index e2f5d9426f82..000000000000
--- a/sys-boot/colo/files/digest-colo-1.4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 51e908ca404b68e1346186c0de479c9d release-1.4.tar.gz 139761
diff --git a/sys-boot/colo/files/digest-colo-1.6 b/sys-boot/colo/files/digest-colo-1.6
deleted file mode 100644
index 4ff83e95e205..000000000000
--- a/sys-boot/colo/files/digest-colo-1.6
+++ /dev/null
@@ -1 +0,0 @@
-MD5 20cdca3fa4045b85869137425fed0577 colo-1.6.tar.gz 146206
diff --git a/sys-boot/colo/files/digest-colo-1.8 b/sys-boot/colo/files/digest-colo-1.8
deleted file mode 100644
index 74fc2ec7cf88..000000000000
--- a/sys-boot/colo/files/digest-colo-1.8
+++ /dev/null
@@ -1 +0,0 @@
-MD5 db06ba7022c450b0e1508c65edbe8b0f colo-1.8.tar.gz 179843
diff --git a/sys-boot/colo/files/digest-colo-1.9 b/sys-boot/colo/files/digest-colo-1.9
deleted file mode 100644
index 3bd45e092fee..000000000000
--- a/sys-boot/colo/files/digest-colo-1.9
+++ /dev/null
@@ -1 +0,0 @@
-MD5 b1394a8a4b981f00976d0e996cfb59e8 colo-1.9.tar.gz 192492
diff --git a/sys-boot/colo/files/menu-linux.colo b/sys-boot/colo/files/menu-linux.colo
new file mode 100644
index 000000000000..0c0156b4d65e
--- /dev/null
+++ b/sys-boot/colo/files/menu-linux.colo
@@ -0,0 +1,9 @@
+#:CoLo:#
+
+# Loads the kernel into memory (and unzips if needed)
+# Makes sure this points at the correct kernel image
+load /boot/vmlinuz.gz
+
+# Executes the loaded image with the specified command args
+# Change these args to suit your purposes
+execute root=/dev/hda5 console=ttyS0,115200