summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-01-21 20:41:55 +0000
committerAron Griffis <agriffis@gentoo.org>2004-01-21 20:41:55 +0000
commitb77ac80284f35ed67900c3aeb690482177c07eca (patch)
treef53ffe5ddd15c836d5a3af428a5b93656e56745f /sys-boot/efibootmgr
parentadd efibootmgr (diff)
downloadhistorical-b77ac80284f35ed67900c3aeb690482177c07eca.tar.gz
historical-b77ac80284f35ed67900c3aeb690482177c07eca.tar.bz2
historical-b77ac80284f35ed67900c3aeb690482177c07eca.zip
add efibootmgr
Diffstat (limited to 'sys-boot/efibootmgr')
-rw-r--r--sys-boot/efibootmgr/Manifest4
-rw-r--r--sys-boot/efibootmgr/efibootmgr-0.4.2.ebuild39
-rw-r--r--sys-boot/efibootmgr/files/digest-efibootmgr-0.4.21
-rw-r--r--sys-boot/efibootmgr/files/efibootmgr-0.4.1-makefile.patch10
-rw-r--r--sys-boot/efibootmgr/metadata.xml5
5 files changed, 58 insertions, 1 deletions
diff --git a/sys-boot/efibootmgr/Manifest b/sys-boot/efibootmgr/Manifest
index 0523a11751f4..f01caf70f9f9 100644
--- a/sys-boot/efibootmgr/Manifest
+++ b/sys-boot/efibootmgr/Manifest
@@ -1,3 +1,5 @@
-MD5 cff788a1e8ca8e1ab6038d0f26aafdaf efibootmgr-0.4.2.ebuild 1269
+MD5 8ff6c90ea70f119ffccd91e4be6f500c efibootmgr-0.4.2.ebuild 1309
+MD5 6ea59989752e00a98ca5545631433df0 metadata.xml 164
+MD5 1f52c25a1995c8132cb38e0c63ed8ce3 ChangeLog 480
MD5 8234d5c715dd59b7b135a7372b626de5 files/digest-efibootmgr-0.4.2 67
MD5 52674d9178b4c50989bfc0724bdd879d files/efibootmgr-0.4.1-makefile.patch 548
diff --git a/sys-boot/efibootmgr/efibootmgr-0.4.2.ebuild b/sys-boot/efibootmgr/efibootmgr-0.4.2.ebuild
new file mode 100644
index 000000000000..4160cbf0dcb0
--- /dev/null
+++ b/sys-boot/efibootmgr/efibootmgr-0.4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/efibootmgr-0.4.2.ebuild,v 1.1 2004/01/21 20:41:47 agriffis Exp $
+
+DESCRIPTION="Interact with the EFI Boot Manager on IA-64 Systems"
+HOMEPAGE="http://developer.intel.com/technology/efi"
+
+# This is efibootmgr, a Linux user-space application to modify the
+# Intel Extensible Firmware Interface (EFI) Boot Manager. This
+# application can create and destroy boot entries, change the boot
+# order, change the next running boot option, and more.
+#
+# Note: efibootmgr requires that the kernel module efivars be loaded
+# prior to use. `modprobe efivars` should do the trick.
+
+SRC_URI="http://domsch.com/linux/ia64/${PN}/${P}.tar.gz"
+KEYWORDS="~ia64"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="virtual/glibc" # don't think there's anything else
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A} && cd ${S} || die "failed to unpack"
+ epatch ${FILESDIR}/efibootmgr-0.4.1-makefile.patch || die "epatch failed"
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ mkdir -p ${D}/usr/sbin
+ install -m755 src/efibootmgr/efibootmgr ${D}/usr/sbin
+ doman src/man/man8/efibootmgr.8
+ dodoc AUTHORS COPYING README doc/ChangeLog doc/TODO
+}
diff --git a/sys-boot/efibootmgr/files/digest-efibootmgr-0.4.2 b/sys-boot/efibootmgr/files/digest-efibootmgr-0.4.2
new file mode 100644
index 000000000000..fde5c916ba0b
--- /dev/null
+++ b/sys-boot/efibootmgr/files/digest-efibootmgr-0.4.2
@@ -0,0 +1 @@
+MD5 f89444e781ef8da1fb53949471f47172 efibootmgr-0.4.2.tar.gz 51608
diff --git a/sys-boot/efibootmgr/files/efibootmgr-0.4.1-makefile.patch b/sys-boot/efibootmgr/files/efibootmgr-0.4.1-makefile.patch
new file mode 100644
index 000000000000..4a9b0f9c1c18
--- /dev/null
+++ b/sys-boot/efibootmgr/files/efibootmgr-0.4.1-makefile.patch
@@ -0,0 +1,10 @@
+--- efibootmgr-0.4.1/Makefile.makefile 2002-10-22 22:45:30.000000000 +0200
++++ efibootmgr-0.4.1/Makefile 2003-05-26 15:09:58.000000000 +0200
+@@ -9,6 +9,7 @@
+ RELEASE_STRING := $(RELEASE_NAME)-$(RELEASE_MAJOR).$(RELEASE_MINOR).$(RELEASE_SUBLEVEL)$(RELEASE_EXTRALEVEL)
+
+ CFLAGS += -DEFIBOOTMGR_VERSION=\"$(RELEASE_MAJOR).$(RELEASE_MINOR).$(RELEASE_SUBLEVEL)$(RELEASE_EXTRALEVEL)\" -Wall
++ CFLAGS += $(shell if $(CC) -fno-merge-constants -S -o /dev/null -xc /dev/null >/dev/null 2>&1; then echo "-fno-merge-constants"; fi)
+
+ MODULES := src
+
diff --git a/sys-boot/efibootmgr/metadata.xml b/sys-boot/efibootmgr/metadata.xml
new file mode 100644
index 000000000000..3f1e1b97e11e
--- /dev/null
+++ b/sys-boot/efibootmgr/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ia64-kernel</herd>
+</pkgmetadata>