summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-01-30 20:48:44 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-01-30 20:48:44 +0000
commit04a763925ba95a4737e174f1f1f9710937060e22 (patch)
tree2bb17b5c0086cd66d07b4ea0f1717638b474cce9 /sys-boot/silo
parentUpdated dtd patch to fix multi-select segfault. Removed alsa debug messages ... (diff)
downloadhistorical-04a763925ba95a4737e174f1f1f9710937060e22.tar.gz
historical-04a763925ba95a4737e174f1f1f9710937060e22.tar.bz2
historical-04a763925ba95a4737e174f1f1f9710937060e22.zip
bump, includes sparc32 fixes
Diffstat (limited to 'sys-boot/silo')
-rw-r--r--sys-boot/silo/ChangeLog7
-rw-r--r--sys-boot/silo/Manifest4
-rw-r--r--sys-boot/silo/files/digest-silo-1.4.41
-rw-r--r--sys-boot/silo/silo-1.4.4.ebuild39
4 files changed, 49 insertions, 2 deletions
diff --git a/sys-boot/silo/ChangeLog b/sys-boot/silo/ChangeLog
index 2dcadff858bf..f87bab7c8f39 100644
--- a/sys-boot/silo/ChangeLog
+++ b/sys-boot/silo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/silo
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.6 2004/01/30 18:59:05 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.7 2004/01/30 20:48:44 ciaranm Exp $
+
+*silo-1.4.4 (30 Jan 2004)
+
+ 30 Jan 2004; Ciaran McCreesh <ciaranm@gentoo.org> silo-1.4.4.ebuild:
+ Version bump, should now work on sparc32. Still in package.mask for the minute.
*silo-1.4.3 (30 Jan 2004)
diff --git a/sys-boot/silo/Manifest b/sys-boot/silo/Manifest
index 25b5708921dc..3728dbe81967 100644
--- a/sys-boot/silo/Manifest
+++ b/sys-boot/silo/Manifest
@@ -1,13 +1,15 @@
MD5 605de336c2b411b96a643445cf7cbc5b silo-1.3.1-r1.ebuild 1105
MD5 af543873ccdc95dd90b333ef9c9bf7cc silo-1.3.2.ebuild 954
-MD5 d3178332d78d1cefeb5f534f92754aec ChangeLog 3061
+MD5 2a2aa666c6fbd2909a69d2b88681ad23 ChangeLog 3242
MD5 e467e2b027d7232497438cffb31d7085 silo-1.4.3.ebuild 1105
MD5 27d21289a709ef45367d3ac6de4eb6d1 silo-1.3.1.ebuild 953
MD5 64e92dc3614963db8a397f670749b6cf metadata.xml 369
MD5 75c27d73b0dfa520a48eec1939448209 silo-1.3.2-r1.ebuild 1106
+MD5 ff2caa60802dfd144dfdc8309b60dbac silo-1.4.4.ebuild 1105
MD5 232ca232d4bb30eecf5cc52346d715d0 files/digest-silo-1.4.3 62
MD5 d64a6c9a2051c74be817cf525ead4db5 files/digest-silo-1.3.1-r1 62
MD5 fb91d749bdbdaee58c78d3da057f48fd files/silo_1.2.5-1.diff 20854
MD5 ba569526e64ff4aae31e2eb37150f62d files/digest-silo-1.3.2-r1 62
MD5 ba569526e64ff4aae31e2eb37150f62d files/digest-silo-1.3.2 62
MD5 d64a6c9a2051c74be817cf525ead4db5 files/digest-silo-1.3.1 62
+MD5 34fafa5d363e6bf1bf3875cf8834fb3f files/digest-silo-1.4.4 62
diff --git a/sys-boot/silo/files/digest-silo-1.4.4 b/sys-boot/silo/files/digest-silo-1.4.4
new file mode 100644
index 000000000000..9c5268f64df1
--- /dev/null
+++ b/sys-boot/silo/files/digest-silo-1.4.4
@@ -0,0 +1 @@
+MD5 dbbaecbdbe1949c14369a5fb5c08881b silo-1.4.4.tar.gz 176828
diff --git a/sys-boot/silo/silo-1.4.4.ebuild b/sys-boot/silo/silo-1.4.4.ebuild
new file mode 100644
index 000000000000..fc1b19a5d4f3
--- /dev/null
+++ b/sys-boot/silo/silo-1.4.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.4.ebuild,v 1.1 2004/01/30 20:48:44 ciaranm Exp $
+
+inherit mount-boot
+
+S=${WORKDIR}/${P}
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="http://www.sparc-boot.org/pub/silo/${P}.tar.gz"
+HOMEPAGE="http://www.sparc-boot.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* ~sparc"
+
+PROVIDE="virtual/bootloader"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-apps/sparc-utils"
+
+src_compile() {
+ make ${MAKEOPTS} || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc COPYING ChangeLog first-isofs/README.SILO_ISOFS docs/README*
+
+ # Fix maketilo manpage
+ rm ${D}/usr/share/man/man1/maketilo.1
+ dosym /usr/share/man/man1/tilo.1 /usr/share/man/man1/maketilo.1
+}
+
+pkg_postinst() {
+ ewarn "NOTE: If this is an upgrade to an existing SILO install,"
+ ewarn " you will need to re-run silo as the /boot/second.b"
+ ewarn " file has changed, else the system will fail to load"
+ ewarn " SILO at the next boot."
+}