summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-17 01:25:28 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-17 01:25:28 +0000
commit0ccab3293ceb40d3b85d88e9c1516b06759375f3 (patch)
tree12b5a4d7005c4db168fa28521ad998cc14a408e1 /sys-boot
parentDetect genkernel initramfs files #300710 by Vincent-Xavier JUMEL. (diff)
downloadhistorical-0ccab3293ceb40d3b85d88e9c1516b06759375f3.tar.gz
historical-0ccab3293ceb40d3b85d88e9c1516b06759375f3.tar.bz2
historical-0ccab3293ceb40d3b85d88e9c1516b06759375f3.zip
Workaround eautomake weirdness #296013.
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/grub-1.97.1.ebuild8
-rw-r--r--sys-boot/grub/grub-9999.ebuild8
3 files changed, 17 insertions, 5 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 6ca9cd15bfdc..4c442b084240 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.130 2010/01/17 01:24:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.131 2010/01/17 01:25:28 vapier Exp $
+
+ 17 Jan 2010; Mike Frysinger <vapier@gentoo.org> grub-1.97.1.ebuild,
+ grub-9999.ebuild:
+ Workaround eautomake weirdness #296013.
17 Jan 2010; Mike Frysinger <vapier@gentoo.org>
files/grub-1.96-genkernel.patch:
diff --git a/sys-boot/grub/grub-1.97.1.ebuild b/sys-boot/grub/grub-1.97.1.ebuild
index a5f3299c314e..e4fd26fd855d 100644
--- a/sys-boot/grub/grub-1.97.1.ebuild
+++ b/sys-boot/grub/grub-1.97.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.97.1.ebuild,v 1.3 2010/01/10 06:13:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.97.1.ebuild,v 1.4 2010/01/17 01:25:28 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -42,8 +42,12 @@ src_unpack() {
epatch_user
# autogen.sh does more than just run autotools
+ # need to eautomake due to weirdness #296013
if [[ ${PV} == "9999" ]] ; then
- sed -i -e 's:^auto:eauto:' autogen.sh
+ sed -i \
+ -e '/^\(auto\|ac\)/s:^:e:' \
+ -e "s:^eautomake:`which automake`:" \
+ autogen.sh
(. ./autogen.sh) || die
fi
}
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 01f53d768a76..241133ce3568 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.18 2010/01/10 06:13:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.19 2010/01/17 01:25:28 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -42,8 +42,12 @@ src_unpack() {
epatch_user
# autogen.sh does more than just run autotools
+ # need to eautomake due to weirdness #296013
if [[ ${PV} == "9999" ]] ; then
- sed -i -e '/^\(auto\|ac\)/s:^:e:' autogen.sh
+ sed -i \
+ -e '/^\(auto\|ac\)/s:^:e:' \
+ -e "s:^eautomake:`which automake`:" \
+ autogen.sh
(. ./autogen.sh) || die
fi
}