summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2008-03-17 16:24:35 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2008-03-17 16:24:35 +0000
commit2a1107817eeb15a65b4e266fd69edca8f77c57fc (patch)
treee35eb2b8b08037c958bbe1bb979c6b8ed471b5c5 /sys-cluster/cman-lib
parentfixed contrib path (diff)
downloadhistorical-2a1107817eeb15a65b4e266fd69edca8f77c57fc.tar.gz
historical-2a1107817eeb15a65b4e266fd69edca8f77c57fc.tar.bz2
historical-2a1107817eeb15a65b4e266fd69edca8f77c57fc.zip
Initial Import.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'sys-cluster/cman-lib')
-rw-r--r--sys-cluster/cman-lib/ChangeLog10
-rw-r--r--sys-cluster/cman-lib/Manifest15
-rw-r--r--sys-cluster/cman-lib/cman-lib-2.02.00.ebuild53
-rw-r--r--sys-cluster/cman-lib/files/cman-lib-2.02.00-include.patch20
-rw-r--r--sys-cluster/cman-lib/metadata.xml8
5 files changed, 106 insertions, 0 deletions
diff --git a/sys-cluster/cman-lib/ChangeLog b/sys-cluster/cman-lib/ChangeLog
new file mode 100644
index 000000000000..a0345140fe26
--- /dev/null
+++ b/sys-cluster/cman-lib/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-cluster/cman-lib
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cman-lib/ChangeLog,v 1.1 2008/03/17 16:24:34 xmerlin Exp $
+
+*cman-lib-2.02.00 (17 Mar 2008)
+
+ 17 Mar 2008; Christian Zoffoli <xmerlin@gentoo.org>
+ +files/cman-lib-2.02.00-include.patch, +cman-lib-2.02.00.ebuild:
+ Initial Import
+
diff --git a/sys-cluster/cman-lib/Manifest b/sys-cluster/cman-lib/Manifest
new file mode 100644
index 000000000000..c084c79a1557
--- /dev/null
+++ b/sys-cluster/cman-lib/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX cman-lib-2.02.00-include.patch 458 RMD160 950181252a82b01050101451d3880fdba448e4cb SHA1 f801463bc66dbe8c1c6e623cd29de22829994c7e SHA256 ee133373a88e6bfe03504d9745124f8642407f911dd2efe7299d1bb096159324
+DIST cluster-2.02.00.tar.gz 8316680 RMD160 3d054699b91f57d8b07d7013dd718a7662d712aa SHA1 8471618222882427ca395f098695c33d2466559c SHA256 c68a62b49780a59dcf075e57fc2aac4524dd27e63ad80c8a2f1313307bca9498
+EBUILD cman-lib-2.02.00.ebuild 1290 RMD160 ca214098d3c20b6b19405aa4135ce7b6257ce7c9 SHA1 8fe4f206f2e6dbeb717c5d85dd66fe7c839b7bd5 SHA256 b2175046d7fff48ae67e26b29f9de5ac151aa4cb4fcc869273d9a21d6e917555
+MISC ChangeLog 386 RMD160 b6eb33151a4187d89bc3de91a6578938974e57a4 SHA1 b68f0c211bcaa37ffb6ba5fcb27bde5b7a3c6adb SHA256 70bff53425294154c7b72faaacd0d3041e698a58ad65b302b14f26daa11db6de
+MISC metadata.xml 229 RMD160 4dcf17b88c5f4db2e817f473f3e8269b0bff2e6e SHA1 e6315be43241c55bdc0d12a42fa05632c5ff9b79 SHA256 49e13d2d49bef7298e3bb665ebeceeff9b0880fae5ff639cb8405993504f244f
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.7 (GNU/Linux)
+
+iD8DBQFH3ptKgMUyd/cdjWsRAhbBAJ9XLBxWcOUVL8q6b9NdE316BP5yLQCfVVLU
+TrUDjp2oHA+RbJ0BlP8lpxA=
+=UGCf
+-----END PGP SIGNATURE-----
diff --git a/sys-cluster/cman-lib/cman-lib-2.02.00.ebuild b/sys-cluster/cman-lib/cman-lib-2.02.00.ebuild
new file mode 100644
index 000000000000..e43251195974
--- /dev/null
+++ b/sys-cluster/cman-lib/cman-lib-2.02.00.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cman-lib/cman-lib-2.02.00.ebuild,v 1.1 2008/03/17 16:24:34 xmerlin Exp $
+
+inherit eutils versionator
+
+CLUSTER_RELEASE="${PV}"
+MY_P="cluster-${CLUSTER_RELEASE}"
+
+MAJ_PV="$(get_major_version)"
+MIN_PV="$(get_version_component_range 2).$(get_version_component_range 3)"
+
+DESCRIPTION="A library for cluster management common to the various pieces of Cluster Suite."
+HOMEPAGE="http://sources.redhat.com/cluster/"
+SRC_URI="ftp://sources.redhat.com/pub/cluster/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!sys-cluster/cman-headers
+ !sys-cluster/cman-kernel
+ !=sys-cluster/cman-1*
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/${PN/-//}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-include.patch || die
+}
+
+src_compile() {
+ (cd "${WORKDIR}"/${MY_P};
+ ./configure \
+ --cc=$(tc-getCC) \
+ --cflags="-Wall" \
+ --disable_kernel_check \
+ --release_major="$MAJ_PV" \
+ --release_minor="$MIN_PV" \
+ ) || die "configure problem"
+
+ emake clean || die "clean problem"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install problem"
+}
diff --git a/sys-cluster/cman-lib/files/cman-lib-2.02.00-include.patch b/sys-cluster/cman-lib/files/cman-lib-2.02.00-include.patch
new file mode 100644
index 000000000000..9dc8de388904
--- /dev/null
+++ b/sys-cluster/cman-lib/files/cman-lib-2.02.00-include.patch
@@ -0,0 +1,20 @@
+--- cluster-2.02.00/cman/lib/Makefile.orig 2008-02-26 15:37:43.000000000 +0000
++++ cluster-2.02.00/cman/lib/Makefile 2008-03-16 15:08:59.000000000 +0000
+@@ -13,6 +13,8 @@
+
+ TARGET= libcman
+
++include ../../make/defines.mk
++
+ LIBDIRT=$(TARGET).a \
+ $(TARGET).so.$(RELEASE_MAJOR).$(RELEASE_MINOR)
+
+@@ -21,8 +23,6 @@
+
+ INCDIRT=$(TARGET).h
+
+-include ../../make/defines.mk
+-
+ SHAREDLIB=$(TARGET).so.${RELEASE_MAJOR}.${RELEASE_MINOR}
+ STATICLIB=$(TARGET).a
+
diff --git a/sys-cluster/cman-lib/metadata.xml b/sys-cluster/cman-lib/metadata.xml
new file mode 100644
index 000000000000..b2c73e8f3872
--- /dev/null
+++ b/sys-cluster/cman-lib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ha-cluster</herd>
+<maintainer>
+ <email>ha-cluster@gentoo.org</email>
+</maintainer>
+</pkgmetadata>