summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2005-01-27 14:36:17 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2005-01-27 14:36:17 +0000
commitcb76403a38a3da98fe306fe9a70c6bd3d29258d1 (patch)
tree5758db426ead61d720007394359f2b74e1b8ff97 /sys-cluster/cman
parentRevision bump; updated gentooisms patch that includes support for gentoo-{con... (diff)
downloadhistorical-cb76403a38a3da98fe306fe9a70c6bd3d29258d1.tar.gz
historical-cb76403a38a3da98fe306fe9a70c6bd3d29258d1.tar.bz2
historical-cb76403a38a3da98fe306fe9a70c6bd3d29258d1.zip
better kernel sources detection handling
Diffstat (limited to 'sys-cluster/cman')
-rw-r--r--sys-cluster/cman/ChangeLog7
-rw-r--r--sys-cluster/cman/cman-1.0_pre3.ebuild9
2 files changed, 12 insertions, 4 deletions
diff --git a/sys-cluster/cman/ChangeLog b/sys-cluster/cman/ChangeLog
index 3ca789a19c69..5acd25aa5506 100644
--- a/sys-cluster/cman/ChangeLog
+++ b/sys-cluster/cman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/cman
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cman/ChangeLog,v 1.4 2005/01/27 04:37:56 xmerlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cman/ChangeLog,v 1.5 2005/01/27 14:36:17 xmerlin Exp $
+
+*cman-1.0_pre3 (27 Jan 2005)
+
+ 27 Jan 2005; Christian Zoffoli <xmerlin@gentoo.org> cman-1.0_pre3.ebuild:
+ better kernel sources detection handling
27 Jan 2005; Christian Zoffoli <xmerlin@gentoo.org> :
new in portage
diff --git a/sys-cluster/cman/cman-1.0_pre3.ebuild b/sys-cluster/cman/cman-1.0_pre3.ebuild
index 9297cfada352..ac2b3ea0326b 100644
--- a/sys-cluster/cman/cman-1.0_pre3.ebuild
+++ b/sys-cluster/cman/cman-1.0_pre3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cman/cman-1.0_pre3.ebuild,v 1.1 2005/01/27 04:37:56 xmerlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cman/cman-1.0_pre3.ebuild,v 1.2 2005/01/27 14:36:17 xmerlin Exp $
-inherit eutils
+inherit eutils linux-mod
MY_PV="${PV/_/-}"
MY_P="${PN}-${MY_PV}"
@@ -25,7 +25,10 @@ RDEPEND="virtual/libc"
S="${WORKDIR}/${MY_P}"
src_compile() {
- ./configure --kernel_src=/usr/src/linux || die
+ check_KV
+ set_arch_to_kernel
+
+ ./configure --kernel_src=${KERNEL_DIR} || die
emake || die
}