summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-27 15:57:38 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-27 15:57:38 +0000
commitd5c615320b1398793521743f33faace7978261a3 (patch)
treef3cafc554092e23438d8039f1de860198afccd8a /sys-cluster/hpl/hpl-2.0-r1.ebuild
parentAdd support for mod_proxy_fcgi; work by Dan Kozlowski rediffed by Jaco Kroon.... (diff)
downloadhistorical-d5c615320b1398793521743f33faace7978261a3.tar.gz
historical-d5c615320b1398793521743f33faace7978261a3.tar.bz2
historical-d5c615320b1398793521743f33faace7978261a3.zip
sys-cluster/hpl: Add missing dep on virtual/pkgconfig; use pc config to detect blas/lapack
Package-Manager: portage-2.2.0_alpha163/cvs/Linux x86_64 Manifest-Sign-Key: 0x70EB7916
Diffstat (limited to 'sys-cluster/hpl/hpl-2.0-r1.ebuild')
-rw-r--r--sys-cluster/hpl/hpl-2.0-r1.ebuild30
1 files changed, 19 insertions, 11 deletions
diff --git a/sys-cluster/hpl/hpl-2.0-r1.ebuild b/sys-cluster/hpl/hpl-2.0-r1.ebuild
index 315555ab3cc3..f50d003120be 100644
--- a/sys-cluster/hpl/hpl-2.0-r1.ebuild
+++ b/sys-cluster/hpl/hpl-2.0-r1.ebuild
@@ -1,32 +1,40 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/hpl-2.0-r1.ebuild,v 1.2 2011/02/01 21:44:39 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/hpl-2.0-r1.ebuild,v 1.3 2013/02/27 15:57:37 jlec Exp $
EAPI=4
-inherit eutils
+
+inherit eutils multilib
DESCRIPTION="A Portable Implementation of the High-Performance Linpack Benchmark for Distributed-Memory Computers"
HOMEPAGE="http://www.netlib.org/benchmark/hpl/"
SRC_URI="http://www.netlib.org/benchmark/hpl/hpl-${PV}.tar.gz"
-LICENSE="HPL"
+
SLOT="0"
+LICENSE="HPL"
KEYWORDS="~x86 ~amd64"
-
IUSE="doc"
-DEPEND="virtual/mpi
+
+RDEPEND="
virtual/blas
- virtual/lapack"
-RDEPEND="${DEPEND}"
+ virtual/lapack
+ virtual/mpi"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
src_prepare() {
- cp setup/Make.Linux_PII_FBLAS Make.gentoo_hpl_fblas_x86
+ local a=""
+ local locallib="${EPREFIX}/usr/$(get_libdir)/lib"
+ local localblas="$(for i in $($(tc-getPKG_CONFIG) --libs-only-l blas lapack);do a="${a} ${i/-l/${locallib}}.so "; done; echo ${a})"
+
+ cp setup/Make.Linux_PII_FBLAS Make.gentoo_hpl_fblas_x86 || die
sed -i \
-e "/^TOPdir/s,= .*,= ${S}," \
-e '/^HPL_OPTS\>/s,=,= -DHPL_DETAILED_TIMING -DHPL_COPY_L,' \
-e '/^ARCH\>/s,= .*,= gentoo_hpl_fblas_x86,' \
-e '/^MPdir\>/s,= .*,=,' \
-e '/^MPlib\>/s,= .*,=,' \
- -e "/^LAlib\>/s,= .*,= /usr/$(get_libdir)/libblas.so /usr/$(get_libdir)/liblapack.so," \
+ -e "/^LAlib\>/s,= .*,= ${localblas}," \
-e '/^LINKER\>/s,= .*,= mpicc,' \
-e '/^CC\>/s,= .*,= mpicc,' \
-e "/^LINKFLAGS\>/s|= .*|= ${LDFLAGS}|" \
@@ -34,7 +42,7 @@ src_prepare() {
}
src_compile() {
- # parallel make failure — bug #321539
+ # parallel make failure bug #321539
HOME=${WORKDIR} emake -j1 arch=gentoo_hpl_fblas_x86
}