summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-06-24 16:30:13 +0000
committerDavid Holm <dholm@gentoo.org>2004-06-24 16:30:13 +0000
commitf594aec2b64cfb4f9fde6cd75658bdb1d335e6b7 (patch)
tree4b68e2bd0b68f984705783f0087b7af58c317a0c /sys-cluster/xgridagent/xgridagent-1.0.ebuild
parentQA - fix use invocation (diff)
downloadhistorical-f594aec2b64cfb4f9fde6cd75658bdb1d335e6b7.tar.gz
historical-f594aec2b64cfb4f9fde6cd75658bdb1d335e6b7.tar.bz2
historical-f594aec2b64cfb4f9fde6cd75658bdb1d335e6b7.zip
Initial import
Diffstat (limited to 'sys-cluster/xgridagent/xgridagent-1.0.ebuild')
-rw-r--r--sys-cluster/xgridagent/xgridagent-1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-cluster/xgridagent/xgridagent-1.0.ebuild b/sys-cluster/xgridagent/xgridagent-1.0.ebuild
new file mode 100644
index 000000000000..5ca4b2a029c0
--- /dev/null
+++ b/sys-cluster/xgridagent/xgridagent-1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/xgridagent/xgridagent-1.0.ebuild,v 1.1 2004/06/24 16:30:13 dholm Exp $
+
+DESCRIPTION="A simple system for setting up and using a cluster of OS X machines"
+HOMEPAGE="http://www.novajo.ca/xgridagent/"
+SRC_URI="http://www.novajo.ca/${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+DEPEND=">=net-libs/roadrunner-0.9.1"
+
+src_compile() {
+ econf \
+ --with-roadrunner-includedir=/usr/include/roadrunner-1.0 \
+ --with-roadrunner-libdir=/usr/lib || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin xgridagent
+ dodoc README
+ insinto /usr/share/${PN}
+ doins xgrid.config.xml
+}