summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2004-04-02 22:30:09 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2004-04-02 22:30:09 +0000
commit17ba5c7f031fe93f614bad637d7a0f524cdce4e4 (patch)
tree9e7de745a312881b663a7b9b7ef33273adef0506 /sys-cluster
parentNow installs to /usr/share/pvm3 instead of /usr/local/pvm3. This closes #33067. (diff)
downloadhistorical-17ba5c7f031fe93f614bad637d7a0f524cdce4e4.tar.gz
historical-17ba5c7f031fe93f614bad637d7a0f524cdce4e4.tar.bz2
historical-17ba5c7f031fe93f614bad637d7a0f524cdce4e4.zip
Add MPICH_CONFIGURE_OPTS variable for customization (#38207).
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich/ChangeLog5
-rw-r--r--sys-cluster/mpich/Manifest4
-rw-r--r--sys-cluster/mpich/mpich-1.2.5.2.ebuild16
3 files changed, 21 insertions, 4 deletions
diff --git a/sys-cluster/mpich/ChangeLog b/sys-cluster/mpich/ChangeLog
index 349b291fb80f..31cb9bfd228f 100644
--- a/sys-cluster/mpich/ChangeLog
+++ b/sys-cluster/mpich/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/mpich
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/ChangeLog,v 1.12 2004/04/02 21:43:26 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/ChangeLog,v 1.13 2004/04/02 22:30:09 spyderous Exp $
+
+ 02 Apr 2004; Donnie Berkholz <spyderous@gentoo.org>; mpich-1.2.5.2.ebuild:
+ Add MPICH_CONFIGURE_OPTS variable for customization (#38207).
02 Apr 2004; Donnie Berkholz <spyderous@gentoo.org>; mpich-1.2.5.2.ebuild:
lam-mpi changed categories a while back, but RDEPEND was never changed to
diff --git a/sys-cluster/mpich/Manifest b/sys-cluster/mpich/Manifest
index 0e001636b7d7..b829ddaf3374 100644
--- a/sys-cluster/mpich/Manifest
+++ b/sys-cluster/mpich/Manifest
@@ -1,4 +1,4 @@
-MD5 3a86da7bd7ec9185bbab56e00bf3e95d ChangeLog 1622
+MD5 e7c3752e8fa0ec59f391ab0e2a0a4acb ChangeLog 1764
MD5 41664043c4624dedcfeeb07950f08d13 metadata.xml 312
-MD5 6125d49590cb12484a804f44bf245cfa mpich-1.2.5.2.ebuild 2687
+MD5 93ce2989490544540cbb8ab3f7429b0c mpich-1.2.5.2.ebuild 3170
MD5 11a56e15994b5f4fe1ae37ebde20fa50 files/digest-mpich-1.2.5.2 67
diff --git a/sys-cluster/mpich/mpich-1.2.5.2.ebuild b/sys-cluster/mpich/mpich-1.2.5.2.ebuild
index 6a85155bf21b..c8a27850429e 100644
--- a/sys-cluster/mpich/mpich-1.2.5.2.ebuild
+++ b/sys-cluster/mpich/mpich-1.2.5.2.ebuild
@@ -1,6 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/mpich-1.2.5.2.ebuild,v 1.5 2004/04/02 21:43:26 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/mpich-1.2.5.2.ebuild,v 1.6 2004/04/02 22:30:09 spyderous Exp $
+
+# Set the MPICH_CONFIGURE_OPTS environment variable to change the signal
+# mpich listens on or any other custom options (#38207).
+# The default USR1 conflicts with pthreads. Options include SIGUSR2 and SIGBUS.
+# For example: MPICH_CONFIGURE_OPTS="--with-device=ch_p4:-listener_sig=SIGBUS"
DESCRIPTION="MPICH - A portable MPI implementation"
HOMEPAGE="http://www-unix.mcs.anl.gov/mpi/mpich"
@@ -17,6 +22,12 @@ RDEPEND="${DEPEND}
!crypt? ( net-misc/netkit-rsh )
!sys-cluster/lam-mpi"
+pkg_setup() {
+ if [ -n "${MPICH_CONFIGURE_OPTS}" ]; then
+ einfo "Custom configure options are ${MPICH_CONFIGURE_OPTS}."
+ fi
+}
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -34,7 +45,10 @@ src_compile() {
export RSHCOMMAND
+ local myconf="${myconf} ${MPICH_CONFIGURE_OPTS}"
+
./configure \
+ ${myconf} \
--mandir=/usr/share/man \
--prefix=/usr || die
make || die