summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-21 16:30:02 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-21 16:30:02 +0000
commitd36b58852b30b4e31f86ad6dca3dbf45c5470edb (patch)
treef3474c7e50e46c6e701dd800d2b208c557dd54dd /sys-cluster
parentfix iproute dep (diff)
downloadhistorical-d36b58852b30b4e31f86ad6dca3dbf45c5470edb.tar.gz
historical-d36b58852b30b4e31f86ad6dca3dbf45c5470edb.tar.bz2
historical-d36b58852b30b4e31f86ad6dca3dbf45c5470edb.zip
fix iproute dep
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/keepalived/keepalived-1.1.3.ebuild4
-rw-r--r--sys-cluster/keepalived/keepalived-1.1.5.ebuild4
-rw-r--r--sys-cluster/keepalived/keepalived-1.1.6.ebuild24
3 files changed, 12 insertions, 20 deletions
diff --git a/sys-cluster/keepalived/keepalived-1.1.3.ebuild b/sys-cluster/keepalived/keepalived-1.1.3.ebuild
index 6a7d31a78724..cc4546624b10 100644
--- a/sys-cluster/keepalived/keepalived-1.1.3.ebuild
+++ b/sys-cluster/keepalived/keepalived-1.1.3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.1.3.ebuild,v 1.3 2004/01/26 06:41:21 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.1.3.ebuild,v 1.4 2004/04/21 16:30:02 vapier Exp $
DESCRIPTION="The main goal of the keepalived project is to add a strong & robust keepalive facility to the Linux Virtual Server project."
HOMEPAGE="http://keepalived.sourceforge.net"
LICENSE="GPL-2"
DEPEND="dev-libs/popt
- sys-apps/iproute"
+ sys-apps/iproute2"
SRC_URI="http://keepalived.sourceforge.net/software/${P}.tar.gz"
diff --git a/sys-cluster/keepalived/keepalived-1.1.5.ebuild b/sys-cluster/keepalived/keepalived-1.1.5.ebuild
index 6aafcd375945..9f33ef65ddd6 100644
--- a/sys-cluster/keepalived/keepalived-1.1.5.ebuild
+++ b/sys-cluster/keepalived/keepalived-1.1.5.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.1.5.ebuild,v 1.1 2004/01/26 06:41:21 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.1.5.ebuild,v 1.2 2004/04/21 16:30:02 vapier Exp $
DESCRIPTION="The main goal of the keepalived project is to add a strong & robust keepalive facility to the Linux Virtual Server project."
HOMEPAGE="http://keepalived.sourceforge.net"
LICENSE="GPL-2"
DEPEND="dev-libs/popt
- sys-apps/iproute"
+ sys-apps/iproute2"
SRC_URI="http://keepalived.sourceforge.net/software/${P}.tar.gz"
diff --git a/sys-cluster/keepalived/keepalived-1.1.6.ebuild b/sys-cluster/keepalived/keepalived-1.1.6.ebuild
index 587f24636f1d..6ad2db4eed8a 100644
--- a/sys-cluster/keepalived/keepalived-1.1.6.ebuild
+++ b/sys-cluster/keepalived/keepalived-1.1.6.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.1.6.ebuild,v 1.1 2004/02/23 18:00:05 iggy Exp $
-
-DESCRIPTION="The main goal of the keepalived project is to add a strong & robust keepalive facility to the Linux Virtual Server project."
-HOMEPAGE="http://keepalived.sourceforge.net"
-LICENSE="GPL-2"
-
-DEPEND="dev-libs/popt
- sys-apps/iproute"
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.1.6.ebuild,v 1.2 2004/04/21 16:30:02 vapier Exp $
+DESCRIPTION="add a strong & robust keepalive facility to the Linux Virtual Server project"
+HOMEPAGE="http://keepalived.sourceforge.net/"
SRC_URI="http://keepalived.sourceforge.net/software/${P}.tar.gz"
-IUSE=""
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
-S="${WORKDIR}/${P}"
+IUSE="debug"
+
+DEPEND="dev-libs/popt
+ sys-apps/iproute2"
src_compile() {
local myconf
@@ -24,15 +22,11 @@ src_compile() {
use debug && myconf="${myconf} --enable-debug"
# use profile && myconf="${myconf} --enable-profile"
- cd "${S}"
./configure ${myconf} || die "configure failed"
emake || die "make failed (myconf=${myconf})"
-
}
src_install() {
-
- cd "${S}"
einstall || die
exeinto /etc/init.d
@@ -43,7 +37,6 @@ src_install() {
}
pkg_postinst() {
-
einfo ""
einfo "If you want Linux Virtual Server support in keepalived then you must emerge an"
einfo "LVS patched kernel, compile with ipvs support either as a module or built into"
@@ -51,5 +44,4 @@ pkg_postinst() {
einfo ""
einfo "For debug support add USE=\"debug\" to your /etc/make.conf"
einfo ""
-
}