summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-10-11 22:23:50 +0000
committerMike Frysinger <vapier@gentoo.org>2011-10-11 22:23:50 +0000
commit18e7c7f6222b0a53d182f3922fdb6bbbb676bef9 (patch)
tree31862205515dd7bc39250099f0b5de2ba3135cd6 /sys-devel/crossdev/crossdev-20111011.ebuild
parentppc/ppc64 stable wrt #385975 (diff)
downloadhistorical-18e7c7f6222b0a53d182f3922fdb6bbbb676bef9.tar.gz
historical-18e7c7f6222b0a53d182f3922fdb6bbbb676bef9.tar.bz2
historical-18e7c7f6222b0a53d182f3922fdb6bbbb676bef9.zip
Version bump.
Package-Manager: portage-2.2.0_alpha65/cvs/Linux x86_64
Diffstat (limited to 'sys-devel/crossdev/crossdev-20111011.ebuild')
-rw-r--r--sys-devel/crossdev/crossdev-20111011.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-devel/crossdev/crossdev-20111011.ebuild b/sys-devel/crossdev/crossdev-20111011.ebuild
new file mode 100644
index 000000000000..2c158cf05d09
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20111011.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-20111011.ebuild,v 1.1 2011/10/11 22:23:50 vapier Exp $
+
+EAPI="3"
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}