summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-10 06:18:55 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-10 06:18:55 +0000
commitb44eaf9373468dac6a1fb0eed41151729a6b6b43 (patch)
tree8ff4525bfd30e9438a8db97e9162910b155fef37 /sys-devel/gcc-config
parentdefault to a pc vendor only for x86/amd64 (diff)
downloadhistorical-b44eaf9373468dac6a1fb0eed41151729a6b6b43.tar.gz
historical-b44eaf9373468dac6a1fb0eed41151729a6b6b43.tar.bz2
historical-b44eaf9373468dac6a1fb0eed41151729a6b6b43.zip
when asking for the current profile of a cross target that has yet to be configured, make sure we error out
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sys-devel/gcc-config')
-rw-r--r--sys-devel/gcc-config/Manifest10
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.117
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.127
3 files changed, 11 insertions, 13 deletions
diff --git a/sys-devel/gcc-config/Manifest b/sys-devel/gcc-config/Manifest
index 72ba44bf97bd..62b9a8705b2c 100644
--- a/sys-devel/gcc-config/Manifest
+++ b/sys-devel/gcc-config/Manifest
@@ -8,7 +8,7 @@ MD5 8ddb51e4d22a768b490aea079b28c334 gcc-config-1.3.11-r3.ebuild 1387
MD5 e1e82310909ead9c8b474d56cb94ee8c gcc-config-1.3.10-r1.ebuild 1393
MD5 63c2a0d7a7de8a2b0253f3cbb6692480 ChangeLog 19808
MD5 77ddef43e2f0a70ebcfe60398ded82a2 gcc-config-1.3.12.ebuild 1394
-MD5 541a9345b607e7798a64d8ace437b80d files/gcc-config-1.3.11 15774
+MD5 d153788edf3039aa4f68ae41bf46bf0d files/gcc-config-1.3.11 15776
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gcc-config-1.3.11-r4 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gcc-config-1.3.12 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gcc-config-1.3.11-r3 0
@@ -18,11 +18,11 @@ MD5 4c31f7f5f8723588a4401dd102061301 files/gcc-config-1.3.10 13549
MD5 e3203a5aa6df669ffa479aeeb7605029 files/wrapper-1.4.5.c 10671
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gcc-config-1.3.10-r1 0
MD5 6002b96b17fc06da1a872ef8032b52d5 files/wrapper-1.4.6.c 10582
-MD5 988317dd280cf11a2139198b5f63ef35 files/gcc-config-1.3.12 15983
+MD5 c4dd33ad0dcb7135344c428f1155b1ad files/gcc-config-1.3.12 15985
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFC0AESgIKl8Uu19MoRAuwUAJkBXQfXZKNTJsHyXADpcd6aa0ZjuACfVtHR
-kNe+YedkPot7wo7HySWGfaQ=
-=Lehw
+iD8DBQFC0L4VgIKl8Uu19MoRAi4EAJ4yoHbNbY9vUIM/hFwxnIukePXKuwCfbJr4
+VCJxJrNKJAMw1wjCInj2gJo=
+=0tdN
-----END PGP SIGNATURE-----
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.11 b/sys-devel/gcc-config/files/gcc-config-1.3.11
index baf9985391f3..ae32f91667a0 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.11
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.11
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.11,v 1.6 2005/07/07 23:03:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.11,v 1.7 2005/07/10 06:18:55 vapier Exp $
trap ":" INT QUIT TSTP
@@ -295,7 +295,7 @@ get_current_profile() {
local conf="${GCC_ENV_D}/config"
if [[ -n ${CTARGET} ]] ; then
conf="${conf}-${CTARGET}"
- elif [[ -f ${GCC_ENV_D}/config-${CC_COMP} ]] ; then
+ elif [[ -n ${CC_COMP} ]] && is_cross_compiler ; then
conf="${conf}-${CC_COMP}"
fi
@@ -506,8 +506,7 @@ if [[ ${DOIT} == "switch_profile" ]] && [[ -z ${CC_COMP} ]] ; then
fi
if [[ -z ${CC_COMP} ]] ; then
- if get_current_profile &>/dev/null
- then
+ if get_current_profile &>/dev/null ; then
CC_COMP="$(get_current_profile)"
else
list_profiles
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.12 b/sys-devel/gcc-config/files/gcc-config-1.3.12
index 926ac6554f6a..8dfe697d856f 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.12
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.12
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.12,v 1.1 2005/07/09 16:52:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.12,v 1.2 2005/07/10 06:18:55 vapier Exp $
trap ":" INT QUIT TSTP
@@ -296,7 +296,7 @@ get_current_profile() {
local conf="${GCC_ENV_D}/config"
if [[ -n ${CTARGET} ]] ; then
conf="${conf}-${CTARGET}"
- elif [[ -f ${GCC_ENV_D}/config-${CC_COMP} ]] ; then
+ elif [[ -n ${CC_COMP} ]] && is_cross_compiler ; then
conf="${conf}-${CC_COMP}"
fi
@@ -566,8 +566,7 @@ if [[ ${DOIT} == "switch_profile" ]] && [[ -z ${CC_COMP} ]] ; then
fi
if [[ -z ${CC_COMP} ]] ; then
- if get_current_profile &>/dev/null
- then
+ if get_current_profile &>/dev/null ; then
CC_COMP="$(get_current_profile)"
else
list_profiles