summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2004-11-29 05:47:11 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2004-11-29 05:47:11 +0000
commitac61c9f20d86e6081e9fbe5052010bb7451347f3 (patch)
tree45f64d95c22a2b33e972337124cff435c26f175d /sys-devel/gcc/gcc-3.4.3-r1.ebuild
parentstable on amd64 (diff)
downloadhistorical-ac61c9f20d86e6081e9fbe5052010bb7451347f3.tar.gz
historical-ac61c9f20d86e6081e9fbe5052010bb7451347f3.tar.bz2
historical-ac61c9f20d86e6081e9fbe5052010bb7451347f3.zip
Updated gcc-3.4.3-r1 for more libffi fixes - moved headers to locations that worked; multilib is still installing in the wrong spot for libffi
Diffstat (limited to 'sys-devel/gcc/gcc-3.4.3-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.4.3-r1.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/sys-devel/gcc/gcc-3.4.3-r1.ebuild b/sys-devel/gcc/gcc-3.4.3-r1.ebuild
index 4061953388f3..2256c752db4b 100644
--- a/sys-devel/gcc/gcc-3.4.3-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.3-r1.ebuild,v 1.3 2004/11/29 00:28:58 fafhrd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.3-r1.ebuild,v 1.4 2004/11/29 05:47:11 fafhrd Exp $
DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
@@ -360,6 +360,18 @@ src_install() {
exeinto /sbin
doexe ${FILESDIR}/fix_libtool_files.sh
fi
+
+ # I do not know if this will break gcj stuff, so I'll only do it for
+ # objc for now; basically "ffi.h" is the correct file to include,
+ # but it gets installed in .../GCCVER/include and yet it does
+ # "#include <ffitarget.h>" which (correctly, as it's an "extra" file)
+ # is installed in .../GCCVER/include/libffi; the following fixes
+ # ffi.'s include of ffitarget.h - Armando Di Cianno <fafhrd@gentoo.org>
+ if use objc && ! use gcj; then
+ #dosed "s:<ffitarget.h>:<libffi/ffitarget.h>:g" /${LIBPATH}/include/ffi.h
+ mv ${D}/${LIBPATH}/include/libffi/* ${D}/${LIBPATH}/include
+ rm -Rf ${D}/${LIBPATH}/include/libffi
+ fi
}
fix_freaky_non_versioned_library_paths_that_dont_ever_get_used() {