summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-10-20 01:50:25 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-10-20 01:50:25 +0000
commitcfa146d28c5e896d0b9c32230bab7e0ffd7f7bc0 (patch)
tree2730d8949a6f9f63ed36238739aa6cff3feebed2 /sys-devel/gecc
parentebuild.makepretty(); (diff)
downloadhistorical-cfa146d28c5e896d0b9c32230bab7e0ffd7f7bc0.tar.gz
historical-cfa146d28c5e896d0b9c32230bab7e0ffd7f7bc0.tar.bz2
historical-cfa146d28c5e896d0b9c32230bab7e0ffd7f7bc0.zip
add good stuff
Diffstat (limited to 'sys-devel/gecc')
-rw-r--r--sys-devel/gecc/files/conf.geccd18
-rw-r--r--sys-devel/gecc/files/env.geccd1
-rw-r--r--sys-devel/gecc/files/rc.geccd35
-rw-r--r--sys-devel/gecc/gecc-20021019.ebuild26
4 files changed, 79 insertions, 1 deletions
diff --git a/sys-devel/gecc/files/conf.geccd b/sys-devel/gecc/files/conf.geccd
new file mode 100644
index 000000000000..df0000f6fb5c
--- /dev/null
+++ b/sys-devel/gecc/files/conf.geccd
@@ -0,0 +1,18 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gecc/files/conf.geccd,v 1.1 2002/10/20 01:50:25 lostlogic Exp $
+
+# Where should gecc store it's cache?
+GECCD_CACHE="/var/tmp/geccd-cache"
+
+# The port the compiler cluster will communicate on
+GECCD_PORT="42042"
+
+# If this is the central node of the gecc cluster then
+# set this to "" otherwise set it to the hostname or IP
+# of the central node.
+GECCD_CENTRAL=""
+
+# This specifies how many gcc processes will be
+# spawned on this machien by gecc
+GECCD_JOBS="1"
diff --git a/sys-devel/gecc/files/env.geccd b/sys-devel/gecc/files/env.geccd
new file mode 100644
index 000000000000..a9f492a72023
--- /dev/null
+++ b/sys-devel/gecc/files/env.geccd
@@ -0,0 +1 @@
+GECCD_SOCKFILE="/var/run/geccd.sock"
diff --git a/sys-devel/gecc/files/rc.geccd b/sys-devel/gecc/files/rc.geccd
new file mode 100644
index 000000000000..f783581d6c39
--- /dev/null
+++ b/sys-devel/gecc/files/rc.geccd
@@ -0,0 +1,35 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gecc/files/rc.geccd,v 1.1 2002/10/20 01:50:25 lostlogic Exp $
+
+depend()
+{
+ need net
+}
+
+start()
+{
+ local myopts
+ if [ ! -z "${GECCD_CENTRAL}" ]; then
+ myopts="-c -a ${GECCD_CENTRAL} -A ${GECCD_PORT}"
+ fi
+
+ ebegin "Starting geccd"
+ start-stop-daemon --start --quiet --exec /usr/bin/geccd -- \
+ ${myopts} \
+ -c \
+ -p ${GECCD_PORT} \
+ -C ${GECCD_CACHE} \
+ -j ${GECCD_JOBS} \
+ -s /var/run/geccd.sock \
+ --pid-file /var/run/geccd.pid
+ eend $?
+}
+
+stop()
+{
+ ebegin "Stopping geccd"
+ start-stop-daemon --stop --quiet -p /var/run/geccd.pid
+ eend $?
+}
diff --git a/sys-devel/gecc/gecc-20021019.ebuild b/sys-devel/gecc/gecc-20021019.ebuild
index 5c7b2122156d..c7e9c058819e 100644
--- a/sys-devel/gecc/gecc-20021019.ebuild
+++ b/sys-devel/gecc/gecc-20021019.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gecc/gecc-20021019.ebuild,v 1.3 2002/10/20 00:56:24 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gecc/gecc-20021019.ebuild,v 1.4 2002/10/20 01:50:25 lostlogic Exp $
# comprehensive list of any and all USE flags leveraged in the build,
# with the exception of any ARCH specific flags, i.e. ppc sparc sparc64
@@ -25,4 +25,28 @@ src_compile() {
src_install() {
einstall || die "Install failed"
+ dodoc README
+
+ dodir /usr/bin/gecc_link
+ dosym /usr/bin/gecc /usr/bin/gecc_link/gcc
+ dosym /usr/bin/gecc /usr/bin/gecc_link/g++
+ dosym /usr/bin/gecc /usr/bin/gecc_link/c++
+ dosym /usr/bin/gecc /usr/bin/gecc_link/cc
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/conf.geccd geccd
+
+ insinto /etc/env.d
+ newins ${FILESDIR}/env.geccd 06geccd
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rc.geccd geccd
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use gecc for you local compiles you will need to add"
+ einfo "/usr/bin/gecc to the front of your path, and add geccd"
+ einfo "to your default runlevel"
+ einfo
}