summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-05-08 14:24:04 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-05-08 14:24:04 +0000
commit2103bfa239b28b4905b7e0d6b0d57022a4fd6b34 (patch)
tree2388d491e44802e18e60a1128f8297e988bd86ea /sys-devel/patch/patch-2.5.9.ebuild
parent~amd64 (diff)
downloadhistorical-2103bfa239b28b4905b7e0d6b0d57022a4fd6b34.tar.gz
historical-2103bfa239b28b4905b7e0d6b0d57022a4fd6b34.tar.bz2
historical-2103bfa239b28b4905b7e0d6b0d57022a4fd6b34.zip
Fixes BUG #46892.
Diffstat (limited to 'sys-devel/patch/patch-2.5.9.ebuild')
-rw-r--r--sys-devel/patch/patch-2.5.9.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/sys-devel/patch/patch-2.5.9.ebuild b/sys-devel/patch/patch-2.5.9.ebuild
index b56b7b5f6b2c..6c0d70f427d5 100644
--- a/sys-devel/patch/patch-2.5.9.ebuild
+++ b/sys-devel/patch/patch-2.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.15 2004/04/24 08:06:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.16 2004/05/08 14:24:04 kugelfang Exp $
inherit flag-o-matic
@@ -20,8 +20,20 @@ DEPEND="virtual/glibc"
src_compile() {
strip-flags
CFLAGS="$CFLAGS -DLINUX -D_XOPEN_SOURCE=500"
+ # workaround for hardened on amd64, 1st part
+ if [ "`use amd64`" ] && [ "is-ldflags -pie" ]; then
+ einfo Stripping "-pie" from LDFLAGS, adding it to Makefile manually
+ filter-ldflags -pie
+ append-flags -fPIC
+ LDFLAGS_PIE="1"
+ fi
ac_cv_sys_long_file_names=yes \
./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
+ # workaround for hardened on amd64, 2nd part
+ if [ ${LDFLAGS_PIE} = "1" ]; then
+ einfo "Patching Makefile..."
+ sed -i -e 's/^LDFLAGS =/& -pie/' Makefile || die "Patching Makefile failed!"
+ fi
if ! use static ; then
emake || die "emake failed"
else