summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-10-11 05:27:23 +0000
committerMike Frysinger <vapier@gentoo.org>2007-10-11 05:27:23 +0000
commit648fb2ed6f36e496971c29407bdcbd515958ff6f (patch)
tree1bdbeb2387bb73dcf26bf0a0cc04d7825b891444 /sys-devel
parentstable on ppc64, bug #195387 (diff)
downloadhistorical-648fb2ed6f36e496971c29407bdcbd515958ff6f.tar.gz
historical-648fb2ed6f36e496971c29407bdcbd515958ff6f.tar.bz2
historical-648fb2ed6f36e496971c29407bdcbd515958ff6f.zip
old
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.4.0-r30
-rw-r--r--sys-devel/gcc-config/gcc-config-1.4.0-r3.ebuild55
2 files changed, 0 insertions, 55 deletions
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.4.0-r3 b/sys-devel/gcc-config/files/digest-gcc-config-1.4.0-r3
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/sys-devel/gcc-config/files/digest-gcc-config-1.4.0-r3
+++ /dev/null
diff --git a/sys-devel/gcc-config/gcc-config-1.4.0-r3.ebuild b/sys-devel/gcc-config/gcc-config-1.4.0-r3.ebuild
deleted file mode 100644
index b8dd7bbbd836..000000000000
--- a/sys-devel/gcc-config/gcc-config-1.4.0-r3.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.4.0-r3.ebuild,v 1.1 2007/10/07 04:20:36 vapier Exp $
-
-inherit flag-o-matic toolchain-funcs multilib
-
-# Version of .c wrapper to use
-W_VER="1.5.0"
-
-DESCRIPTION="Utility to change the gcc compiler being used"
-HOMEPAGE="http://www.gentoo.org/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND="!app-admin/eselect-compiler"
-
-S=${WORKDIR}
-
-src_unpack() {
- cp "${FILESDIR}"/wrapper-${W_VER}.c "${S}"/wrapper.c || die
-}
-
-src_compile() {
- strip-flags
- emake CC="$(tc-getCC)" wrapper || die "compile wrapper"
-}
-
-src_install() {
- newbin "${FILESDIR}"/${PN}-${PV} ${PN} || die "install gcc-config"
- sed -i \
- -e "s:PORTAGE-VERSION:${PVR}:g" \
- -e "s:GENTOO_LIBDIR:$(get_libdir):g" \
- "${D}"/usr/bin/${PN}
-
- exeinto /usr/$(get_libdir)/misc
- newexe wrapper gcc-config || die "install wrapper"
-}
-
-pkg_postinst() {
- # Do we have a valid multi ver setup ?
- if gcc-config --get-current-profile &>/dev/null ; then
- # We not longer use the /usr/include/g++-v3 hacks, as
- # it is not needed ...
- [[ -L ${ROOT}/usr/include/g++ ]] && rm -f "${ROOT}"/usr/include/g++
- [[ -L ${ROOT}/usr/include/g++-v3 ]] && rm -f "${ROOT}"/usr/include/g++-v3
- gcc-config $(/usr/bin/gcc-config --get-current-profile)
- fi
-
- # Make sure old versions dont exist #79062
- rm -f "${ROOT}"/usr/sbin/gcc-config
-}