summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-04-07 07:05:49 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-04-07 07:05:49 +0000
commitc6620cb5d678bdbf6a16d0a7a42268b174804354 (patch)
tree4fc65d5861b70762723c03311f3235087ccea240 /sys-devel
parentAdded PostgreSQL dep; netlib dep ajustment, version bump. (diff)
downloadhistorical-c6620cb5d678bdbf6a16d0a7a42268b174804354.tar.gz
historical-c6620cb5d678bdbf6a16d0a7a42268b174804354.tar.bz2
historical-c6620cb5d678bdbf6a16d0a7a42268b174804354.zip
new version
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/ChangeLog4
-rw-r--r--sys-devel/binutils/binutils-2.12.90.0.3.ebuild123
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.12.90.0.31
3 files changed, 127 insertions, 1 deletions
diff --git a/sys-devel/binutils/ChangeLog b/sys-devel/binutils/ChangeLog
index 9da915ec8080..009b970f3bd9 100644
--- a/sys-devel/binutils/ChangeLog
+++ b/sys-devel/binutils/ChangeLog
@@ -1,6 +1,8 @@
# ChangeLog for sys-devel/binutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.3 2002/03/21 17:17:54 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.4 2002/04/07 07:05:49 azarah Exp $
+
+*binutils-2.12.90.0.3 (7 Apr 2002)
*binutils-2.12.90.0.1 (21 Mar 2002)
diff --git a/sys-devel/binutils/binutils-2.12.90.0.3.ebuild b/sys-devel/binutils/binutils-2.12.90.0.3.ebuild
new file mode 100644
index 000000000000..a12e0fd58b6a
--- /dev/null
+++ b/sys-devel/binutils/binutils-2.12.90.0.3.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.12.90.0.3.ebuild,v 1.1 2002/04/07 07:05:49 azarah Exp $
+
+# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
+# the manpages, but seems this is incorrect ....
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools necessary to build programs"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.bz2"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+[ -z "`use build`" ] && [ -z "`use bootstrap`" ] && DEPEND="${DEPEND} sys-devel/perl"
+
+
+src_compile() {
+
+ local myconf=""
+ use nls && \
+ myconf="${myconf} --without-included-gettext" || \
+ myconf="${myconf} --disable-nls"
+
+ # DO NOT LIBTOOLIZE, AS BINUTILS COME WITH ITS OWN VERSION
+ # OF LIBTOOL!!!!!!!
+ libtoolize --copy --force
+
+ ./configure --enable-shared \
+ --enable-64-bit-bfd \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ if [ "`use static`" ]
+ then
+ make headers -C bfd CFLAGS=-O || die
+ emake -e LDFLAGS=-all-static || die
+ else
+ make headers -C bfd CFLAGS=-O || die
+ emake || die
+ fi
+
+ if [ -z "`use build`" ]
+ then
+ if [ -z "`use bootstrap`" ]
+ then
+ #nuke the manpages to recreate them (only use this if we have perl)
+ find . -name '*.1' -exec rm {} ';'
+ fi
+ #make the info pages (makeinfo included with gcc is used)
+ make info || die
+ fi
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ insinto /usr/include
+ doins include/libiberty.h
+
+ #c++filt is included with gcc -- what are these GNU people thinking?
+ #but not the manpage, so leave that!
+ rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
+
+ #strip has a symlink going from /usr/${CHOST}/bin/strip to /usr/bin/strip
+ #we should reverse it:
+
+ rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
+ #the strip symlink gets created in the loop below
+
+ #ar, as, ld, nm, ranlib and strip are in two places; create symlinks. This will reduce the
+ #size of the tbz2 significantly. We also move all the stuff in /usr/bin to /usr/${CHOST}/bin
+ #and create the appropriate symlinks. Things are cleaner that way.
+ cd ${D}/usr/bin
+ local x
+ for x in * strip
+ do
+ if [ ! -e ../${CHOST}/bin/${x} ]
+ then
+ mv $x ../${CHOST}/bin/${x}
+ else
+ rm -f $x
+ fi
+ ln -s ../${CHOST}/bin/${x} ${x}
+ done
+
+ cd ${S}
+ if [ -z "`use build`" ]
+ then
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install-info || die
+
+ dodoc COPYING* README
+ docinto bfd
+ dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
+ docinto binutils
+ dodoc binutils/ChangeLog binutils/NEWS binutils/README
+ docinto gas
+ dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
+ docinto gprof
+ dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
+ docinto ld
+ dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
+ docinto libiberty
+ dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
+ docinto opcodes
+ dodoc opcodes/ChangeLog*
+ #install pre-generated manpages
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+}
+
diff --git a/sys-devel/binutils/files/digest-binutils-2.12.90.0.3 b/sys-devel/binutils/files/digest-binutils-2.12.90.0.3
new file mode 100644
index 000000000000..c59246e89bf9
--- /dev/null
+++ b/sys-devel/binutils/files/digest-binutils-2.12.90.0.3
@@ -0,0 +1 @@
+MD5 f6c42e6d89785198dea45d97a609b349 binutils-2.12.90.0.3.tar.bz2 8741219