summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2004-05-02 21:20:49 +0000
committerLisa M. Seelye <lisa@gentoo.org>2004-05-02 21:20:49 +0000
commitd58162830626de46703dfff3d6c26844872b82f6 (patch)
treec3460b1ce81b0861f0d122489010620ad4720bef /sys-devel
parentAdded ~mips keyword. (diff)
downloadhistorical-d58162830626de46703dfff3d6c26844872b82f6.tar.gz
historical-d58162830626de46703dfff3d6c26844872b82f6.tar.bz2
historical-d58162830626de46703dfff3d6c26844872b82f6.zip
bump to 2.14
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/distcc/ChangeLog7
-rw-r--r--sys-devel/distcc/Manifest10
-rw-r--r--sys-devel/distcc/distcc-2.14.ebuild147
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.141
4 files changed, 160 insertions, 5 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index 60a3a1ef90e4..1dde36ec384f 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/distcc
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.101 2004/04/12 00:33:42 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.102 2004/05/02 21:20:49 lisa Exp $
+
+*distcc-2.14 (02 May 2004)
+
+ 02 May 2004; Lisa Seelye <lisa@gentoo.org> +distcc-2.14.ebuild:
+ bump to 2.14
11 Apr 2004; Lisa Seelye <lisa@gentoo.org> distcc-2.12.1.ebuild,
distcc-2.13-r1.ebuild, distcc-2.13.ebuild:
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index a5126b4d57fa..26b8101fc8ae 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -1,9 +1,11 @@
-MD5 9828c18f2a25949f55f4f440c4ad833a distcc-2.12.1-r1.ebuild 4634
MD5 2d952a41dbc441fb90e8767605c04f91 distcc-2.13-r1.ebuild 4675
-MD5 4ca65deb16b139c753c18c43ab7f9a22 ChangeLog 18615
MD5 70619e7eb5fa4fd0aa4f3588579cd50d metadata.xml 443
+MD5 a9e7752c290eb5309037db0e3632de51 ChangeLog 18725
+MD5 9828c18f2a25949f55f4f440c4ad833a distcc-2.12.1-r1.ebuild 4634
+MD5 10d785281187a68d65b7417a99413c17 distcc-2.14.ebuild 4679
+MD5 47a8df000e00ce5f8bff08c9342bdae4 files/digest-distcc-2.14 64
MD5 9ca407ce154707a1f27485523adf943c files/digest-distcc-2.12.1-r1 66
MD5 6ab90bfeafe27c0d276eb8b6f1257560 files/digest-distcc-2.13-r1 64
-MD5 93a6aabdbddfa7f9ac19c9c4f4b584b5 files/2.11.1p/conf 545
-MD5 5f509189d5beee2fbafadafc8ecc62d6 files/2.11.1p/init 625
MD5 25fc12feb724b6c68a0d4a46b6cd0033 files/2.11.1p/distcc-config 4884
+MD5 5f509189d5beee2fbafadafc8ecc62d6 files/2.11.1p/init 625
+MD5 93a6aabdbddfa7f9ac19c9c4f4b584b5 files/2.11.1p/conf 545
diff --git a/sys-devel/distcc/distcc-2.14.ebuild b/sys-devel/distcc/distcc-2.14.ebuild
new file mode 100644
index 000000000000..c1205441527d
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.14.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.14.ebuild,v 1.1 2004/05/02 21:20:49 lisa Exp $
+
+# If you change this in any way please email lisa@gentoo.org and make an
+# entry in the ChangeLog (this means you spanky :P). (2004-04-11) Lisa Seelye
+
+inherit eutils gcc flag-o-matic
+
+PATCHLEVEL="2.11.1p"
+
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~ia64 ~amd64"
+IUSE="gnome gtk selinux ipv6"
+
+DEPEND=">=sys-apps/portage-2.0.49-r6
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow
+ dev-util/pkgconfig"
+RDEPEND="
+ !arm? ( !mips? (
+ gnome? (
+ >=x11-libs/gtk+-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0.0
+ >=gnome-base/libglade-2.0.0
+ x11-libs/pango
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.0.0
+ x11-libs/pango
+ )
+ ) )
+ selinux? ( sec-policy/selinux-distcc )"
+
+src_compile() {
+ local myconf="--with-included-popt "
+ #Here we use the built in parse-options package. saves a dependancy
+
+ #not taking any chances here, guessing which takes precedence in the
+ #configure script, so we'll just make the distinction here:
+ #gnome takes precedence over gtk if both are specified (gnome pulls
+ #in gtk anyways...)
+ use gtk && ! use gnome && ! use mips && myconf="${myconf} --with-gtk"
+ use gtk && use gnome && ! use mips && myconf="${myconf} --with-gnome"
+ use mips && use gtk || use gnome && ewarn "X support for Mips has been disabled."
+ #Above, mips is excluded due to version issues. 2004-02-20
+
+ [ `gcc-major-version` -eq 2 ] && filter-lfs-flags
+
+ if use ipv6; then
+ ewarn "To use IPV6 you must have IPV6 compiled into your kernel"
+ ewarn "either via a module or compiled code"
+ myconf=" ${myconf} --enable-rfc2553 "
+ sleep 4s
+ fi
+
+ econf ${myconf} || die "econf ${myconf} failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/${PATCHLEVEL}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PATCHLEVEL}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PATCHLEVEL}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ # handle DISTCC_HOSTS upgrade better
+ local ENVFILE
+ ENVFILE="${ROOT}etc/env.d/02distcc"
+ [ ! -f "${ENVFILE}" ] && \
+ ENVFILE="${ROOT}etc/env.d/04distcc"
+ if [ -f "${ENVFILE}" ]
+ then
+ # save hosts to new file
+ ROOT="${ROOT}"
+ HOSTS=$(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
+ [ ${HOSTS} ] && ${ROOT}usr/bin/distcc-config --set-hosts ${HOSTS}
+ # now remove from the file
+ grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
+ mv "${ENVFILE}.new" "${ENVFILE}"
+ fi
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "Setting permissions on ${ROOT}var/run/distccd"
+ chown -R distcc:daemon ${ROOT}var/run/distccd
+ echo ""
+
+ einfo "Tips on using distcc with Gentoo can be found at"
+ einfo "http://www.gentoo.org/doc/en/distcc.xml"
+ ewarn "As of distcc-2.11, the only thing you have to do to configure distcc"
+ ewarn "is to set your hosts (see the Guide, above) and to add distcc to"
+ ewarn "the FEATURES line in /etc/make.conf"
+ ewarn "This version includes a new distcc-config. If you encounter problems with it,"
+ ewarn "please report them to our Bugzilla at bugs.gentoo.org"
+ echo ""
+ einfo "To use the distccmon programs with Gentoo you should use this command:"
+ einfo " DISTCC_DIR=/var/tmp/portage/.distcc distccmon-text N"
+ use gnome || use gtk && einfo "Or: DISTCC_DIR=/var/tmp/portage/.distcc distccmon-gnome"
+ sleep 3s
+}
diff --git a/sys-devel/distcc/files/digest-distcc-2.14 b/sys-devel/distcc/files/digest-distcc-2.14
new file mode 100644
index 000000000000..af4a45dcc9a8
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.14
@@ -0,0 +1 @@
+MD5 612ee81b3e04fc6000dfbc4078ec9d8b distcc-2.14.tar.bz2 340510