summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2003-01-06 14:53:39 +0000
committerMichael Cummings <mcummings@gentoo.org>2003-01-06 14:53:39 +0000
commitf8ca32473c8692fc7885b2a85473f92dfb52edac (patch)
tree219f5911c48810e67662157324311a4d07a7e388 /sys-devel
parentmoved (diff)
downloadhistorical-f8ca32473c8692fc7885b2a85473f92dfb52edac.tar.gz
historical-f8ca32473c8692fc7885b2a85473f92dfb52edac.tar.bz2
historical-f8ca32473c8692fc7885b2a85473f92dfb52edac.zip
Updated -r8 (thanks azarah), added note and script for rebuilding libperl stuff
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/perl/ChangeLog10
-rw-r--r--sys-devel/perl/files/digest-perl-5.8.0-r81
-rw-r--r--sys-devel/perl/files/libperl_rebuilder301
-rw-r--r--sys-devel/perl/perl-5.8.0-r8.ebuild425
4 files changed, 735 insertions, 2 deletions
diff --git a/sys-devel/perl/ChangeLog b/sys-devel/perl/ChangeLog
index 962715267d32..53d95d079dc3 100644
--- a/sys-devel/perl/ChangeLog
+++ b/sys-devel/perl/ChangeLog
@@ -1,8 +1,14 @@
# ChangeLog for sys-devel/perl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/ChangeLog,v 1.36 2003/01/03 16:36:46 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/ChangeLog,v 1.37 2003/01/06 14:53:39 mcummings Exp $
- 03 jan 2002; Michael Cummings <mcummings@gentoo.org perl-5.6.1-r10:
+* perl-5.8.0-r8 (06 Jan 2003)
+
+ 06 Jan 2003; Michael Cummings <mcummings@gentoo.org> perl-5.8.0-r8:
+ Updated einfo, added libperl ebuild. I've placed the libperl rebuilder
+ in the filesdir and added a note about it to the pkg_postinstall.
+
+ 03 Jan 2002; Michael Cummings <mcummings@gentoo.org> perl-5.6.1-r10:
small fix to regex of x2p/makefile - cp'ied the process further down the
ebuild since this is rebuilt at each stage. This is for gcc-3.2 users
in particular and should take care of bug 12853
diff --git a/sys-devel/perl/files/digest-perl-5.8.0-r8 b/sys-devel/perl/files/digest-perl-5.8.0-r8
new file mode 100644
index 000000000000..517f2bed79ae
--- /dev/null
+++ b/sys-devel/perl/files/digest-perl-5.8.0-r8
@@ -0,0 +1 @@
+MD5 d9bdb180620306023fd35901a2878b62 perl-5.8.0.tar.gz 11023084
diff --git a/sys-devel/perl/files/libperl_rebuilder b/sys-devel/perl/files/libperl_rebuilder
new file mode 100644
index 000000000000..4d6e0b4ad527
--- /dev/null
+++ b/sys-devel/perl/files/libperl_rebuilder
@@ -0,0 +1,301 @@
+#!/bin/bash
+
+LOG=/tmp/system-update.log
+
+echo "--------------------------------------------------------------" >> $LOG
+echo "--------------------------------------------------------------" >> $LOG
+echo "--------------------------------------------------------------" >> $LOG
+
+
+echo 'Finding what perl modules you have installed...'
+echo 'Finding what perl modules you have installed...' >> $LOG
+
+
+cd /var/db/pkg/dev-perl
+PRE_MODULE_LIST=`
+ for i in $(ls -1| sort | uniq)
+ do
+ echo "dev-perl/${i}"
+ done | sed 's/-[0-9].*//g' | sort -u `
+
+
+
+echo "Preliminary Module List: $PRE_MODULE_LIST"
+echo "Preliminary Module List: $PRE_MODULE_LIST" >> $LOG
+
+#First, we clean up the perl module list - this is to avoid ambiguities later
+echo "Cleaning Module List..."
+echo "Cleaning Module List..." >> $LOG
+
+
+for MODULE in $PRE_MODULE_LIST;
+do
+ env-update
+ echo "Cleaning $MODULE"
+ echo "Cleaning $MODULE" >> $LOG
+ emerge -cp ${MODULE} 2>&1 | tee -a $LOG
+ emerge -c ${MODULE}
+done
+
+echo 'Rechecking what perl modules you have installed...'
+echo 'Rechecking what perl modules you have installed...' >> $LOG
+
+
+MODULE_LIST=`
+ for i in $(ls -1| sort | uniq)
+ do
+ echo "dev-perl/${i}"
+ done | sort -u `
+
+
+
+x=0
+while [ $x -lt 3 ] ; do
+let "x++"
+for MODULE in $MODULE_LIST;
+ do
+ env-update
+ echo "Rebuilding: $MODULE, pass ${x}"
+ echo "Rebuilding: $MODULE, pass ${x}" >> $LOG
+ if ! emerge --oneshot "=$MODULE"; then
+ echo "emerge $MODULE FAILED while in rebuild, pass ${x}."
+ echo "emerge $MODULE FAILED while in rebuild, pass ${x}." >> $LOG
+
+ else
+ echo "Done with $MODULE, pass ${x}"
+ echo "Done with $MODULE, pass ${x}" >> $LOG
+
+
+ fi
+ done
+
+done
+
+echo 'Preliminary Module Rebuild Complete. Now for rebuilding the rest...'
+echo 'Preliminary Module Rebuild Complete. Now for rebuilding the rest...' >> $LOG
+
+
+echo 'Finding broken packages...'
+echo 'Finding broken packages...' >> $LOG
+unset USE
+REBUILD_FAKED=""
+
+env-update
+
+# Note: `` == $()
+# REBUILD EXACTLY AS ON DISK. emerge =cat/package-version-rev
+LDD_LIST=`
+for i in $(find $(egrep -v ^# /etc/ld.so.conf) -type f -name '*.so*') \
+ $(find $(echo $PATH | sed 's/:/ /g') -type f -perm +0111);
+do
+ ldd ${i} 2>&1 | grep "libperl" - >/dev/null && qpkg -f -nc -v $i;
+done | sort -u`
+ORIGINAL_LIST="$LDD_LIST"
+
+if [ ! -z "$LDD_LIST" ]; then
+ REBUILD_LIST=`
+ echo $LDD_LIST | sed 's:\([^ ]\+\):=\1:g' | xargs emerge -p |
+ grep ebuild | sed 's:.*\] \([^ ]*\) .*:\1:'`
+fi
+
+
+
+if echo $REBUILD_LIST | egrep -q "no.*ebuilds to satisfy"; then
+ echo "Packages are installed that no longer exist in Gentoo."
+ echo "Determine what you need to do to fix this and try again."
+ echo "The package may have been moved to a different category."
+ echo
+ echo "Easiest course of action: unmerge these by explicit versions"
+ echo "and re-emerge them if they still exist."
+ echo 'emerge -C \=package-version'
+ echo "Notice: $REBUILD_LIST"
+ exit 1
+fi
+
+echo "Preliminary List: $REBUILD_LIST"
+echo "Preliminary List: $REBUILD_LIST" >> $LOG
+
+sleep 10s
+
+if ! emerge -p $(echo "$REBUILD_LIST" | sed 's:\([^ ]\+\):=\1:g') &>/dev/null; #'
+then
+ # System isn't up to date, or nothing here to do...
+ if [ ! -z "$LDD_LIST" ]; then
+ REBUILD_LIST=`
+ echo $LDD_LIST | sed 's:\([^ ]\+\):>=\1:g' | xargs emerge -p |
+ grep ebuild | sed 's:.*\] \([^ ]\+\) .*:\1:'`
+ fi
+fi
+
+
+
+
+echo -e "Rebuild list:\n$REBUILD_LIST"
+echo -e "Rebuild list:\n$REBUILD_LIST" >> $LOG
+
+sleep 20s
+
+if echo $REBUILD_LIST | egrep -q "no.*ebuilds to satisfy"; then
+ echo "Packages are installed that no longer exist in Gentoo."
+ echo "Determine what you need to do to fix this and try again."
+ echo "The package may have been moved to a different category."
+ echo
+ echo "Easiest course of action: unmerge these by explicit versions"
+ echo "and re-emerge them if they still exist."
+ echo 'emerge -C \=package-version'
+ echo "Notice: $REBUILD_LIST"
+ exit 1
+fi
+
+if echo $REBUILD_LIST | grep -q "have been masked"; then
+ echo "Masked packages are installed and need to be rebuilt..."
+ echo "Either unmask them, or emerge -C them all."
+ echo
+ echo "Easiest course of action: unmerge these by explicit versions"
+ echo 'emerge -C \=package-version'
+ echo "Notice: $REBUILD_LIST"
+ exit 1
+fi
+
+echo "Backing up the world file."
+cp /var/cache/edb/world /var/cache/edb/world.update_system_backup
+
+
+echo "Unmerging broken packages..."
+emerge -Cp $ORIGINAL_LIST | tee -a $LOG
+if ! emerge -C $ORIGINAL_LIST; then
+ echo
+ echo "There was a problem unmerging the broken packages."
+ echo "Please pass on your log file to a Gentoo Dev via bugzilla."
+ echo "Log file: $LOG"
+ echo
+ exit 1
+fi
+
+env-update
+
+echo "Restoring world file..."
+mv /var/cache/edb/world.update_system_backup /var/cache/edb/world
+
+REBUILD_LIST=`
+ echo $LDD_LIST | sed 's:\([^ ]\+\):\\>\\=\1:g' | xargs emerge -np $(cat /var/cache/edb/world) |
+ grep ebuild | sed 's:.*\] \([^ ]\+\) .*:\1:'`
+
+if echo $REBUILD_LIST | egrep -q "no.*ebuilds to satisfy"; then
+ echo "Packages are installed that no longer exist in Gentoo."
+ echo "Determine what you need to do to fix this and try again."
+ echo "The package may have been moved to a different category."
+ echo
+ echo "Easiest course of action: unmerge these by explicit versions"
+ echo "and re-emerge them if they still exist."
+ echo 'emerge -C \=package-version'
+ echo "Notice: $REBUILD_LIST"
+ exit 1
+fi
+
+if echo $REBUILD_LIST | grep -q "have been masked"; then
+ echo "Masked packages are installed and need to be rebuilt..."
+ echo "Either unmask them, or emerge -C them all."
+ echo
+ echo "Easiest course of action: unmerge these by explicit versions"
+ echo 'emerge -C \=package-version'
+ echo "Notice: $REBUILD_LIST"
+ exit 1
+fi
+
+#Join the perl module list and the binary list, sorting out dups
+FULL_LIST=`echo ${REBUILD_LIST} ${MODULE_LIST} | sort -u`
+
+echo -e "Complete rebuild list:\n$FULL_LIST"
+echo -e "Complete rebuild list:\n$FULL_LIST" >> $LOG
+
+
+CLEAN_FAILED=""
+MERGE_FAILED=""
+MERGE_DONE=""
+
+for PACKAGE in $FULL_LIST;
+do
+ env-update
+ echo "Rebuilding: $PACKAGE"
+ echo "Rebuilding: $PACKAGE" >> $LOG
+ if ! emerge --oneshot "=$PACKAGE"; then
+ echo "emerge $PACKAGE FAILED while in rebuild."
+ echo "emerge $PACKAGE FAILED while in rebuild." >> $LOG
+ MERGE_FAILED="$MERGE_FAILED \n$PACKAGE"
+ else
+ echo "Cleaning after $PACKAGE"
+ echo "Cleaning after $PACKAGE" >> $LOG
+ emerge -cp 2>&1 | tee -a $LOG
+ if ! emerge -c; then
+ echo "FAILED cleaning after $PACKAGE while in rebuild"
+ echo "FAILED cleaning after $PACKAGE while in rebuild" >> $LOG
+ CLEAN_FAILED="$CLEAN_FAILED \n$PACKAGE"
+ else
+ echo "Done with $PACKAGE"
+ echo "Done with $PACKAGE" >> $LOG
+ MERGE_DONE="$MERGE_DONE \n$PACKAGE"
+ fi
+ fi
+done
+
+# One last pass of the modules - this is to catch those modules that dep'd a binary from above
+
+for MODULE in $MODULE_LIST;
+ do
+ env-update
+ echo "Rebuilding: $MODULE"
+ echo "Rebuilding: $MODULE" >> $LOG
+ if ! emerge --oneshot "=$MODULE"; then
+ echo "emerge $MODULE FAILED while in final rebuild."
+ echo "emerge $MODULE FAILED while in final rebuild." >> $LOG
+
+ else
+ echo "Done with $MODULE"
+ echo "Done with $MODULE" >> $LOG
+
+
+ fi
+ done
+
+
+
+
+echo
+echo "Ok... We're done (really)..."
+echo -e "The following packages merged successfully:$MERGE_DONE"
+echo -e "The following packages merged successfully:$MERGE_DONE" >> $LOG
+echo "-------------------------------------------"
+echo
+
+if [ ! -z "$MERGE_FAILED" ]; then
+ echo -e "Merging failed on the following packages: $MERGE_FAILED"
+ echo -e "Merging failed on the following packages: $MERGE_FAILED" >> $LOG
+ echo "-----------------------------------------"
+else
+ echo "All packages merged successfully."
+ echo "All packages merged successfully." >> $LOG
+fi
+
+if [ ! -z "$CLEAN_FAILED" ]; then
+ echo -e "Weird: the following packages failed to clean:$CLEAN_FAILED"
+ echo -e "Weird: the following packages failed to clean:$CLEAN_FAILED" >> $LOG
+ echo "----------------------------------------------------------"
+else
+ echo "All packages cleaned successfully."
+ echo "All packages cleaned successfully." >> $LOG
+fi
+
+if [ -z "$MERGE_FAILED" ] && [ -z "$CLEAN_FAILED" ]; then
+ echo -e "\n\nEverything Completed Successfully."
+ echo -e "Have a nice day and thank you for flying with Gentoo."
+ echo -e "\n\nEverything Completed Successfully." >> $LOG
+ echo -e "Have a nice day and thank you for flying with Gentoo. :)" >> $LOG
+else
+ echo -e "\n\nThere were some issues... Check the log for details. :("
+ echo "Some or all of the failed packages may have been cause by a"
+ echo "dependancy failing earlier. Don't assume EVERYTHING is broken."
+ echo "Start with the first one to fail."
+ echo "Log is: $LOG"
+fi
+
diff --git a/sys-devel/perl/perl-5.8.0-r8.ebuild b/sys-devel/perl/perl-5.8.0-r8.ebuild
new file mode 100644
index 000000000000..84f13a3683df
--- /dev/null
+++ b/sys-devel/perl/perl-5.8.0-r8.ebuild
@@ -0,0 +1,425 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.8.0-r8.ebuild,v 1.1 2003/01/06 14:53:39 mcummings Exp $
+
+# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
+#
+# We split the perl ebuild into libperl and perl. The layout is as follows:
+#
+# libperl:test
+#
+# This is a slotted (SLOT=[0-9]*) ebuild, meaning we should be able to have a
+# few versions that are not binary compadible installed.
+#
+# How we get libperl.so multi-versioned, is by adding to the link command:
+#
+# -Wl,-soname -Wl,libperl.so.`echo $(LIBPERL) | cut -d. -f3`
+#
+# This gives us:
+#
+# $(LIBPERL): $& perl$(OBJ_EXT) $(obj) $(LIBPERLEXPORT)
+# $(LD) -o $@ $(SHRPLDFLAGS) perl$(OBJ_EXT) $(obj) \
+# -Wl,-soname -Wl,libperl.so.`echo $(LIBPERL) | cut -d. -f3`
+#
+# We then configure perl with LIBPERL set to:
+#
+# LIBPERL="libperl.so.${SLOT}.`echo ${PV} | cut -d. -f1,2`"
+#
+# Or with the variables defined in this ebuild:
+#
+# LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
+#
+# The result is that our 'soname' is 'libperl.so.${PERLSLOT}' (at the time of
+# writing this for perl-5.8.0, 'libperl.so.1'), causing all apps that is linked
+# to libperl to link to 'libperl.so.${PERLSLOT}'.
+#
+# If a new perl version, perl-z.y.z comes out that have a libperl not binary
+# compatible with the previous version, we just keep the previous libperl
+# installed, and all apps linked to it will still be able to use:
+#
+# libperl.so.${PERLSLOT}'
+#
+# while the new ones will link to:
+#
+# libperl.so.$((PERLSLOT+1))'
+#
+# perl:
+#
+# Not much to this one. It compiles with a static libperl.a, and are unslotted
+# (meaning SLOT=0). We thus always have the latest *stable* perl version
+# installed, with corrisponding version of libperl. The perl ebuild will of
+# course DEPEND on libperl.
+#
+# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
+
+
+IUSE="berkdb gdbm"
+
+inherit eutils
+
+# The slot of this binary compat version of libperl.so
+PERLSLOT="1"
+
+SHORT_PV="`echo ${PV} | cut -d. -f1,2`"
+MY_P="${P/lib}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
+SRC_URI="ftp://ftp.perl.org/pub/CPAN/src/${MY_P}.tar.gz"
+HOMEPAGE="http://www.perl.org"
+
+if [ "${PN}" = "libperl" ]
+then
+ SLOT="${PERLSLOT}"
+else
+ SLOT="0"
+fi
+
+LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
+
+LICENSE="Artistic GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~mips"
+
+DEPEND="sys-apps/groff
+ berkdb? ( >=sys-libs/db-3.2.3h-r3 =sys-libs/db-1.85-r1 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ >=sys-apps/portage-2.0.45-r4"
+if [ "${PN}" = "perl" ]
+then
+ DEPEND="${DEPEND}
+ =sys-devel/libperl-${PV}*"
+fi
+
+RDEPEND="berkdb? ( >=sys-libs/db-3.2.3h-r3 =sys-libs/db-1.85-r1 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+if [ "${PN}" = "libperl" ]
+then
+ # If we are installing a new version of libperl, we *have* to update perl as
+ # well, else all things linking to libperl.so will break at *build* time ..
+ PDEPEND=">=sys-devel/perl-${PV}"
+else
+ PDEPEND=">=dev-perl/Safe-2.09"
+fi
+
+pkg_setup() {
+ # I think this should rather be displayed if you *have* 'threads'
+ # in USE if it could break things ...
+ if [ -n "`use threads`" ]
+ then
+ ewarn ""
+ ewarn "PLEASE NOTE: If you wish to compile perl-5.8 with "
+ ewarn "threading enabled, you must restart this emerge "
+ ewarn "with USE=threads emerge...."
+ ewarn "Threading is not supported by all applications "
+ ewarn "that compile against perl. You use threading at "
+ ewarn "your own discretion. "
+ ewarn ""
+ sleep 15
+ fi
+
+ if [ "${PN}" = "perl" -a ! -f /usr/lib/${LIBPERL} ]
+ then
+ # Make sure whe have libperl installed ...
+ eerror "Cannot find /usr/lib/${LIBPERL}! Make sure that you"
+ eerror "have sys-libs/libperl installed properly ..."
+ die "Cannot find /usr/lib/${LIBPERL}!"
+ fi
+}
+
+src_unpack() {
+
+ unpack ${A}
+
+ if [ "${PN}" = "libperl" ]
+ then
+ # Fix the build scripts to create libperl with a soname of ${SLOT}.
+ # We basically add:
+ #
+ # -Wl,-soname -Wl,libperl.so.`echo $(LIBPERL) | cut -d. -f3`
+ #
+ # to the line that links libperl.so, and then set LIBPERL to:
+ #
+ # LIBPERL=libperl.so.${SLOT}.`echo ${PV} | cut -d. -f1,2`
+ #
+ cd ${S}; epatch ${FILESDIR}/${P}-create-libperl-soname.patch
+ else
+ # Fix the definition of 'int sockatmark(int);' in perl.h to have __THROW.
+ # This fixes bug #12605.
+ # <azarah@gentoo.org> (28 Dec 2002).
+ cd ${S}; epatch ${FILESDIR}/${P}-sockatmark-should-__THROW.patch
+ fi
+}
+
+src_compile() {
+
+ export LC_ALL="C"
+ local myconf=""
+
+ if [ "`use threads`" ]
+ then
+ einfo "using threads"
+ mythreading="-multi"
+ myconf="-Dusethreads ${myconf}"
+ myarch="${CHOST%%-*}-linux-thread"
+ else
+ myarch="${CHOST%%-*}-linux"
+ fi
+
+ if [ "`use gdbm`" ]
+ then
+ myconf="${myconf} -Di_gdbm"
+ fi
+ if [ "`use berkdb`" ]
+ then
+ myconf="${myconf} -Di_db -Di_ndbm"
+ else
+ myconf="${myconf} -Ui_db -Ui_ndbm"
+ fi
+ if [ "`use sparc`" ]
+ then
+ myconf="${myconf} -Ud_longdbl"
+ fi
+ if [ "`use sparc64`" ]
+ then
+ myconf="${myconf} -Ud_longdbl"
+ fi
+
+ if [ "${PN}" = "libperl" ]
+ then
+ rm -f config.sh Policy.sh
+
+ sh Configure -des \
+ -Darchname="${myarch}" \
+ -Dcccdlflags='-fPIC' \
+ -Dccdlflags='-rdynamic' \
+ -Dcc='gcc' \
+ -Dprefix='/usr' \
+ -Dvendorprefix='/usr' \
+ -Dsiteprefixx='/usr' \
+ -Dlocincpth=' ' \
+ -Doptimize="${CFLAGS}" \
+ -Duselargefiles \
+ -Duseshrplib \
+ -Dman3ext='3pm' \
+ -Dlibperl="${LIBPERL}" \
+ -Dd_dosuid \
+ -Dd_semctl_semun \
+ -Dcf_by='Gentoo' \
+ -Ud_csh \
+ ${myconf} || die
+
+ make -f Makefile depend || die "Couldn't make libperl.so depends"
+ make -f Makefile ${LIBPERL} || die "Unable to make libperl.so"
+ mv ${LIBPERL} ${WORKDIR}
+ else
+
+ cat > config.over <<EOF
+installprefix=${D}/usr
+installarchlib=\`echo \$installarchlib | sed "s!\$prefix!\$installprefix!"\`
+installbin=\`echo \$installbin | sed "s!\$prefix!\$installprefix!"\`
+installman1dir=\`echo \$installman1dir | sed "s!\$prefix!\$installprefix!"\`
+installman3dir=\`echo \$installman3dir | sed "s!\$prefix!\$installprefix!"\`
+installman1dir=`echo $installman1dir | sed "s!/share/share/!/share/!"`
+installman3dir=`echo $installman3dir | sed "s!/share/share/!/share/!"`
+installman1dir=\`echo \$installman1dir | sed "s!/usr/man/!/usr/share/man/!"\`
+installman3dir=\`echo \$installman3dir | sed "s!/usr/man/!/usr/share/man/!"\`
+man1ext=1
+man3ext=3pm
+installprivlib=\`echo \$installprivlib | sed "s!\$prefix!\$installprefix!"\`
+installscript=\`echo \$installscript | sed "s!\$prefix!\$installprefix!"\`
+installsitelib=\`echo \$installsitelib | sed "s!\$prefix!\$installprefix!"\`
+installsitearch=\`echo \$installsitearch | sed "s!\$prefix!\$installprefix!"\`
+EOF
+
+ sh Configure -des \
+ -Darchname="${myarch}" \
+ -Dcc='gcc' \
+ -Dprefix='/usr' \
+ -Dvendorprefix='/usr' \
+ -Dsiteprefixx='/usr' \
+ -Dlocincpth=' ' \
+ -Doptimize="${CFLAGS}" \
+ -Duselargefiles \
+ -Dd_dosuid \
+ -Dd_semctl_semun \
+ -Dman3ext='3pm' \
+ -Dcf_by='Gentoo' \
+ -Ud_csh \
+ ${myconf} || die "Unable to configure"
+
+ make || die "Unable to make"
+
+ make -i test CCDLFLAGS=
+ fi
+}
+
+src_install() {
+
+ export LC_ALL="C"
+
+ if [ "${PN}" = "libperl" ]
+ then
+ dolib.so ${WORKDIR}/${LIBPERL}
+ preplib
+ else
+ # Need to do this, else apps do not link to dynamic version of
+ # the library ...
+ local coredir="/usr/lib/perl5/${PV}/${myarch}${mythreading}/CORE"
+ dodir ${coredir}
+ dosym ../../../../${LIBPERL} ${coredir}/${LIBPERL}
+ dosym ../../../../${LIBPERL} ${coredir}/libperl.so.${PERLSLOT}
+ dosym ../../../../${LIBPERL} ${coredir}/libperl.so
+
+ # Fix for "stupid" modules and programs
+ dodir /usr/lib/perl5/site_perl/${PV}/${myarch}${mythreading}
+
+ make DESTDIR="${D}" \
+ INSTALLMAN1DIR="${D}/usr/share/man/man1" \
+ INSTALLMAN3DIR="${D}/usr/share/man/man3" \
+ install || die "Unable to make install"
+
+ cp -f utils/h2ph utils/h2ph_patched
+ epatch ${FILESDIR}/perl-5.8.0-RC2-special-h2ph-not-failing-on-machine_ansi_header.patch
+
+ LD_LIBRARY_PATH=. ./perl -Ilib utils/h2ph_patched \
+ -a -d ${D}/usr/lib/perl5/${PV}/${myarch}${mythreading} <<EOF
+asm/termios.h
+syscall.h
+syslimits.h
+syslog.h
+sys/ioctl.h
+sys/socket.h
+sys/time.h
+wait.h
+EOF
+
+ # This is to fix a missing c flag for backwards compat
+ dosed "s:ccflags=':ccflags='-DPERL5 :" \
+ /usr/lib/perl5/${PV}/${myarch}${mythreading}/Config.pm
+ dosed "s:cppflags=':cppflags='-DPERL5 :" \
+ /usr/lib/perl5/${PV}/${myarch}${mythreading}/Config.pm
+
+ # A poor fix for the miniperl issues
+ dosed 's:./miniperl:/usr/bin/perl:' /usr/lib/perl5/${PV}/ExtUtils/xsubpp
+ fperms 0444 /usr/lib/perl5/${PV}/ExtUtils/xsubpp
+ dosed 's:./miniperl:/usr/bin/perl:' /usr/bin/xsubpp
+ fperms 0755 /usr/bin/xsubpp
+
+
+ ./perl installman \
+ --man1dir="${D}/usr/share/man/man1" --man1ext='1' \
+ --man3dir="${D}/usr/share/man/man3" --man3ext='3'
+
+ # This removes ${D} from Config.pm
+ dosed /usr/lib/perl5/${PV}/${myarch}${mythreading}/Config.pm
+ dosed /usr/lib/perl5/${PV}/${myarch}${mythreading}/.packlist
+ fi
+
+ dodoc Changes* Artistic Copying README Todo* AUTHORS
+
+ if [ "${PN}" = "perl" ]
+ then
+ # HTML Documentation
+ # We expect errors, warnings, and such with the following.
+
+ dodir /usr/share/doc/${PF}/html
+ ./perl installhtml \
+ --podroot='.' \
+ --podpath='lib:ext:pod:vms' \
+ --recurse \
+ --htmldir="${D}/usr/share/doc/${PF}/html" \
+ --libpods='perlfunc:perlguts:perlvar:perlrun:perlop'
+ fi
+}
+
+pkg_postinst() {
+
+ # Make sure we do not have stale/invalid libperl.so 's ...
+ if [ -f "${ROOT}usr/lib/libperl.so" -a ! -L "${ROOT}usr/lib/libperl.so" ]
+ then
+ mv -f ${ROOT}usr/lib/libperl.so ${ROOT}usr/lib/libperl.so.old
+ fi
+
+ if [ "${PN}" = "libperl" ]
+ then
+ # Next bit is to try and setup the /usr/lib/libperl.so symlink
+ # properly ...
+ local libnumber="`ls -1 ${ROOT}usr/lib/libperl.so.?.* | grep -v '\.old' | wc -l`"
+ if [ "${libnumber}" -eq 1 ]
+ then
+ # Only this version of libperl is installed, so just link libperl.so
+ # to the *soname* version of it ...
+ ln -snf libperl.so.${PERLSLOT} ${ROOT}usr/lib/libperl.so
+ else
+ if [ -x "${ROOT}/usr/bin/perl" ]
+ then
+ # OK, we have more than one version .. first try to figure out
+ # if there are already a perl installed, if so, link libperl.so
+ # to that *soname* version of libperl.so ...
+ local perlversion="`${ROOT}/usr/bin/perl -V:version | cut -d\' -f2 | cut -d. -f1,2`"
+
+ cd ${ROOT}usr/lib
+ # Link libperl.so to the *soname* versioned lib ...
+ ln -snf `echo libperl.so.?.${perlversion} | cut -d. -f1,2,3` libperl.so
+ else
+ local x latest
+
+ # Nope, we are not so lucky ... try to figure out what version
+ # is the latest, and keep fingers crossed ...
+ for x in `ls -1 ${ROOT}usr/lib/libperl.so.?.*`
+ do
+ latest="${x}"
+ done
+
+ cd ${ROOT}usr/lib
+ # Link libperl.so to the *soname* versioned lib ...
+ ln -snf `echo ${latest##*/} | cut -d. -f1,2,3` libperl.so
+ fi
+ fi
+ else
+ local perllib="`readlink -f ${ROOT}usr/lib/libperl.so | sed -e 's:^.*/::'`"
+
+ # If we are installing perl, we need the /usr/lib/libperl.so symlink to
+ # point to the version of perl we are running, else builing something
+ # against libperl.so will break ...
+ if [ "${perllib}" != "${LIBPERL}" ]
+ then
+ # Delete stale symlinks
+ rm -f ${ROOT}usr/lib/libperl.so
+ rm -f ${ROOT}usr/lib/libperl.so.${PERLSLOT}
+ # Regenerate libperl.so.${PERLSLOT}
+ ln -snf ${LIBPERL} ${ROOT}usr/lib/libperl.so.${PERLSLOT}
+ # Create libperl.so (we use the *soname* versioned lib here ..)
+ ln -snf libperl.so.${PERLSLOT} ${ROOT}usr/lib/libperl.so
+ fi
+
+ if [ "${ROOT}" = "/" ]
+ then
+ ebegin "Converting C header files to the corresponding Perl format"
+ cd /usr/include; h2ph *.h sys/*.h
+ fi
+
+ eerror ""
+ eerror "If this is an upgrade to a perl 5.6.1 system,"
+ eerror "~OR~ an upgrade to a previous Gentoo release"
+ eerror "of perl 5.8.0, prior to -r8 "
+ eerror "you may need to recompile applications that"
+ eerror "were emerged against the old libperl.so"
+ eerror ""
+ eerror "${FILESDIR}/libperl_rebuilder is provided "
+ eerror "to assist with this. PLEASE DO NOT INTERRUPT"
+ eerror "THE RUNNING OF THIS SCRIPT. Part of the "
+ eerror "rebuilding of applications compiled against "
+ eerror "your old libperl involves temporarily unmerging"
+ eerror "them - interruptions could leave you with unmerged"
+ eerror "packages before they can be remerged."
+ eerror ""
+ eerror "If you have run the rebuilder and a package still gives"
+ eerror "you trouble, and re-emerging it fails to correct"
+ eerror "the problem, please check http://bugs.gentoo.org/"
+ eerror "for more information or to report a bug."
+ eerror ""
+ fi
+}
+
+