summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-10-06 12:21:16 +0000
committerRoy Marples <uberlord@gentoo.org>2006-10-06 12:21:16 +0000
commitf2a16996f002d0a752b58fc1e778a747405ab9b0 (patch)
treed3540513e99aea071f73ef01c61002c27ca9bddb /sys-freebsd
parentVersion bump. Bug #147971, reported by Hod <coil93 at mail.ee>. (diff)
downloadhistorical-f2a16996f002d0a752b58fc1e778a747405ab9b0.tar.gz
historical-f2a16996f002d0a752b58fc1e778a747405ab9b0.tar.bz2
historical-f2a16996f002d0a752b58fc1e778a747405ab9b0.zip
sparc has the same csu issue as amd64 - lacking a dir to install to
Package-Manager: portage-2.1.2_pre2-r2
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-lib/ChangeLog8
-rw-r--r--sys-freebsd/freebsd-lib/files/freebsd-lib-6.1-csu.patch20
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-6.1.ebuild4
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-6.2_beta1.ebuild4
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-6.2_beta2.ebuild4
5 files changed, 33 insertions, 7 deletions
diff --git a/sys-freebsd/freebsd-lib/ChangeLog b/sys-freebsd/freebsd-lib/ChangeLog
index 62f5c531f14a..e0765a2f0606 100644
--- a/sys-freebsd/freebsd-lib/ChangeLog
+++ b/sys-freebsd/freebsd-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-lib
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.30 2006/10/05 20:57:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.31 2006/10/06 12:21:16 uberlord Exp $
+
+ 06 Oct 2006; Roy Marples <uberlord@gentoo.org>
+ +files/freebsd-lib-6.1-csu.patch, -files/freebsd-lib-6.1-csu-amd64.patch,
+ freebsd-lib-6.1.ebuild, freebsd-lib-6.2_beta1.ebuild,
+ freebsd-lib-6.2_beta2.ebuild:
+ sparc has the same csu issue as amd64 - lacking a dir to install to
05 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> freebsd-lib-6.1.ebuild,
freebsd-lib-6.2_beta2.ebuild:
diff --git a/sys-freebsd/freebsd-lib/files/freebsd-lib-6.1-csu.patch b/sys-freebsd/freebsd-lib/files/freebsd-lib-6.1-csu.patch
new file mode 100644
index 000000000000..075f2780e693
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/freebsd-lib-6.1-csu.patch
@@ -0,0 +1,20 @@
+--- lib/csu/amd64/Makefile.orig 2006-07-04 07:49:58 -0300
++++ lib/csu/amd64/Makefile 2006-07-04 07:50:15 -0300
+@@ -16,6 +16,7 @@
+ ${CC} ${CFLAGS} -DGCRT -c -o gcrt1.o ${.CURDIR}/crt1.c
+
+ realinstall:
++ ${INSTALL} -d ${DESTDIR}${LIBDIR}
+ ${INSTALL} -o ${LIBOWN} -g ${LIBGRP} -m ${LIBMODE} \
+ ${OBJS} ${DESTDIR}${LIBDIR}
+
+--- lib/csu/sparc64/Makefile.orig 2006-10-06 15:13:55 +0100
++++ lib/csu/sparc64/Makefile 2006-10-06 15:15:06 +0100
+@@ -15,6 +15,7 @@
+ ${CC} ${CFLAGS} -DGCRT -c -o gcrt1.o ${.ALLSRC}
+
+ realinstall:
++ ${INSTALL} -d ${DESTDIR}${LIBDIR}
+ ${INSTALL} -o ${LIBOWN} -g ${LIBGRP} -m ${LIBMODE} \
+ ${OBJS} ${DESTDIR}${LIBDIR}
+
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-6.1.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-6.1.ebuild
index 5d11a3215366..08167da69e39 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-6.1.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-6.1.ebuild,v 1.11 2006/10/05 20:57:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-6.1.ebuild,v 1.12 2006/10/06 12:21:16 uberlord Exp $
inherit bsdmk freebsd flag-o-matic toolchain-funcs
@@ -80,7 +80,7 @@ PATCHES="${FILESDIR}/${PN}-bsdxml.patch
${FILESDIR}/${PN}-6.0-flex-2.5.31.patch
${FILESDIR}/${PN}-6.0-binutils-asm.patch
${FILESDIR}/${PN}-6.0-ssp.patch
- ${FILESDIR}/${P}-csu-amd64.patch"
+ ${FILESDIR}/${P}-csu.patch"
# Here we disable and remove source which we don't need or want
# In order:
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-6.2_beta1.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-6.2_beta1.ebuild
index 39ca13c7b4e9..e3ef8a4eb3fd 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-6.2_beta1.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-6.2_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-6.2_beta1.ebuild,v 1.2 2006/09/22 05:16:42 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-6.2_beta1.ebuild,v 1.3 2006/10/06 12:21:16 uberlord Exp $
inherit bsdmk freebsd flag-o-matic toolchain-funcs
@@ -78,7 +78,7 @@ PATCHES="${FILESDIR}/${PN}-bsdxml.patch
${FILESDIR}/${PN}-6.0-flex-2.5.31.patch
${FILESDIR}/${PN}-6.0-binutils-asm.patch
${FILESDIR}/${PN}-6.0-ssp.patch
- ${FILESDIR}/${PN}-6.1-csu-amd64.patch
+ ${FILESDIR}/${PN}-6.1-csu.patch
${FILESDIR}/${PN}-6.2-gcc41.patch"
# Here we disable and remove source which we don't need or want
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-6.2_beta2.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-6.2_beta2.ebuild
index 5a9bbf100081..18214257c2dc 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-6.2_beta2.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-6.2_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-6.2_beta2.ebuild,v 1.2 2006/10/05 20:57:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-6.2_beta2.ebuild,v 1.3 2006/10/06 12:21:16 uberlord Exp $
inherit bsdmk freebsd flag-o-matic toolchain-funcs
@@ -80,7 +80,7 @@ PATCHES="${FILESDIR}/${PN}-bsdxml.patch
${FILESDIR}/${PN}-6.0-flex-2.5.31.patch
${FILESDIR}/${PN}-6.0-binutils-asm.patch
${FILESDIR}/${PN}-6.0-ssp.patch
- ${FILESDIR}/${PN}-6.1-csu-amd64.patch
+ ${FILESDIR}/${PN}-6.1-csu.patch
${FILESDIR}/${PN}-6.2-gcc41.patch"
# Here we disable and remove source which we don't need or want