summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2008-02-23 10:33:36 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2008-02-23 10:33:36 +0000
commitec56516669eba08b4c39a1a5f23376003ca590ab (patch)
tree08a7e2b13c625105637f2f73fed8caaec2a276bc /sys-fs/dazuko
parentInitial import for dazuko (diff)
downloadhistorical-ec56516669eba08b4c39a1a5f23376003ca590ab.tar.gz
historical-ec56516669eba08b4c39a1a5f23376003ca590ab.tar.bz2
historical-ec56516669eba08b4c39a1a5f23376003ca590ab.zip
Version bump to support 2.6.24
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'sys-fs/dazuko')
-rw-r--r--sys-fs/dazuko/ChangeLog10
-rw-r--r--sys-fs/dazuko/dazuko-2.3.5_pre1.ebuild95
-rw-r--r--sys-fs/dazuko/files/dazuko-2.3.5_pre1-redirfs.patch31
3 files changed, 134 insertions, 2 deletions
diff --git a/sys-fs/dazuko/ChangeLog b/sys-fs/dazuko/ChangeLog
index bd8a78d4518a..10631ba1750b 100644
--- a/sys-fs/dazuko/ChangeLog
+++ b/sys-fs/dazuko/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/dazuko
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.26 2007/10/11 20:26:56 alonbl Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.27 2008/02/23 10:33:35 alonbl Exp $
+
+*dazuko-2.3.5_pre1 (23 Feb 2008)
+
+ 23 Feb 2008; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/dazuko-2.3.5_pre1-redirfs.patch, +dazuko-2.3.5_pre1.ebuild:
+ Version bump to support 2.6.24
*dazuko-2.3.4 (11 Oct 2007)
diff --git a/sys-fs/dazuko/dazuko-2.3.5_pre1.ebuild b/sys-fs/dazuko/dazuko-2.3.5_pre1.ebuild
new file mode 100644
index 000000000000..baf643a5aa4a
--- /dev/null
+++ b/sys-fs/dazuko/dazuko-2.3.5_pre1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.5_pre1.ebuild,v 1.1 2008/02/23 10:33:35 alonbl Exp $
+
+inherit linux-mod toolchain-funcs flag-o-matic
+
+DESCRIPTION="Linux kernel module and interface providing file access control"
+MY_P="${P/_/-}" # for -preN versions
+SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz"
+HOMEPAGE="http://www.dazuko.org"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="kernel_linux? (
+ >=virtual/linux-sources-2.6.20
+ >=sys-fs/redirfs-0.2
+)"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ [ "${KERNEL}" = "linux" ] && linux-mod_pkg_setup
+ # kernel settings
+ if [ "${KERNEL}" = "linux" ] && kernel_is le 2 4; then
+ BUILD_TARGETS="all"
+ else
+ EXTRA_CONFIG="--enable-redirfs"
+ BUILD_TARGETS="dummy_rule"
+ fi
+ MODULE_NAMES="dazuko(misc:)"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-redirfs.patch"
+}
+
+src_compile() {
+ if [ "${KERNEL}" = "FreeBSD" ]; then
+ KERNEL_DIR=/usr/src/sys
+ KBUILD_OUTPUT=/boot/modules
+ MAKE=make
+ fi
+ ./configure \
+ --without-dep \
+ --kernelsrcdir="${KERNEL_DIR}" \
+ --kernelobjdir="${KBUILD_OUTPUT}" \
+ ${EXTRA_CONFIG} \
+ || die "configure failed"
+
+ if [ "${KERNEL}" = "linux" ]; then
+ convert_to_m Makefile
+ linux-mod_src_compile
+ else
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" LDFLAGS="$(raw-ldflags)" || die
+ fi
+
+ emake -C library CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ if [ "${KERNEL}" = "linux" ]; then
+ linux-mod_src_install
+ else
+ insinto /boot/modules
+ doins "${S}"/dazuko.kld
+ exeinto /boot/modules
+ doexe "${S}"/dazuko.ko
+ fi
+
+ dolib.a library/libdazuko.a
+ insinto /usr/include
+ doins dazukoio.h
+ doins dazuko_events.h
+
+ dodoc README*
+}
+
+src_test() {
+ if [ "${EUID}" != 0 ]; then
+ ewarn "Cannot test while not root"
+ else
+ emake test || die "Test failed"
+ fi
+}
+
+pkg_postinst() {
+ [ "${KERNEL}" = "linux" ] && linux-mod_pkg_postinst
+}
+
+pkg_postrm() {
+ [ "${KERNEL}" = "linux" ] && linux-mod_pkg_postrm
+}
diff --git a/sys-fs/dazuko/files/dazuko-2.3.5_pre1-redirfs.patch b/sys-fs/dazuko/files/dazuko-2.3.5_pre1-redirfs.patch
new file mode 100644
index 000000000000..b0159d88051c
--- /dev/null
+++ b/sys-fs/dazuko/files/dazuko-2.3.5_pre1-redirfs.patch
@@ -0,0 +1,31 @@
+diff -urNp dazuko-2.3.5-pre1.org/configure dazuko-2.3.5-pre1/configure
+--- dazuko-2.3.5-pre1.org/configure 2008-02-20 23:05:25.000000000 +0200
++++ dazuko-2.3.5-pre1/configure 2008-02-23 11:26:09.000000000 +0200
+@@ -413,13 +413,13 @@ do_linux26()
+ if [ $LINUX26_USE_SYSCALLS -eq 0 -a $LINUX26_USE_REDIRFS -eq 1 ]
+ then
+ echo -n "checking for RedirFS source code... "
+- if [ ! -f "../redirfs/redirfs.h" ]
++ if [ ! -f "/usr/include/redirfs.h" ]
+ then
+ echo "not found"
+ echo "error: please make sure the RedirFS code is available as ../redirfs/"
+ exit 1
+ fi
+- echo "found (../redirfs)"
++ echo "found (/usr/include/redirfs)"
+
+ elif [ $LINUX26_USE_SYSCALLS -eq 0 -a $LINUX26_USE_REDIRFS -eq 0 ]
+ then
+diff -urNp dazuko-2.3.5-pre1.org/dazuko_redirfs.c dazuko-2.3.5-pre1/dazuko_redirfs.c
+--- dazuko-2.3.5-pre1.org/dazuko_redirfs.c 2008-02-20 23:06:04.000000000 +0200
++++ dazuko-2.3.5-pre1/dazuko_redirfs.c 2008-02-23 12:02:09.000000000 +0200
+@@ -33,7 +33,7 @@
+ #include <linux/namei.h>
+ #include <linux/dcache.h>
+ #include <linux/mount.h>
+-#include "../redirfs/redirfs.h"
++#include "/usr/include/redirfs.h"
+ #ifdef DEVFS_SUPPORT
+ #include <linux/devfs_fs_kernel.h>
+ #endif