summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-03-07 02:34:44 +0000
committerMike Frysinger <vapier@gentoo.org>2010-03-07 02:34:44 +0000
commit13f5697cd7937a708c2529e4da5bf94884df8452 (patch)
treed2d1596fb96ae52a9ddff0edbf0017ee4922227e /sys-fs/e2fsprogs
parentBumped to latest version for bug #291943. (diff)
downloadhistorical-13f5697cd7937a708c2529e4da5bf94884df8452.tar.gz
historical-13f5697cd7937a708c2529e4da5bf94884df8452.tar.bz2
historical-13f5697cd7937a708c2529e4da5bf94884df8452.zip
Version bump #306589 by Krzysztof Olędzki.
Package-Manager: portage-2.2_rc65/cvs/Linux x86_64
Diffstat (limited to 'sys-fs/e2fsprogs')
-rw-r--r--sys-fs/e2fsprogs/ChangeLog10
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.41.10.ebuild138
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.41.10-e2fsck-corruption.patch38
3 files changed, 184 insertions, 2 deletions
diff --git a/sys-fs/e2fsprogs/ChangeLog b/sys-fs/e2fsprogs/ChangeLog
index d1f4722f0232..4b5626335395 100644
--- a/sys-fs/e2fsprogs/ChangeLog
+++ b/sys-fs/e2fsprogs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/e2fsprogs
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.207 2009/12/07 11:11:31 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.208 2010/03/07 02:34:44 vapier Exp $
+
+*e2fsprogs-1.41.10 (07 Mar 2010)
+
+ 07 Mar 2010; Mike Frysinger <vapier@gentoo.org> +e2fsprogs-1.41.10.ebuild,
+ +files/e2fsprogs-1.41.10-e2fsck-corruption.patch:
+ Version bump #306589 by Krzysztof Olędzki.
07 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
e2fsprogs-1.41.9.ebuild:
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.41.10.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.41.10.ebuild
new file mode 100644
index 000000000000..cb276b577263
--- /dev/null
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.41.10.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.41.10.ebuild,v 1.1 2010/03/07 02:34:44 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="Standard EXT2/EXT3/EXT4 filesystem utilities"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 -x86-fbsd"
+IUSE="nls elibc_FreeBSD"
+
+RDEPEND="~sys-libs/${PN}-libs-${PV}
+ >=sys-apps/util-linux-2.16
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig
+ sys-apps/texinfo"
+
+pkg_setup() {
+ if [[ ! -e ${ROOT}/etc/mtab ]] ; then
+ # add some crap to deal with missing /etc/mtab #217719
+ ewarn "No /etc/mtab file, creating one temporarily"
+ echo "${PN} crap for src_test" > "${ROOT}"/etc/mtab
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
+ epatch "${FILESDIR}"/${PN}-1.41.8-makefile.patch
+ epatch "${FILESDIR}"/${PN}-1.40-fbsd.patch
+ epatch "${FILESDIR}"/${P}-e2fsck-corruption.patch
+ # use symlinks rather than hardlinks
+ sed -i \
+ -e 's:$(LN) -f $(DESTDIR).*/:$(LN_S) -f :' \
+ {e2fsck,misc}/Makefile.in || die
+ # blargh ... trick e2fsprogs into using e2fsprogs-libs
+ rm -rf doc
+ sed -i -r \
+ -e 's:@LIBINTL@:@LTLIBINTL@:' \
+ -e '/^LIB(COM_ERR|SS)/s:[$][(]LIB[)]/lib([^@]*)@LIB_EXT@:-l\1:' \
+ -e '/^DEPLIB(COM_ERR|SS)/s:=.*:=:' \
+ MCONFIG.in || die "muck libs" #122368
+ sed -i -r \
+ -e '/^LIB_SUBDIRS/s:lib/(et|ss)::g' \
+ Makefile.in || die "remove subdirs"
+
+ # Avoid rebuild
+ touch lib/ss/ss_err.h
+}
+
+src_compile() {
+ # Keep the package from doing silly things #261411
+ export VARTEXFONTS=${T}/fonts
+
+ # We want to use the "bsd" libraries while building on Darwin, but while
+ # building on other Gentoo/*BSD we prefer elf-naming scheme.
+ local libtype
+ case ${CHOST} in
+ *-darwin*) libtype=bsd;;
+ *) libtype=elf;;
+ esac
+
+ ac_cv_path_LDCONFIG=: \
+ econf \
+ --with-root-prefix=/ \
+ --enable-${libtype}-shlibs \
+ $(tc-has-tls || echo --disable-tls) \
+ --without-included-gettext \
+ $(use_enable nls) \
+ --disable-libblkid \
+ --disable-libuuid \
+ --disable-fsck \
+ --disable-uuidd
+ if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
+ eerror "INTL sanity check failed, aborting build."
+ eerror "Please post your ${S}/config.log file as an"
+ eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
+ die "Preventing included intl cruft from building"
+ fi
+ emake COMPILE_ET=compile_et MK_CMDS=mk_cmds || die
+
+ # Build the FreeBSD helper
+ if use elibc_FreeBSD ; then
+ cp "${FILESDIR}"/fsck_ext2fs.c .
+ emake fsck_ext2fs || die
+ fi
+}
+
+pkg_preinst() {
+ if [[ -r ${ROOT}/etc/mtab ]] ; then
+ if [[ $(<"${ROOT}"/etc/mtab) == "${PN} crap for src_test" ]] ; then
+ rm -f "${ROOT}"/etc/mtab
+ fi
+ fi
+}
+
+src_install() {
+ # need to set root_libdir= manually as any --libdir options in the
+ # econf above (i.e. multilib) will screw up the default #276465
+ emake \
+ STRIP=: \
+ root_libdir="/$(get_libdir)" \
+ DESTDIR="${D}" \
+ install install-libs || die
+ dodoc README RELEASE-NOTES
+
+ insinto /etc
+ doins "${FILESDIR}"/e2fsck.conf || die
+
+ # make sure symlinks are relative, not absolute, for cross-compiling
+ cd "${D}"/usr/$(get_libdir)
+ local x l
+ for x in lib* ; do
+ l=$(readlink "${x}")
+ [[ ${l} == /* ]] || continue
+ rm -f "${x}"
+ ln -s "../..${l}" "${x}"
+ done
+
+ if use elibc_FreeBSD ; then
+ # Install helpers for us
+ into /
+ dosbin "${S}"/fsck_ext2fs || die
+ doman "${FILESDIR}"/fsck_ext2fs.8
+
+ # filefrag is linux only
+ rm \
+ "${D}"/usr/sbin/filefrag \
+ "${D}"/usr/share/man/man8/filefrag.8 || die
+ fi
+}
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.10-e2fsck-corruption.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.41.10-e2fsck-corruption.patch
new file mode 100644
index 000000000000..4f24b9ada8cc
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/e2fsprogs-1.41.10-e2fsck-corruption.patch
@@ -0,0 +1,38 @@
+From: Theodore Ts'o <tytso@mit.edu>
+Date: Tue, 23 Feb 2010 04:51:26 +0000 (-0500)
+Subject: e2fsck: Fix bug which can cause e2fsck -fD to corrupt non-indexed directories
+X-Git-Url: http://git.kernel.org/?p=fs%2Fext2%2Fe2fsprogs.git;a=commitdiff_plain;h=53fbfb2bc3490d0ff317666322dd077c08116e0c
+
+e2fsck: Fix bug which can cause e2fsck -fD to corrupt non-indexed directories
+
+E2fsprogs 1.41.10 introduced a regression (in commit b71e018) where
+e2fsck -fD can corrupt non-indexed directories when are exists one or
+more file names which alphabetically sort before ".". This can happen
+with ext2 filesystems or for small directories (take less than a
+block) which contain filenames that begin with a space or some other
+punctuation mark.
+
+Fix this by making sure we never reorder the '.' or '..' entry in the
+directory, since they must be first.
+
+Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
+---
+
+diff --git a/e2fsck/rehash.c b/e2fsck/rehash.c
+index 780742e..ceb8543 100644
+--- a/e2fsck/rehash.c
++++ b/e2fsck/rehash.c
+@@ -763,7 +763,12 @@ retry_nohash:
+
+ /* Sort the list */
+ resort:
+- qsort(fd.harray, fd.num_array, sizeof(struct hash_entry), hash_cmp);
++ if (fd.compress)
++ qsort(fd.harray+2, fd.num_array-2, sizeof(struct hash_entry),
++ hash_cmp);
++ else
++ qsort(fd.harray, fd.num_array, sizeof(struct hash_entry),
++ hash_cmp);
+
+ /*
+ * Look for duplicates