summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-10-09 22:20:15 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-10-09 22:20:15 +0000
commit4466f95b7f90f91564c0f4e487eccc64a0b84638 (patch)
treeb8aacb0f5e4eb12f22e3ee9efb1226e095ed27e2 /sys-fs/fuse/fuse-2.7.0.ebuild
parentStable for SPARC (bug #195255). (diff)
downloadhistorical-4466f95b7f90f91564c0f4e487eccc64a0b84638.tar.gz
historical-4466f95b7f90f91564c0f4e487eccc64a0b84638.tar.bz2
historical-4466f95b7f90f91564c0f4e487eccc64a0b84638.zip
Make 2.6.23 support actually work for Sven <skoehler@upb.de> in bug 195300
Package-Manager: portage-2.1.3.12
Diffstat (limited to 'sys-fs/fuse/fuse-2.7.0.ebuild')
-rw-r--r--sys-fs/fuse/fuse-2.7.0.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/sys-fs/fuse/fuse-2.7.0.ebuild b/sys-fs/fuse/fuse-2.7.0.ebuild
index e9b5a02675ed..0c06fac91d76 100644
--- a/sys-fs/fuse/fuse-2.7.0.ebuild
+++ b/sys-fs/fuse/fuse-2.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.0.ebuild,v 1.7 2007/10/05 17:22:28 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.0.ebuild,v 1.8 2007/10/09 22:20:15 genstef Exp $
inherit linux-mod eutils libtool
@@ -16,14 +16,15 @@ PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
pkg_setup() {
if use kernel_linux ; then
- MODULE_NAMES="fuse(fs:${S}/kernel)"
- CONFIG_CHECK="@FUSE_FS:fuse"
- FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
- We will continue, but we wont build the module this time."
-
if kernel_is ge 2 6 23; then
CONFIG_CHECK="FUSE_FS"
FUSE_FS_ERROR="You need to build the FUSE module from the kernel source, because your kernel is too new"
+ else
+ MODULE_NAMES="fuse(fs:${S}/kernel)"
+ CONFIG_CHECK="@FUSE_FS:fuse"
+ FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+ We will continue, but we wont build the module this time."
+
fi
linux-mod_pkg_setup
kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an