summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Andreetta <satya@gentoo.org>2006-04-12 10:14:33 +0000
committerChristian Andreetta <satya@gentoo.org>2006-04-12 10:14:33 +0000
commitadd2c7e4191d98621f8fed0377f39c82c7d539d5 (patch)
tree4a3f0b720610509310c632253628dfed969be53f /sys-fs/unionfs/unionfs-1.1.4.ebuild
parentVersion bump. (diff)
downloadhistorical-add2c7e4191d98621f8fed0377f39c82c7d539d5.tar.gz
historical-add2c7e4191d98621f8fed0377f39c82c7d539d5.tar.bz2
historical-add2c7e4191d98621f8fed0377f39c82c7d539d5.zip
unionfs 1.1.4 version bump
Package-Manager: portage-2.1_pre7-r4
Diffstat (limited to 'sys-fs/unionfs/unionfs-1.1.4.ebuild')
-rw-r--r--sys-fs/unionfs/unionfs-1.1.4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-fs/unionfs/unionfs-1.1.4.ebuild b/sys-fs/unionfs/unionfs-1.1.4.ebuild
new file mode 100644
index 000000000000..c08ada12077c
--- /dev/null
+++ b/sys-fs/unionfs/unionfs-1.1.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.1.4.ebuild,v 1.1 2006/04/12 10:14:33 satya Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="Stackable unification file system, which can appear to merge the contents of several directories"
+HOMEPAGE="http://www.fsl.cs.sunysb.edu/project-unionfs.html"
+SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/unionfs/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="acl debug nfs"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ MODULE_NAMES="unionfs(fs:)"
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="LINUXSRC=${KV_DIR} KERNELVERSION=${KV_MAJOR}.${KV_MINOR}"
+}
+
+src_unpack() {
+ local user_Makefile=fistdev.mk EXTRACFLAGS=""
+
+ unpack ${A}
+ cd ${S}
+
+ if ! use debug; then
+ echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
+ EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_NDEBUG"
+ fi
+
+ if use acl; then
+ EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_XATTR" # -DFIST_SETXATTR_CONSTVOID"
+ elif use nfs; then
+ EXTRACFLAGS="${EXTRACFLAGS} -DNFS_SECURITY_HOLE"
+ fi
+
+ echo "EXTRACFLAGS=${EXTRACFLAGS}" >> ${user_Makefile}
+}
+
+src_install() {
+ dosbin unionctl uniondbg unionimap snapmerge
+ doman man/unionfs.4 man/unionctl.8 man/uniondbg.8 man/unionimap.8
+
+ linux-mod_src_install
+
+ dodoc INSTALL NEWS README ChangeLog patch-kernel.sh
+}
+