summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2014-01-20 17:03:09 +0000
committerMike Pagano <mpagano@gentoo.org>2014-01-20 17:03:09 +0000
commitad3fb6eddb3bc1820215178b03d806a52dd10420 (patch)
tree522990b1fd1a1fa30d036f4d4db31338261de3cb /sys-kernel/gentoo-sources/gentoo-sources-3.13.0.ebuild
parentamd64/x86 stable wrt bug #495506; Drop old. (diff)
downloadhistorical-ad3fb6eddb3bc1820215178b03d806a52dd10420.tar.gz
historical-ad3fb6eddb3bc1820215178b03d806a52dd10420.tar.bz2
historical-ad3fb6eddb3bc1820215178b03d806a52dd10420.zip
Support for namespace user.pax.* on tmpfs. Enable mic mute led in thinkpads. Zero copy for infiniband psm userspace driver. Disable Windows 8 compatibility for some Lenovo ThinkPads. Ensure that /dev/root doesn't appear in /proc/mounts when bootint without an initramfs. Do not lock when UMH is waiting on current thread spawned by linuxrc. Bootsplash successor by Michal Januszewski ported by Jeremy. Support for Pogoplug e02 (bug #460350), adjusted to be opt-in by TomWij. Add Gentoo Linux support config settings and defaults. BFQ patch
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0xB576E4E3
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-3.13.0.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.13.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.13.0.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.13.0.ebuild
new file mode 100644
index 000000000000..3a3a88131ef9
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.13.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.13.0.ebuild,v 1.1 2014/01/20 17:02:58 mpagano Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="1"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}