summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2003-10-31 02:16:08 +0000
committerSteve Arnold <nerdboy@gentoo.org>2003-10-31 02:16:08 +0000
commit9330e75ca67102c02cd565dba93ffcd0ad4c506e (patch)
tree30da13f7293fe02221c6e4fc45ec5e3c3e3664ce /sys-kernel/planet-ccrma-sources
parentAdd connection logging example and do away with config file settings -- snmpd... (diff)
downloadhistorical-9330e75ca67102c02cd565dba93ffcd0ad4c506e.tar.gz
historical-9330e75ca67102c02cd565dba93ffcd0ad4c506e.tar.bz2
historical-9330e75ca67102c02cd565dba93ffcd0ad4c506e.zip
added redhat kernel.h file
Diffstat (limited to 'sys-kernel/planet-ccrma-sources')
-rw-r--r--sys-kernel/planet-ccrma-sources/ChangeLog7
-rw-r--r--sys-kernel/planet-ccrma-sources/Manifest6
-rw-r--r--sys-kernel/planet-ccrma-sources/files/kernel.h27
-rw-r--r--sys-kernel/planet-ccrma-sources/planet-ccrma-sources-2.4.21-r1.ebuild81
4 files changed, 118 insertions, 3 deletions
diff --git a/sys-kernel/planet-ccrma-sources/ChangeLog b/sys-kernel/planet-ccrma-sources/ChangeLog
index 8cb77bd5ad87..6b38e81ea5a1 100644
--- a/sys-kernel/planet-ccrma-sources/ChangeLog
+++ b/sys-kernel/planet-ccrma-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/planet-ccrma-sources
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/planet-ccrma-sources/ChangeLog,v 1.3 2003/10/18 19:58:54 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/planet-ccrma-sources/ChangeLog,v 1.4 2003/10/31 02:16:06 nerdboy Exp $
+
+*planet-ccrma-sources-2.4.21-r1 (30 Oct 2003)
+
+ 30 Oct 2003; <nerdboy@gentoo.org> planet-ccrma-sources-2.4.21-r1.ebuild:
+ added RedHat kernel.h file due to scrllock's troubles
18 Oct 2003; <nerdboy@gentoo.org> planet-ccrma-sources-2.4.21.ebuild:
Bumped to x86 since it now works with Alsa 0.9.6 or better
diff --git a/sys-kernel/planet-ccrma-sources/Manifest b/sys-kernel/planet-ccrma-sources/Manifest
index 0772aa4ef0fb..6e61a35d85f3 100644
--- a/sys-kernel/planet-ccrma-sources/Manifest
+++ b/sys-kernel/planet-ccrma-sources/Manifest
@@ -1,4 +1,6 @@
-MD5 971ef526873d136bd1d9cf3ed4b1b348 ChangeLog 642
-MD5 fb311162d56a954e09b111a7d8d0340e metadata.xml 473
MD5 40c9d18749a7e7c3b92e710b0960046c planet-ccrma-sources-2.4.21.ebuild 2875
+MD5 fb311162d56a954e09b111a7d8d0340e metadata.xml 473
+MD5 8c04c2cc0532f809db24616727517c0c ChangeLog 821
+MD5 62e9dceabebcffd28f79547a316f3c8b planet-ccrma-sources-2.4.21-r1.ebuild 3108
MD5 59f5e2bd9a32c727f02ad6469a0adc68 files/digest-planet-ccrma-sources-2.4.21 164
+MD5 f19e34110f61d3b54f33c176cece8a27 files/kernel.h 473
diff --git a/sys-kernel/planet-ccrma-sources/files/kernel.h b/sys-kernel/planet-ccrma-sources/files/kernel.h
new file mode 100644
index 000000000000..5cb622efa108
--- /dev/null
+++ b/sys-kernel/planet-ccrma-sources/files/kernel.h
@@ -0,0 +1,27 @@
+/* This file is automatically generated at boot time. */
+#ifndef __BOOT_KERNEL_H_
+#define __BOOT_KERNEL_H_
+
+/* Kernel type i386 */
+
+#ifndef __MODULE_KERNEL_i386
+#define __MODULE_KERNEL_i386 1
+#endif
+
+#ifndef __BOOT_KERNEL_ENTERPRISE
+#define __BOOT_KERNEL_ENTERPRISE 0
+#endif
+
+#ifndef __BOOT_KERNEL_BIGMEM
+#define __BOOT_KERNEL_BIGMEM 0
+#endif
+
+#ifndef __BOOT_KERNEL_SMP
+#define __BOOT_KERNEL_SMP 0
+#endif
+
+#ifndef __BOOT_KERNEL_UP
+#define __BOOT_KERNEL_UP 1
+#endif
+
+#endif
diff --git a/sys-kernel/planet-ccrma-sources/planet-ccrma-sources-2.4.21-r1.ebuild b/sys-kernel/planet-ccrma-sources/planet-ccrma-sources-2.4.21-r1.ebuild
new file mode 100644
index 000000000000..2c55e34d93f4
--- /dev/null
+++ b/sys-kernel/planet-ccrma-sources/planet-ccrma-sources-2.4.21-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/planet-ccrma-sources/planet-ccrma-sources-2.4.21-r1.ebuild,v 1.1 2003/10/31 02:16:06 nerdboy Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="sources"
+inherit kernel || die
+
+OKV=2.4.21
+EXTRAVERSION="-1.ll.acpi"
+KV=${OKV}${EXTRAVERSION}
+S=${WORKDIR}/linux-${KV}
+
+# This package contains the Linux Kernel source for the version of the
+# RedHat Linux Kernel modified by the Planet CCRMA project.
+#
+# Do not report problems with this source package or the resulting compiled
+# compiled kernel to Red Hat, Inc. Red Hat is not responsible for this
+# package and has offered no warranties or promises that the kernels
+# resulting from the compilation of this package will work on anything
+# except specific versions of the Red Hat distribution and specific
+# compiler revisions.
+#
+# Gentoo provides this package without any guarantees that this kernel
+# will compile and run correctly and will only respond to bug reports
+# dealing with Gentoo specific packaging problems.
+
+# The easiest way to grab Red Hat kernel sources is from the rpm file
+# itself. We used to generate a patch against vanilla sources trees but
+# the added dependency of rpm2targz is minimal compared with having to
+# generate a new diff for every minor version update. (Also not to many
+# people have 2.4.18 vanilla source tarballs floating around these days)
+
+DEPEND="${DEPEND} app-arch/rpm2targz"
+
+DESCRIPTION="Kernel source used in Planet CCRMA custom audio upgrade (based on RedHat)"
+SRC_URI="http://ccrma-www.stanford.edu/planetccrma/mirror/redhat/linux/planetcore/9/en/os/i386/kernel-source-${KV}.i386.rpm
+mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="http://ccrma-www.stanford.edu/ http://www.kernel.org/ http://www.redhat.com/"
+KEYWORDS="x86"
+SLOT="${KV}"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+
+ # Defining TMPDIR avoids breaking if /tmp is mounted in RAM
+ # and too small to hold all the temp files.
+ # Portage probably shouldn't create any files outside of
+ # /var/tmp/portage just yet anyway. :)
+
+ TMPDIR=${T} rpm2targz ${DISTDIR}/kernel-source-${KV}.i386.rpm
+
+ tar xvzf kernel-source-${KV}.i386.tar.gz || die
+
+ tar xvzf ${DISTDIR}/${P}.tar.gz || die
+
+ mv usr/src/linux-${KV} ${WORKDIR} || die
+
+ cd ${S}
+
+ kernel_universal_unpack
+}
+
+pkg_postinst() {
+
+ ewarn "This kernel should now work with ALSA 0.9.6 or better."
+ ewarn "You'll need ~x86 for ALSA greater than 0.9.2"
+
+ einfo "A default kernel config has been provided in"
+ einfo "distfiles/planet-ccrma-sources-2.4.21.tar.gz."
+ einfo "Copy it to /usr/src/linux/.config and run make oldconfig."
+ einfo "Then edit to taste, but be careful not to tweak too much."
+ einfo "Just make sure to enable the devfs support."
+ einfo "And never run with scissors..."
+
+ ewarn "Mount your /boot partition and copy the file"
+ ewarn "PORTDIR/sys-kernel/planet-ccrma-sources/files/kernel.h"
+ ewarn "to /boot before you configure and build the kernel."
+ einfo "Don't ask why; it's a RedHat thing..."
+}