summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryon Roche <kain@gentoo.org>2002-06-12 07:28:42 +0000
committerBryon Roche <kain@gentoo.org>2002-06-12 07:28:42 +0000
commit77c52e264552aad1ebb41b0049320e59a7b591a2 (patch)
tree984b10330c52858cac81f1c1c5ac2a290d7224e2 /sys-kernel/ppc-sources
parent*** empty log message *** (diff)
downloadhistorical-77c52e264552aad1ebb41b0049320e59a7b591a2.tar.gz
historical-77c52e264552aad1ebb41b0049320e59a7b591a2.tar.bz2
historical-77c52e264552aad1ebb41b0049320e59a7b591a2.zip
ppc-sources-2.4.19-r6 tested stable for me. commiting masked.. will unmask tomorrow of testing permits.
Diffstat (limited to 'sys-kernel/ppc-sources')
-rw-r--r--sys-kernel/ppc-sources/ChangeLog9
-rw-r--r--sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r62
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.19-r6.ebuild114
3 files changed, 124 insertions, 1 deletions
diff --git a/sys-kernel/ppc-sources/ChangeLog b/sys-kernel/ppc-sources/ChangeLog
index 9538877d59de..8cf0e7f27bb1 100644
--- a/sys-kernel/ppc-sources/ChangeLog
+++ b/sys-kernel/ppc-sources/ChangeLog
@@ -1,6 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Id: ChangeLog,v 1.4 2002/05/27 02:26:44 kain Exp $
+# $Id: ChangeLog,v 1.5 2002/06/12 07:28:42 kain Exp $
+
+*ppc-sources-2.4.19-r6 (12 Jun 2002)
+
+ 12 Jun 2002; Kain <kain@kain.org> all :
+
+ We are back to a standard kernel + XFS. This will be the ppc-sources used
+ for the gentoo-ppc-1.2 bootcd.
*ppc-sources-2.4.19-r5 (26 May 2002)
diff --git a/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r6 b/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r6
new file mode 100644
index 000000000000..fbbe70f1b50e
--- /dev/null
+++ b/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.19-r6
@@ -0,0 +1,2 @@
+MD5 ad92859baaa837847b34d842b9f39d38 linux-2.4.18.tar.bz2 24161675
+MD5 f25e093cff4b41b696a7fd6cadd33f07 linux-gentoo-ppc-2.4.19-r6.patch.bz2 5327681
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.19-r6.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.19-r6.ebuild
new file mode 100644
index 000000000000..4a0f9a92c148
--- /dev/null
+++ b/sys-kernel/ppc-sources/ppc-sources-2.4.19-r6.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Kain X <kain@gentoo.org>
+# Maintainer: Kain X <kain@gentoo.org>
+# $Id: ppc-sources-2.4.19-r6.ebuild,v 1.1 2002/06/12 07:28:42 kain Exp $
+
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.18
+KV=${PVR}
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.19-pre10-ben0
+# ati.2 Xfree86 4.2.0 DRM
+# from http://oss.sgi.com/projects/xfs:
+# SGI XFS 1.1 (Official release code -- the most thoroughly tested)
+# from 2.4.19-pre9aa2
+# 74_super_quotaops-1 : 1 liner makes sure quota_ops are included in
+# super.c
+
+DESCRIPTION="Full sources for the Gentoo Linux PPC kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://ftp.sunsite.dk/projects/gentooppc/distfiles/linux-gentoo-ppc-${KV}.patch.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+GENTOOPATCH=${DISTDIR}/linux-gentoo-ppc-${KV}.patch.bz2
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux linux-${KV} || die
+ cd ${S}
+ pwd
+ bzcat ${GENTOOPATCH} | patch -p1 || die # Patch the kernel
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ make dep
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-ppc/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}