summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2006-09-04 18:58:04 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2006-09-04 18:58:04 +0000
commitb825b96eeaef2bb2c8e659285b0668348f7bd4ec (patch)
tree84d8897bb37968f3dea381fdf2960547bd200821 /sys-kernel/sparc-sources
parentAdd patch from Alex for sandbox not to deadlock devfs, see bug #146284. (diff)
downloadhistorical-b825b96eeaef2bb2c8e659285b0668348f7bd4ec.tar.gz
historical-b825b96eeaef2bb2c8e659285b0668348f7bd4ec.tar.bz2
historical-b825b96eeaef2bb2c8e659285b0668348f7bd4ec.zip
2.4.33.3 base, fixes CVE-2006-4145 and sun disklabel sector usage count. Rolled back to squashfs3.0 since 3.1 has issues with 2.4
Package-Manager: portage-2.1-r2
Diffstat (limited to 'sys-kernel/sparc-sources')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog9
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.33.39
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.33.3.ebuild36
3 files changed, 53 insertions, 1 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index 4729f679ac36..e650c0c2466a 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.106 2006/08/28 18:35:04 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.107 2006/09/04 18:58:04 gustavoz Exp $
+
+*sparc-sources-2.4.33.3 (04 Sep 2006)
+
+ 04 Sep 2006; Gustavo Zacarias <gustavoz@gentoo.org>
+ -sparc-sources-2.4.33.2-r1.ebuild, +sparc-sources-2.4.33.3.ebuild:
+ 2.4.33.3 base, fixes CVE-2006-4145 and sun disklabel sector usage count.
+ Rolled back to squashfs3.0 since 3.1 has issues with 2.4
*sparc-sources-2.4.33.2-r1 (28 Aug 2006)
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.33.3 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.33.3
new file mode 100644
index 000000000000..7f4a91c46cec
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.33.3
@@ -0,0 +1,9 @@
+MD5 807eee53a4270659d568a542c4d08ea3 linux-2.4.33.tar.bz2 31161078
+RMD160 6acdabafecfdc69f3f5b0203eac154ac1c39c44b linux-2.4.33.tar.bz2 31161078
+SHA256 a1d8403a72dbe7a4d63986e71e22e6eeb32fe2e2e949f40c3f9f3bb6496ee47a linux-2.4.33.tar.bz2 31161078
+MD5 3597da59e82a495d97e1f0ecd8fc5d4d patch-2.4.33.3.bz2 6069
+RMD160 dba22420a3c3445042f1193475718fdf4c5a6c3d patch-2.4.33.3.bz2 6069
+SHA256 926223533c33791770a8ae134d731aa3f98b67a2b5676426ea74a1a888eb5a7b patch-2.4.33.3.bz2 6069
+MD5 29dc0546cb2bff4e4c486673143e9685 patches-2.4.33.3-sparc.tar.bz2 191949
+RMD160 a667b0c99aba48a38e3f2a16928a9d7c7b81213a patches-2.4.33.3-sparc.tar.bz2 191949
+SHA256 f2018fd6aaaf56d2672d6307cce7a2e0bd7c57fff20aaa637713ae9aec99dd23 patches-2.4.33.3-sparc.tar.bz2 191949
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.33.3.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.33.3.ebuild
new file mode 100644
index 000000000000..460c9fe06460
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.33.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.33.3.ebuild,v 1.1 2006/09/04 18:58:04 gustavoz Exp $
+
+ETYPE="sources"
+IUSE="ultra1"
+inherit kernel-2
+detect_version
+
+PATCH_BASE="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}${EXTRAVERSION}"
+
+SSV_URI="mirror://gentoo/patches-${PATCH_BASE}.tar.bz2"
+
+KEYWORDS="-* ~sparc"
+DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
+UNIPATCH_LIST="${DISTDIR}/patches-${PATCH_BASE}.tar.bz2"
+SRC_URI="${KERNEL_URI} ${SSV_URI}"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org"
+
+pkg_setup() {
+ use ultra1 || UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE} 2000_U1-hme-lockup.patch"
+}
+
+pkg_postinst() {
+ postinst_sources
+
+ if [ ! -r "/proc/openprom/name" -o "cat /proc/openprom/name 2>/dev/null" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+
+}