summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2004-02-21 19:13:29 +0000
committerChristian Birchinger <joker@gentoo.org>2004-02-21 19:13:29 +0000
commitd835b90fb8aaa943c332630958ae574f95ef0024 (patch)
tree3a12bdb48fc8e44b2639f082fa7874a78e5c9de1 /sys-kernel/sparc-sources
parentInitial import. (diff)
downloadhistorical-d835b90fb8aaa943c332630958ae574f95ef0024.tar.gz
historical-d835b90fb8aaa943c332630958ae574f95ef0024.tar.bz2
historical-d835b90fb8aaa943c332630958ae574f95ef0024.zip
Version bump
Diffstat (limited to 'sys-kernel/sparc-sources')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog8
-rw-r--r--sys-kernel/sparc-sources/Manifest4
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.252
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.25.ebuild61
4 files changed, 73 insertions, 2 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index 0651acfecebc..92d0f9fe070b 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.49 2004/02/19 00:56:35 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.50 2004/02/21 19:13:28 joker Exp $
+
+*sparc-sources-2.4.25 (21 Feb 2004)
+
+ 21 Feb 2004; Christian Birchinger <joker@gentoo.org>
+ sparc-sources-2.4.25.ebuild:
+ Version bump
19 Feb 2004; Christian Birchinger <joker@gentoo.org>
sparc-sources-2.4.24-r2.ebuild:
diff --git a/sys-kernel/sparc-sources/Manifest b/sys-kernel/sparc-sources/Manifest
index 9ad525ed215a..2a2d84bf3b0e 100644
--- a/sys-kernel/sparc-sources/Manifest
+++ b/sys-kernel/sparc-sources/Manifest
@@ -1,8 +1,10 @@
MD5 0a01f4b4ff50037a35981138001fe905 sparc-sources-2.4.24-r2.ebuild 2137
-MD5 40d6d2fad0ab4c084932b58c6f2b19c9 ChangeLog 8451
+MD5 b8ee5630cf4a3ddd666829bcebf2eaa2 sparc-sources-2.4.25.ebuild 2140
+MD5 3c10209a47e22cdf06b79a55840432b4 ChangeLog 8590
MD5 6706a601c155869440dcb544e3759a04 metadata.xml 381
MD5 935f3a9c9a5209ad79a0cdbf9ca4b610 files/U1-hme-lockup.patch 263
MD5 296a426c487b12676eaa07a6abfc2edc files/digest-sparc-sources-2.4.24-r2 143
+MD5 a0aa4a974abbf9f5e698cf474c2716b2 files/digest-sparc-sources-2.4.25 140
MD5 25553b42e5daa2638570a8b019a35069 files/generate-asm-sparc 1656
MD5 13f20ae89e814fb87621b471e4d2ca68 files/2.4.19/sparc-asm_offsets.h 23156
MD5 89fb52efc9018f970ceeeaadac9c0f9e files/2.4.19/sparc64-asm_offsets.h 35521
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.25 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.25
new file mode 100644
index 000000000000..aeda787d6a0d
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.25
@@ -0,0 +1,2 @@
+MD5 5fc8e9f43fa44ac29ddf9a9980af57d8 linux-2.4.25.tar.bz2 30626548
+MD5 ebf1bf200cdc568b8bf9c07fc88327df patches-2.4.25-sparc.tar.bz2 141155
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.25.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.25.ebuild
new file mode 100644
index 000000000000..105083729acb
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.25.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.25.ebuild,v 1.1 2004/02/21 19:13:28 joker Exp $
+
+IUSE="ultra1"
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="grsecurity" would not patch any patches whose names match
+# *grsecurity*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+inherit kernel
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+[ "$OKV" == "" ] && OKV="${PV}"
+
+EXTRAVERSION="-${PN/-*/}"
+[ ! "${PR}" == "r0" ] && EXTRAVERSION="${EXTRAVERSION}-${PR}"
+KV="${OKV}${EXTRAVERSION}"
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/sparc-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${KV}.tar.bz2"
+
+S=${WORKDIR}/linux-${KV}
+KEYWORDS="~x86 -ppc ~sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die "Error moving kernel source tree to linux-${KV}"
+ cd ${KV} || die "Unable to cd into ${KV}"
+
+ kernel_src_unpack
+
+ # Patch the HME driver only on Ultra1 machines.
+ use ultra1 && epatch ${FILESDIR}/U1-hme-lockup.patch
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ # Display SUN Ultra 1 HME warning if it can be detected or if the machinetype is unknown.
+ if [ ! -r "/proc/openprom/name" -o "`cat /proc/openprom/name 2>/dev/null`" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+}