summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tgall@gentoo.org>2004-05-19 02:53:28 +0000
committerTom Gall <tgall@gentoo.org>2004-05-19 02:53:28 +0000
commit95087924309d5e16dea81982327b6748ae45a6da (patch)
treeadf8a308d7f82c6302ebf63b65ca7d8a8969f463 /sys-kernel
parentCloses #51099 (diff)
downloadhistorical-95087924309d5e16dea81982327b6748ae45a6da.tar.gz
historical-95087924309d5e16dea81982327b6748ae45a6da.tar.bz2
historical-95087924309d5e16dea81982327b6748ae45a6da.zip
new stable ppc64 kernel version
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ppc64-sources/ChangeLog7
-rw-r--r--sys-kernel/ppc64-sources/Manifest4
-rw-r--r--sys-kernel/ppc64-sources/files/digest-ppc64-sources-2.6.62
-rw-r--r--sys-kernel/ppc64-sources/ppc64-sources-2.6.6.ebuild98
4 files changed, 109 insertions, 2 deletions
diff --git a/sys-kernel/ppc64-sources/ChangeLog b/sys-kernel/ppc64-sources/ChangeLog
index ec9ee801e22b..063caef87c70 100644
--- a/sys-kernel/ppc64-sources/ChangeLog
+++ b/sys-kernel/ppc64-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/ppc64-sources
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc64-sources/ChangeLog,v 1.3 2004/04/15 12:21:47 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc64-sources/ChangeLog,v 1.4 2004/05/19 02:53:28 tgall Exp $
+
+*ppc64-sources-2.6.6 (18 May 2004)
+
+ 18 May 2004; Tom Gall <tgall@gentoo.org> ppc64-sources-2.6.6.ebuild:
+ new version
*ppc64-sources-2.6.4-r1 (15 Apr 2004)
diff --git a/sys-kernel/ppc64-sources/Manifest b/sys-kernel/ppc64-sources/Manifest
index bc38208456af..12cd3e129b83 100644
--- a/sys-kernel/ppc64-sources/Manifest
+++ b/sys-kernel/ppc64-sources/Manifest
@@ -1,5 +1,7 @@
-MD5 20766856e59ec6a966e724126c90b629 ChangeLog 604
+MD5 53f408231bde7c115520a94a060b5efc ChangeLog 722
MD5 28d3906c49ca260f1bc0b39170d02ed0 metadata.xml 405
MD5 0c75fc39d6ac07bb4df3d77afcf27c31 ppc64-sources-2.6.4-r1.ebuild 3167
+MD5 e8e396a215e18576849cd4b0829cc43b ppc64-sources-2.6.6.ebuild 2925
MD5 37846cc823c056554078424877d57ec4 files/digest-ppc64-sources-2.6.4-r1 198
MD5 31ec7b4310dd7be3e34aab0204f9b1e8 files/ppc64-sources-2.6.4.CAN-2004-0109.patch 2072
+MD5 2db6399bd9b0f2b1358c0ea48a50b757 files/digest-ppc64-sources-2.6.6 136
diff --git a/sys-kernel/ppc64-sources/files/digest-ppc64-sources-2.6.6 b/sys-kernel/ppc64-sources/files/digest-ppc64-sources-2.6.6
new file mode 100644
index 000000000000..22e84f0ece4d
--- /dev/null
+++ b/sys-kernel/ppc64-sources/files/digest-ppc64-sources-2.6.6
@@ -0,0 +1,2 @@
+MD5 5218790bc3db41e77a7422969639a9ad linux-2.6.6.tar.bz2 34896138
+MD5 30410b7427515bbb748586fceb3958b0 ppc64-ames266-1.patch.gz 2179783
diff --git a/sys-kernel/ppc64-sources/ppc64-sources-2.6.6.ebuild b/sys-kernel/ppc64-sources/ppc64-sources-2.6.6.ebuild
new file mode 100644
index 000000000000..6f89b952ac53
--- /dev/null
+++ b/sys-kernel/ppc64-sources/ppc64-sources-2.6.6.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc64-sources/ppc64-sources-2.6.6.ebuild,v 1.1 2004/05/19 02:53:28 tgall Exp $
+
+ETYPE="sources"
+inherit kernel
+
+OKV="2.6.6"
+
+######## last BK changeset in this patch: 1.1390
+
+AMV=1
+EXTRAVERSION="-${PR}"
+
+KV=${PV}${EXTRAVERSION}
+S=${WORKDIR}/${PN}-${KV}
+
+inherit eutils
+IUSE="extlib"
+
+# What's in this kernel?
+# INCLUDED: 2.6 ames snapshot
+
+DESCRIPTION="Full sources for the linux kernel 2.6 with ames's patchset"
+SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${OKV}.tar.bz2
+ mirror://kernel/ppc64-ames266-1.patch.gz"
+KEYWORDS="-ppc ppc64"
+DEPEND=" extlib? ( dev-libs/ucl )"
+RDEPEND="sys-apps/module-init-tools"
+SLOT=${KV}
+PROVIDE="virtual/linux-sources
+ virtual/alsa"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+
+ mv linux-${OKV} ${S}
+ cd ${S}
+
+ cp ${DISTDIR}/ppc64-ames266-1.patch.gz ${WORKDIR}
+ gunzip ${WORKDIR}/ppc64-ames266-1.patch.gz
+ epatch ${WORKDIR}/ppc64-ames266-1.patch
+ rm ${WORKDIR}/ppc64-ames266-1.patch
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ # also fix the EXTRAVERSION
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+
+ cd Documentation/DocBook
+ sed -e "s:db2:docbook2:g" Makefile > Makefile.new \
+ && mv Makefile.new Makefile
+ cd ${S}
+
+ # This is needed on > 2.5
+ MY_ARCH=${ARCH}
+ unset ARCH
+ # Sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die "make mrproper died"
+ ARCH=${MY_ARCH}
+}
+
+src_install() {
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+}
+pkg_postinst() {
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ ln -sf ppc64-sources-2.6.6-r0 ${ROOT}/usr/src/linux
+ fi
+
+ ewarn "Please note that ptyfs support has been removed from devfs"
+ ewarn "in the later 2.6 kernels, and you have to compile it in now,"
+ ewarn "or else you will get errors when trying to open a pty."
+ ewarn "The option is File systems->Pseudo filesystems->/dev/pts"
+ ewarn "filesystem."
+ echo
+ ewarn "Also, note that you must compile in support for"
+ ewarn "input devices (Input device support->Input devices),"
+ ewarn "the virtual terminal (Character Devices->Virtual terminal),"
+ ewarn "and the vt_console (Character Devices->Support for console...)."
+ ewarn "Otherwise, you will get the dreaded \"Uncompressing the Kernel\""
+ ewarn "error."
+ echo
+ ewarn "DONT enable preempt as it's very broken on ppc64, also"
+ ewarn "rivafb and the mac floppy drivers are both broken. NVidia"
+ ewarn "users should use the openfirmware framebuffer for now."
+ echo
+ einfo "Consult http://www.linux.org.uk/~davej/docs/post-halloween-2.6.txt"
+ einfo "for more info about the 2.6 series."
+ echo
+}