summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-04-30 23:37:47 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-04-30 23:37:47 +0000
commit9b09c94c04ae982fdf27023b38bbb5c84642e462 (patch)
tree73fe5a4faa96f5440bbec47a94a98fc0fa5627bd /sys-kernel
parentmasking out new kernels (diff)
downloadhistorical-9b09c94c04ae982fdf27023b38bbb5c84642e462.tar.gz
historical-9b09c94c04ae982fdf27023b38bbb5c84642e462.tar.bz2
historical-9b09c94c04ae982fdf27023b38bbb5c84642e462.zip
new kerns
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r12
-rw-r--r--sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r22
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r1.ebuild124
3 files changed, 128 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r1 b/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r1
new file mode 100644
index 000000000000..b35d56d7b0c1
--- /dev/null
+++ b/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r1
@@ -0,0 +1,2 @@
+MD5 ad92859baaa837847b34d842b9f39d38 linux-2.4.18.tar.bz2 24161675
+MD5 96f5f59463511c8c2744fb05500f2b48 linux-gentoo-2.4.19-gentoo-r1.patch.bz2 5479031
diff --git a/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r2 b/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r2
new file mode 100644
index 000000000000..9a29ffd7d64e
--- /dev/null
+++ b/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r2
@@ -0,0 +1,2 @@
+MD5 ad92859baaa837847b34d842b9f39d38 linux-2.4.18.tar.bz2 24161675
+MD5 deaa169c20560e5c85429b99d7751663 linux-gentoo-2.4.19-gentoo-r2.patch.bz2 5521794
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r1.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r1.ebuild
new file mode 100644
index 000000000000..65aa6c8bcde9
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r1.ebuild,v 1.1 2002/04/30 23:37:47 drobbins Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.18
+KV=2.4.19-gentoo-r1
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.19-pre7-ac2
+# grsecurity-1.9.4 (with fixes and a fix for an NVIDIA driver compile problem)
+# 2.4.19-pre7-low-latency
+# htb2 (QoS support)
+# 00_3.5G-address-space-4 (from Andrea Archangeli)
+# preempt-kernel-rml-2.4.19-pre7-ac2-1.patch
+# preempt-stats-rml-2.4.19-pre5-ac3-1.patch
+# 1000 HZ patch
+# from jp10 (http://www.infolinux.de/jp10):
+# 41_twofish-2.4.3.bz2
+# 50_crypto-patch-int-2.4.18.1.bz2
+# 50_crypto-patch-int-2.4.18.1-1.bz2
+# 51_loop-jari-2.4.16.0.bz2
+# 90_freeswan-1.97.bz2
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}.patch.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux linux-${KV} || die
+ cd ${S}
+ cat ${DISTDIR}/linux-gentoo-${KV}.patch.bz2 | bzip2 -d | patch -p1 || die
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ cd ${ROOT}usr/src/linux-${KV}
+ make mrproper
+ if [ -e "${ROOT}usr/src/linux/.config" ]
+ then
+ cp "${ROOT}usr/src/linux/.config" .config
+ #we only make dep when upgrading to a new kernel (with existing config)
+ #The default setting will be selected.
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ make dep
+ else
+ cp "${ROOT}usr/src/linux-${KV}/arch/i386/defconfig" .config
+ fi
+ #remove /usr/src/linux symlink
+ rm -f ${ROOT}/usr/src/linux
+ #set up a new one
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+}