summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-04-30 12:57:55 +0000
committerMike Frysinger <vapier@gentoo.org>2010-04-30 12:57:55 +0000
commit720b8e52178131d1e59752c5235e703e70bde626 (patch)
tree5296e7fb2326ebd98242baf6dc67001731c24ec9 /sys-libs/cracklib
parentVersion bump and old version cleanup (diff)
downloadhistorical-720b8e52178131d1e59752c5235e703e70bde626.tar.gz
historical-720b8e52178131d1e59752c5235e703e70bde626.tar.bz2
historical-720b8e52178131d1e59752c5235e703e70bde626.zip
old
Diffstat (limited to 'sys-libs/cracklib')
-rw-r--r--sys-libs/cracklib/cracklib-2.8.13-r1.ebuild65
-rw-r--r--sys-libs/cracklib/cracklib-2.8.13.ebuild67
2 files changed, 0 insertions, 132 deletions
diff --git a/sys-libs/cracklib/cracklib-2.8.13-r1.ebuild b/sys-libs/cracklib/cracklib-2.8.13-r1.ebuild
deleted file mode 100644
index 0f7a62919c14..000000000000
--- a/sys-libs/cracklib/cracklib-2.8.13-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.8.13-r1.ebuild,v 1.3 2010/03/08 22:35:46 zmedico Exp $
-
-inherit eutils toolchain-funcs multilib libtool
-
-MY_P=${P/_}
-DESCRIPTION="Password Checking Library"
-HOMEPAGE="http://sourceforge.net/projects/cracklib"
-SRC_URI="mirror://sourceforge/cracklib/${MY_P}.tar.gz"
-
-LICENSE="CRACKLIB"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls python"
-
-DEPEND="python? ( <dev-lang/python-3 )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- # workaround #195017
- if has unmerge-orphans ${FEATURES} && has_version "<${CATEGORY}/${PN}-2.8.10" ; then
- eerror "Upgrade path is broken with FEATURES=unmerge-orphans"
- eerror "Please run: FEATURES=-unmerge-orphans emerge cracklib"
- die "Please run: FEATURES=-unmerge-orphans emerge cracklib"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-python-linkage.patch #246747
- elibtoolize #269003
-}
-
-src_compile() {
- econf \
- --with-default-dict='$(libdir)/cracklib_dict' \
- $(use_enable nls) \
- $(use_with python) \
- || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- rm -r "${D}"/usr/share/cracklib
-
- # move shared libs to /
- gen_usr_ldscript -a crack
-
- insinto /usr/share/dict
- doins dicts/cracklib-small || die "word dict"
-
- dodoc AUTHORS ChangeLog NEWS README*
-}
-
-pkg_postinst() {
- if [[ ${ROOT} == "/" ]] ; then
- ebegin "Regenerating cracklib dictionary"
- create-cracklib-dict /usr/share/dict/* > /dev/null
- eend $?
- fi
-}
diff --git a/sys-libs/cracklib/cracklib-2.8.13.ebuild b/sys-libs/cracklib/cracklib-2.8.13.ebuild
deleted file mode 100644
index 66c7c6721294..000000000000
--- a/sys-libs/cracklib/cracklib-2.8.13.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.8.13.ebuild,v 1.13 2010/03/08 22:35:46 zmedico Exp $
-
-inherit eutils toolchain-funcs multilib libtool
-
-MY_P=${P/_}
-DESCRIPTION="Password Checking Library"
-HOMEPAGE="http://sourceforge.net/projects/cracklib"
-SRC_URI="mirror://sourceforge/cracklib/${MY_P}.tar.gz"
-
-LICENSE="CRACKLIB"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls python"
-
-DEPEND="python? ( <dev-lang/python-3 )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- # workaround #195017
- if has unmerge-orphans ${FEATURES} && has_version "<${CATEGORY}/${PN}-2.8.10" ; then
- eerror "Upgrade path is broken with FEATURES=unmerge-orphans"
- eerror "Please run: FEATURES=-unmerge-orphans emerge cracklib"
- die "Please run: FEATURES=-unmerge-orphans emerge cracklib"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-python-linkage.patch #246747
- elibtoolize #269003
-}
-
-src_compile() {
- econf \
- --with-default-dict='$(libdir)/cracklib_dict' \
- $(use_enable nls) \
- $(use_with python) \
- || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- rm -r "${D}"/usr/share/cracklib
-
- # move shared libs to /
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/ || die "could not move shared"
- gen_usr_ldscript libcrack.so
-
- insinto /usr/share/dict
- doins dicts/cracklib-small || die "word dict"
-
- dodoc AUTHORS ChangeLog NEWS README*
-}
-
-pkg_postinst() {
- if [[ ${ROOT} == "/" ]] ; then
- ebegin "Regenerating cracklib dictionary"
- create-cracklib-dict /usr/share/dict/* > /dev/null
- eend $?
- fi
-}