summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-05-03 11:54:00 +0000
committerMamoru Komachi <usata@gentoo.org>2005-05-03 11:54:00 +0000
commit071b941ac7dec42023cdf55c4a18a5f707eae288 (patch)
tree5e9b87cb622d67ec746e5f277151c0ef330ca9e1 /sys-libs/gpm
parentFix SLOT (s/1.3/2/). (diff)
downloadhistorical-071b941ac7dec42023cdf55c4a18a5f707eae288.tar.gz
historical-071b941ac7dec42023cdf55c4a18a5f707eae288.tar.bz2
historical-071b941ac7dec42023cdf55c4a18a5f707eae288.zip
Added emacs IUSE; bug #80217.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-libs/gpm')
-rw-r--r--sys-libs/gpm/ChangeLog5
-rw-r--r--sys-libs/gpm/Manifest8
-rw-r--r--sys-libs/gpm/gpm-1.20.1-r4.ebuild20
3 files changed, 24 insertions, 9 deletions
diff --git a/sys-libs/gpm/ChangeLog b/sys-libs/gpm/ChangeLog
index 9221c8e4c925..41fc022c59e0 100644
--- a/sys-libs/gpm/ChangeLog
+++ b/sys-libs/gpm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/gpm
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.40 2005/04/01 22:20:49 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.41 2005/05/03 11:54:00 usata Exp $
+
+ 03 May 2005; Mamoru KOMACHI <usata@gentoo.org> gpm-1.20.1-r4.ebuild:
+ Added emacs IUSE; bug #80217.
01 Apr 2005; Lars Weiler <pylon@gentoo.org> gpm-1.20.1-r4.ebuild:
Stable on ppc.
diff --git a/sys-libs/gpm/Manifest b/sys-libs/gpm/Manifest
index cccbc728b889..c52fa68e76dc 100644
--- a/sys-libs/gpm/Manifest
+++ b/sys-libs/gpm/Manifest
@@ -1,9 +1,9 @@
-MD5 04dd44372a4147995b791619caf41f68 ChangeLog 5870
+MD5 e81b21438e96ce7fcaa14db985e5105c gpm-1.20.1-r4.ebuild 1771
MD5 81f80af7a34f9e25f9213422bcb30b09 gpm-1.20.1.ebuild 1644
+MD5 21458945bc47919c05d5779bfeac325c ChangeLog 5974
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 d5e39d00c6b66745e9cb5258fc9441e5 gpm-1.20.1-r4.ebuild 1498
+MD5 d562712814b13d09904823bd3eb31269 files/gpm.conf.d 570
+MD5 97f0853f825f506bf47be3b8ce6f9ce9 files/digest-gpm-1.20.1 136
MD5 73d6199d600c0f63c31a6de234159bba files/digest-gpm-1.20.1-r4 136
MD5 1e2ab7c222263d460e9e881f7a1558c7 files/gpm-linux26-headers.patch 423
-MD5 97f0853f825f506bf47be3b8ce6f9ce9 files/digest-gpm-1.20.1 136
-MD5 d562712814b13d09904823bd3eb31269 files/gpm.conf.d 570
MD5 b1364fd3bf27cda742dbcfc87497cc18 files/gpm.rc6 951
diff --git a/sys-libs/gpm/gpm-1.20.1-r4.ebuild b/sys-libs/gpm/gpm-1.20.1-r4.ebuild
index 27199cecc97f..443787a49941 100644
--- a/sys-libs/gpm/gpm-1.20.1-r4.ebuild
+++ b/sys-libs/gpm/gpm-1.20.1-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.1-r4.ebuild,v 1.9 2005/05/03 04:50:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.1-r4.ebuild,v 1.10 2005/05/03 11:54:00 usata Exp $
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs elisp-common
PATCH_VER="1.3"
DESCRIPTION="Console-based mouse driver"
@@ -14,7 +14,7 @@ SRC_URI="ftp://arcana.linux.it/pub/gpm/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="selinux"
+IUSE="selinux emacs"
DEPEND="sys-libs/ncurses"
RDEPEND="selinux? ( sec-policy/selinux-gpm )"
@@ -34,11 +34,18 @@ src_compile() {
CC=$(tc-getCC) \
AR=$(tc-getAR) \
RANLIB=$(tc-getRANLIB) \
+ EMACS=: \
|| die "emake failed"
+
+ local lisp="emacs/t-mouse.el emacs/t-mouse.elc"
+ if use emacs ; then
+ cd ${S}/contrib ; make clean
+ make EMACS=emacs ELISP="${lisp}" || die
+ fi
}
src_install() {
- make install DESTDIR="${D}" || die "make install failed"
+ make install DESTDIR="${D}" EMACS=: ELISP="" || die "make install failed"
# fix lib symlinks since the default is missing/bogus
dosym libgpm.so.1.19.0 /$(get_libdir)/libgpm.so.1
dosym libgpm.so.1 /$(get_libdir)/libgpm.so
@@ -46,6 +53,11 @@ src_install() {
mv "${D}"/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/
gen_usr_ldscript libgpm.so
+ if use emacs ; then
+ cd ${S}/contrib/emacs
+ elisp-install . t-mouse*
+ fi
+
insinto /etc/gpm
doins conf/gpm-*.conf