summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-18 02:10:37 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-18 02:10:37 +0000
commit7ebe20a96e95b3ec953fbee209cadf3a7898afbc (patch)
tree4c4012359d05ea9cf245a3986cb70c8ddc614078 /sys-libs
parentFix dependency over libvorbis only if encode is requrested. Bug #111739. (diff)
downloadhistorical-7ebe20a96e95b3ec953fbee209cadf3a7898afbc.tar.gz
historical-7ebe20a96e95b3ec953fbee209cadf3a7898afbc.tar.bz2
historical-7ebe20a96e95b3ec953fbee209cadf3a7898afbc.zip
fix header searching when emerging into an empty ROOT #114923
Package-Manager: portage-2.0.53
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/Manifest10
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild7
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild7
3 files changed, 15 insertions, 9 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index db15a0c575a6..bf4db2f208cb 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -129,8 +129,8 @@ MD5 4c1b1e9c75fe7fbc58753d0ecff5a381 glibc-2.3.3.20040420-r2.ebuild 21706
MD5 df67184db48138252008ff91e0cef2cb glibc-2.3.4.20040619-r2.ebuild 21380
MD5 d578299067a293f9b23e7496d2591f86 glibc-2.3.4.20040808-r1.ebuild 27729
MD5 8ca88e0313461666c2f3cbe3377e7201 glibc-2.3.4.20041102-r1.ebuild 34294
-MD5 dbf02602c9886aad11c2be1c8fe7774e glibc-2.3.4.20041102-r2.ebuild 41257
-MD5 b3e317284bea4e7205e6338695675394 glibc-2.3.4.20050125-r1.ebuild 39450
+MD5 d0501b95beefec42d574b34ef0d0cecb glibc-2.3.4.20041102-r2.ebuild 41390
+MD5 dcc9e5194707e88476804f3a43d65517 glibc-2.3.4.20050125-r1.ebuild 39583
MD5 2eb2b01004d8f68600c5e1aed8fed4ef glibc-2.3.5-r1.ebuild 40647
MD5 d3760592fdf5d357bf2a4efe96fd285d glibc-2.3.5-r2.ebuild 38973
MD5 d51445264b99889b5e564aa776728fad glibc-2.3.5-r3.ebuild 39021
@@ -143,7 +143,7 @@ MD5 567094e03359ffc1c95af7356395228d metadata.xml 162
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDo2Ac2+ySkm8kpY0RAngQAKDHNh1dy5qsIm7gwpHQytscfEVsswCfQUIi
-BynD7PIVtdaTzYT5YnnTwC4=
-=UzyX
+iD8DBQFDpMVA2+ySkm8kpY0RAv3aAKCXc77E3l93J4oh5g8rifn6Be+SPACcC5+l
+xcUGW9dPkPnARIsyB5wWGOM=
+=98Ah
-----END PGP SIGNATURE-----
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild
index 2c71dd249793..ca9aef965cd9 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild,v 1.8 2005/12/03 00:55:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r2.ebuild,v 1.9 2005/12/18 02:10:37 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -939,6 +939,9 @@ glibc_do_configure() {
myconf="${myconf} --without-selinux"
fi
+ # Pick out the correct location for build headers
+ local headersloc=$(alt_headers)
+ tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -946,7 +949,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
--disable-profile
--without-gd
- --with-headers=${ROOT}$(alt_headers)
+ --with-headers=${headersloc}
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index 4a2c2a518572..71efd3dafbc0 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.64 2005/12/03 00:55:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.65 2005/12/18 02:10:37 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -884,6 +884,9 @@ glibc_do_configure() {
myconf="${myconf} --without-selinux"
fi
+ # Pick out the correct location for build headers
+ local headersloc=$(alt_headers)
+ tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -891,7 +894,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
--disable-profile
--without-gd
- --with-headers=${ROOT}$(alt_headers)
+ --with-headers=${headersloc}
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info