summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-04-22 19:26:03 +0000
committerJoshua Brindle <method@gentoo.org>2003-04-22 19:26:03 +0000
commit9e592d3a154367a5d13871c5703e7895d651d4e9 (patch)
treebf4b47ce19040b82b2a1b13dc8175052c7e012b6 /sys-libs
parentVersion bumped. (diff)
downloadhistorical-9e592d3a154367a5d13871c5703e7895d651d4e9.tar.gz
historical-9e592d3a154367a5d13871c5703e7895d651d4e9.tar.bz2
historical-9e592d3a154367a5d13871c5703e7895d651d4e9.zip
fixed placement of stack-protector and sandbox check
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/Manifest2
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r1.ebuild18
2 files changed, 10 insertions, 10 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index b5adb38b0f5e..5397bf4cfdca 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -1,5 +1,5 @@
MD5 f87141919fc5723aad194a923fb809a9 glibc-2.3.1-r2.ebuild 9670
-MD5 f43c643984440c472205338059589202 glibc-2.3.2-r1.ebuild 15052
+MD5 f2777f87e9140aaaa800de0a08e7b293 glibc-2.3.2-r1.ebuild 15052
MD5 6c22b1fdc3570ff7a75cd69f08709f5d glibc-2.3.1-r4.ebuild 10472
MD5 a8447557fe0e36b955ed4af19ea5884b glibc-2.3.2.ebuild 14328
MD5 9ca3d97fbb9c9b0b3958b00f2959947c glibc-2.2.5-r8.ebuild 9702
diff --git a/sys-libs/glibc/glibc-2.3.2-r1.ebuild b/sys-libs/glibc/glibc-2.3.2-r1.ebuild
index 7d8daf4397de..cd04949461f2 100644
--- a/sys-libs/glibc/glibc-2.3.2-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r1.ebuild,v 1.3 2003/04/20 20:59:26 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r1.ebuild,v 1.4 2003/04/22 19:25:59 method Exp $
IUSE="nls pic build nptl"
@@ -180,6 +180,14 @@ pkg_setup() {
die "GCC too old"
fi
+ if [ -n "`is-flag "-fstack-protector"`" -a -n "`has "sandbox" $FEATURES`" ]
+ then
+ eerror "You have both -fstack-protector and sandbox enabled"
+ eerror "glibc will not compile correctly with both of these enabled"
+ eerror "Please disable sandbox by calling emerge with FEATURES=\"-sandbox\""
+ die
+ fi
+
if use_nptl
then
echo
@@ -231,14 +239,6 @@ pkg_setup() {
src_unpack() {
- if [ -n "`is-flag "-fstack-protector"`" -a -n "`has "sandbox" $FEATURES`" ]
- then
- eerror "You have both -fstack-protector and sandbox enabled"
- eerror "glibc will not compile correctly with both of these enabled"
- eerror "Please disable sandbox by calling emerge with FEATURES=\"-sandbox\""
- die
- fi
-
unpack glibc-${MY_PV}.tar.bz2
# Extract pre-made man pages. Otherwise we need perl, which is a no-no.