summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2005-07-02 18:27:49 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2005-07-02 18:27:49 +0000
commit014ba74f3add5a4c130d9d040931bff242032719 (patch)
tree7c58fcee76a23db260f60a6f2b38bd0e03354a1c /sys-power
parentAdded sys-power/acpid:logrotate (diff)
downloadhistorical-014ba74f3add5a4c130d9d040931bff242032719.tar.gz
historical-014ba74f3add5a4c130d9d040931bff242032719.tar.bz2
historical-014ba74f3add5a4c130d9d040931bff242032719.zip
Added logrotate configuration file (bug #89350), added reload() function to init script.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpid/ChangeLog9
-rw-r--r--sys-power/acpid/Manifest6
-rw-r--r--sys-power/acpid/acpid-1.0.4-r2.ebuild78
-rw-r--r--sys-power/acpid/files/acpid-1.0.4-init.d38
-rw-r--r--sys-power/acpid/files/acpid-1.0.4-logrotate9
-rw-r--r--sys-power/acpid/files/digest-acpid-1.0.4-r21
6 files changed, 139 insertions, 2 deletions
diff --git a/sys-power/acpid/ChangeLog b/sys-power/acpid/ChangeLog
index 6cfda803276c..8ce09abfb1a3 100644
--- a/sys-power/acpid/ChangeLog
+++ b/sys-power/acpid/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-power/acpid
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.8 2005/05/26 12:43:41 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.9 2005/07/02 18:27:49 brix Exp $
+
+*acpid-1.0.4-r2 (02 Jul 2005)
+
+ 02 Jul 2005; <brix@gentoo.org> +files/acpid-1.0.4-init.d,
+ +files/acpid-1.0.4-logrotate, +acpid-1.0.4-r2.ebuild:
+ Added logrotate configuration file (bug #89350), added reload() function to
+ init script.
26 May 2005; <brix@gentoo.org> -acpid-1.0.1.ebuild,
-acpid-1.0.2-r1.ebuild, -acpid-1.0.4.ebuild:
diff --git a/sys-power/acpid/Manifest b/sys-power/acpid/Manifest
index c7b28c42861f..252bee78f1d0 100644
--- a/sys-power/acpid/Manifest
+++ b/sys-power/acpid/Manifest
@@ -1,11 +1,15 @@
+MD5 335ba9386396da630bb42dafdffa4278 acpid-1.0.4-r2.ebuild 1903
MD5 6ecac61c2fa9a9d58c584b7b01977165 acpid-1.0.4-r1.ebuild 1804
-MD5 b246f765c42a1888623c135d37cb3854 ChangeLog 3648
+MD5 ccf71776384075057217544f83c50e9b ChangeLog 3889
MD5 b280eebc74d70d85e664debf1adce2c3 metadata.xml 255
MD5 a15ebede7a8bd47be9c5cd838cc9a47f acpid-1.0.2-r2.ebuild 1443
MD5 747fc9ab0e7a041ea461b8f0ecab9132 files/acpid-1.0.4-default.sh 560
MD5 3cc2de9822a0f65e061e31184ad2e91f files/default.sh-gentoo.patch 550
+MD5 23b29e88498fcf89fb12c69f513aed0e files/acpid-1.0.4-logrotate 133
MD5 13412c1fef605768fd76a97fd7e92162 files/acpid-1.0.4-default 858
MD5 93f4357c4993442069a86bd9b6a6f6a7 files/acpid.rc6 646
MD5 faf93dd3ae4cc7973d7375beea0738a3 files/acpid-1.0.4-gcc4.patch 670
MD5 4bf4b207e7f3c9f7a966c62236dd73be files/digest-acpid-1.0.2-r2 62
MD5 e193d813bbbabf9aceb89ba3c612e58e files/digest-acpid-1.0.4-r1 62
+MD5 e193d813bbbabf9aceb89ba3c612e58e files/digest-acpid-1.0.4-r2 62
+MD5 d8a1eba60a556bf4a65f3fea9795bc63 files/acpid-1.0.4-init.d 818
diff --git a/sys-power/acpid/acpid-1.0.4-r2.ebuild b/sys-power/acpid/acpid-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..e99a64b606a3
--- /dev/null
+++ b/sys-power/acpid/acpid-1.0.4-r2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-1.0.4-r2.ebuild,v 1.1 2005/07/02 18:27:49 brix Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
+HOMEPAGE="http://acpid.sourceforge.net"
+SRC_URI="mirror://sourceforge/acpid/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc ~alpha ~amd64 ~ia64"
+IUSE="doc logrotate"
+
+DEPEND="sys-apps/sed
+ virtual/libc
+ virtual/linux-sources"
+RDEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Fix building with gcc4
+ epatch ${FILESDIR}/${P}-gcc4.patch
+
+ # do not treat warnings as errors, bug #90873
+ sed -i -e "s:-Werror::" ${S}/Makefile
+}
+
+src_compile() {
+ # DO NOT COMPILE WITH OPTIMISATIONS (bug #22365)
+ # That is a note to the devs. IF you are a user, go ahead and optimise
+ # if you want, but we won't support bugs associated with that.
+ make CC="$(tc-getCC)" INSTPREFIX="${D}" || die
+}
+
+src_install() {
+ # needed since the Makefile doesn't do 'mkdir -p $(BINDIR)'
+ dodir /usr/bin
+
+ make INSTPREFIX="${D}" install || die
+
+ exeinto /etc/acpi
+ newexe ${FILESDIR}/${P}-default.sh default.sh || die
+
+ insinto /etc/acpi/events
+ newins ${FILESDIR}/${P}-default default || die
+
+ dodoc README Changelog TODO
+
+ newinitd ${FILESDIR}/${P}-init.d acpid || die
+
+ if use doc; then
+ docinto examples
+ dodoc samples/{acpi_handler.sh,sample.conf}
+
+ docinto examples/battery
+ dodoc samples/battery/*
+
+ docinto examples/panasonic
+ dodoc samples/panasonic/*
+ fi
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins ${FILESDIR}/${P}-logrotate acpid || die
+ fi
+}
+
+pkg_postinst() {
+ echo
+ einfo "You may wish to read the Gentoo Linux Power Management Guide,"
+ einfo "which can be found online at:"
+ einfo " http://www.gentoo.org/doc/en/power-management-guide.xml"
+ echo
+}
diff --git a/sys-power/acpid/files/acpid-1.0.4-init.d b/sys-power/acpid/files/acpid-1.0.4-init.d
new file mode 100644
index 000000000000..33bb80a5a01e
--- /dev/null
+++ b/sys-power/acpid/files/acpid-1.0.4-init.d
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/files/acpid-1.0.4-init.d,v 1.1 2005/07/02 18:27:49 brix Exp $
+
+opts="${opts} reload"
+
+depend() {
+ need localmount
+}
+
+checkconfig() {
+ if [ ! -e /proc/acpi ]; then
+ eerror "ACPI support has not been compiled into the kernel"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting acpid"
+ start-stop-daemon --start --quiet --exec /usr/sbin/acpid -- \
+ -c /etc/acpi/events
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping acpid"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/acpid
+ eend ${?}
+}
+
+reload() {
+ ebegin "Reloading acpid configuration"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/acpid --signal HUP
+ eend ${?}
+}
diff --git a/sys-power/acpid/files/acpid-1.0.4-logrotate b/sys-power/acpid/files/acpid-1.0.4-logrotate
new file mode 100644
index 000000000000..6e8e024b2ae1
--- /dev/null
+++ b/sys-power/acpid/files/acpid-1.0.4-logrotate
@@ -0,0 +1,9 @@
+/var/log/acpid {
+ missingok
+ rotate 5
+ size 100k
+ weekly
+ postrotate
+ /etc/init.d/acpid reload
+ endscript
+}
diff --git a/sys-power/acpid/files/digest-acpid-1.0.4-r2 b/sys-power/acpid/files/digest-acpid-1.0.4-r2
new file mode 100644
index 000000000000..37c23c5f0323
--- /dev/null
+++ b/sys-power/acpid/files/digest-acpid-1.0.4-r2
@@ -0,0 +1 @@
+MD5 3aff94e92186e99ed5fd6dcee2db7c74 acpid-1.0.4.tar.gz 23416