summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-07-22 00:33:48 +0000
committerChristian Heim <phreak@gentoo.org>2006-07-22 00:33:48 +0000
commitf6a4da66b30181cdea3fe0d68335ed447c9eb17b (patch)
tree3a4a07df29a0437c918b60dae05eba4d3a8753d0 /sys-power
parentlibchipcard bump (diff)
downloadhistorical-f6a4da66b30181cdea3fe0d68335ed447c9eb17b.tar.gz
historical-f6a4da66b30181cdea3fe0d68335ed447c9eb17b.tar.bz2
historical-f6a4da66b30181cdea3fe0d68335ed447c9eb17b.zip
Revision bump. Moving the patches to a seperate tarball. Backporting some changes from UPSTREAM svn. Finally fixing the last-return error, adding new ERROR messages for newer kernels. Fixing bug #141204 (thanks to Stefan Becker <schtefan at gmx.net> for the initial patch), restart 855resolution after resume.
Package-Manager: portage-2.1.1_pre3-r3
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/hibernate-script/ChangeLog17
-rw-r--r--sys-power/hibernate-script/files/digest-hibernate-script-1.93-r46
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.93-r4.ebuild72
3 files changed, 94 insertions, 1 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index ee39b6c5e1bd..34b692c70f0c 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,21 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.30 2006/07/19 06:39:03 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.31 2006/07/22 00:33:48 phreak Exp $
+
+*hibernate-script-1.93-r4 (22 Jul 2006)
+
+ 22 Jul 2006; Christian Heim <phreak@gentoo.org>
+ -files/hibernate-script-1.93-gentoo.patch,
+ -files/hibernate-script-1.93-kde-lock-session.patch,
+ -files/hibernate-script-1.93-last_result.patch,
+ -files/hibernate-script-1.93-return.patch,
+ -files/hibernate-script-1.93-rt2500-blacklist.patch,
+ +hibernate-script-1.93-r4.ebuild:
+ Revision bump. Moving the patches to a seperate tarball. Backporting some
+ changes from UPSTREAM svn. Finally fixing the last-return error, adding new
+ ERROR messages for newer kernels. Fixing bug #141204 (thanks to Stefan
+ Becker <schtefan at gmx.net> for the initial patch), restart 855resolution
+ after resume.
*hibernate-script-1.93-r3 (19 Jul 2006)
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.93-r4 b/sys-power/hibernate-script/files/digest-hibernate-script-1.93-r4
new file mode 100644
index 000000000000..a790032f8caf
--- /dev/null
+++ b/sys-power/hibernate-script/files/digest-hibernate-script-1.93-r4
@@ -0,0 +1,6 @@
+MD5 1b0ebe0f20c3572bed8b29546fe15371 hibernate-script-1.93-patches-0.1.tar.bz2 3184
+RMD160 d9c0d4d4c5e55ca39b858ee5d2c1ec51b997071a hibernate-script-1.93-patches-0.1.tar.bz2 3184
+SHA256 c0b53f2398b4da55a25b4a7823cb7c93932dd2c118e272558e959a36a89ee6cb hibernate-script-1.93-patches-0.1.tar.bz2 3184
+MD5 903e30d67bcdf728f245a71b9ec412e2 hibernate-script-1.93.tar.gz 68644
+RMD160 bbb59d7ac5c7a26667cb00c5dd32224ad3eb8f01 hibernate-script-1.93.tar.gz 68644
+SHA256 8020d653cc09d1724f700e2b28cf5ce83eef3ffd287304141357eef2c22db366 hibernate-script-1.93.tar.gz 68644
diff --git a/sys-power/hibernate-script/hibernate-script-1.93-r4.ebuild b/sys-power/hibernate-script/hibernate-script-1.93-r4.ebuild
new file mode 100644
index 000000000000..91bf7fe14676
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.93-r4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.93-r4.ebuild,v 1.1 2006/07/22 00:33:48 phreak Exp $
+
+inherit eutils
+
+PATCH_VERSION="0.1"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.suspend2.net/"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz
+ http://dev.gentoo.org/~phreak/distfiles/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" PREFIX=/usr MAN_DIR="${D}"/usr/share/man \
+ "${S}"/install.sh
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You should run the following command to invalidate"
+ einfo "suspend images on a clean boot."
+ einfo
+ einfo " # rc-update add hibernate-cleanup boot"
+ einfo
+ einfo "See /usr/share/doc/${PF}/README.gz for further details."
+ einfo
+ einfo "Please note that you will need to manually emerge any utilities"
+ einfo "(radeontool, vbetool, ...) enabled in the configuration files,"
+ einfo "should you wish to use them."
+ einfo
+ einfo "Starting with hibernate-script-1.90 the configuration files have"
+ einfo "been reordered and split into method specific files. Make sure you"
+ einfo "update your /etc/hibernate/ configuration files accordingly."
+ einfo
+}