summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-08-15 09:37:21 +0000
committerStuart Herbert <stuart@gentoo.org>2004-08-15 09:37:21 +0000
commit5b00e8c451bc4754d88f314c678632fa22f67929 (patch)
treed7219076926ca586dca83d5e0acbfb793a243293 /www-apps/Apache-Gallery
parentUpdated HOMEPAGE, as noted in but #60394 (diff)
downloadhistorical-5b00e8c451bc4754d88f314c678632fa22f67929.tar.gz
historical-5b00e8c451bc4754d88f314c678632fa22f67929.tar.bz2
historical-5b00e8c451bc4754d88f314c678632fa22f67929.zip
Moved from dev-perl/Apache-Gallery to www-apps/Apache-Gallery.
Diffstat (limited to 'www-apps/Apache-Gallery')
-rw-r--r--www-apps/Apache-Gallery/Apache-Gallery-0.6.ebuild59
-rw-r--r--www-apps/Apache-Gallery/Apache-Gallery-0.8.ebuild60
-rw-r--r--www-apps/Apache-Gallery/ChangeLog37
-rw-r--r--www-apps/Apache-Gallery/Manifest7
-rw-r--r--www-apps/Apache-Gallery/files/apache-gallery.conf23
-rw-r--r--www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.61
-rw-r--r--www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.81
-rw-r--r--www-apps/Apache-Gallery/metadata.xml10
8 files changed, 198 insertions, 0 deletions
diff --git a/www-apps/Apache-Gallery/Apache-Gallery-0.6.ebuild b/www-apps/Apache-Gallery/Apache-Gallery-0.6.ebuild
new file mode 100644
index 000000000000..860ac0166712
--- /dev/null
+++ b/www-apps/Apache-Gallery/Apache-Gallery-0.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/Apache-Gallery-0.6.ebuild,v 1.1 2004/08/15 09:37:21 stuart Exp $
+
+inherit perl-module
+
+DESCRIPTION="Apache gallery for mod_perl"
+SRC_URI="http://cpan.org/modules/by-module/Apache/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/author/LEGART/${P}"
+
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="x86 amd64 ~ppc ~alpha ~sparc"
+IUSE=""
+
+
+DEPEND="${DEPEND}
+ >=dev-perl/libapreq-1.0
+ >=media-libs/imlib2-1.0.6-r1
+ >=dev-perl/mod_perl-1.27-r1
+ >=dev-perl/ImageInfo-1.04-r2
+ >=dev-perl/ImageSize-2.99-r1
+ >=dev-perl/CGI-2.78-r3
+ >=dev-perl/CGI-FastTemplate-1.09
+ >=dev-perl/Parse-RecDescent-1.80-r3
+ >=dev-perl/Inline-0.43-r1
+ virtual/x11"
+
+
+
+src_install() {
+ mydoc="INSTALL"
+
+ perl-module_src_install
+
+ insinto /home/httpd/icons
+ doins htdocs/*.png
+
+ insinto /etc/apache/gallery/templates
+ doins templates/*.tpl
+
+ insinto /etc/apache/conf
+ doins ${FILESDIR}/apache-gallery.conf
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}/etc/apache/conf/ssl
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated."
+ einfo "You should then edit your /etc/apache/conf/apache-gallery.conf file to suit."
+ einfo
+}
+
+pkg_config() {
+ echo "Include conf/apache-gallery.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}
diff --git a/www-apps/Apache-Gallery/Apache-Gallery-0.8.ebuild b/www-apps/Apache-Gallery/Apache-Gallery-0.8.ebuild
new file mode 100644
index 000000000000..a63d58d4a16a
--- /dev/null
+++ b/www-apps/Apache-Gallery/Apache-Gallery-0.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/Apache-Gallery-0.8.ebuild,v 1.1 2004/08/15 09:37:21 stuart Exp $
+
+inherit perl-module
+
+DESCRIPTION="Apache gallery for mod_perl"
+SRC_URI="http://cpan.org/modules/by-module/Apache/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/author/LEGART/${P}"
+
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~alpha ~sparc"
+IUSE=""
+
+
+DEPEND="${DEPEND}
+ >=dev-perl/libapreq-1.0
+ >=media-libs/imlib2-1.0.6-r1
+ >=dev-perl/mod_perl-1.27-r1
+ >=dev-perl/ImageInfo-1.04-r2
+ >=dev-perl/ImageSize-2.99-r1
+ dev-perl/Image-Imlib2
+ >=dev-perl/CGI-2.78-r3
+ >=dev-perl/CGI-FastTemplate-1.09
+ >=dev-perl/Parse-RecDescent-1.80-r3
+ >=dev-perl/Inline-0.43-r1
+ virtual/x11"
+
+
+
+src_install() {
+ mydoc="INSTALL"
+
+ perl-module_src_install
+
+ insinto /home/httpd/icons
+ doins htdocs/*.png
+
+ insinto /etc/apache/gallery/templates
+ doins templates/*.tpl
+
+ insinto /etc/apache/conf
+ doins ${FILESDIR}/apache-gallery.conf
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}/etc/apache/conf/ssl
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated."
+ einfo "You should then edit your /etc/apache/conf/apache-gallery.conf file to suit."
+ einfo
+}
+
+pkg_config() {
+ echo "Include conf/apache-gallery.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}
diff --git a/www-apps/Apache-Gallery/ChangeLog b/www-apps/Apache-Gallery/ChangeLog
new file mode 100644
index 000000000000..bb60d079a902
--- /dev/null
+++ b/www-apps/Apache-Gallery/ChangeLog
@@ -0,0 +1,37 @@
+# ChangeLog for dev-perl/Apache-Gallery
+# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/ChangeLog,v 1.1 2004/08/15 09:37:21 stuart Exp $
+
+*Apache-Gallery-0.8 (15 Aug 2004)
+
+ 15 Aug 2004; Stuart Herbert <stuart@gentoo.org> +metadata.xml,
+ +files/apache-gallery.conf, +Apache-Gallery-0.6.ebuild,
+ +Apache-Gallery-0.8.ebuild:
+ Moved from dev-perl/Apache-Gallery to www-apps/Apache-Gallery.
+
+ 05 Jun 2004; Michael Cummings <mcummings@gentoo.org>
+ Apache-Gallery-0.6.ebuild, Apache-Gallery-0.8.ebuild:
+ Keyword fix, virtual for older version
+
+ 05 Jun 2004; Michael Cummings <mcummings@gentoo.org>
+ Apache-Gallery-0.8.ebuild:
+ changed to virtaul/x11
+
+*Apache-Gallery-0.8 (05 Jun 2004)
+
+ 05 Jun 2004; Michael Cummings <mcummings@gentoo.org>
+ Apache-Gallery-0.8.ebuild:
+ new version, new deps
+
+ 29 Jul 2003; Michael Cummings <mcummings@gentoo.org>
+ files/apache-gallery.conf:
+ Totally missed the missing apache-gallery.conf file. Thanks to Dan Noe
+ <dpn@isomerica.net> in Bug 25136 for catching that
+
+*Apache-Gallery-0.6 (20 Jun 2003)
+
+ 20 Jun 2003; Michael Cummings <mcummings@gentoo.org>
+ Apache-Gallery-0.6.ebuild:
+ New ebuild. Original ebuild submitted in bug 11725 by Jens Hilligsoee
+ <gentoo@hilli.dk>
+
diff --git a/www-apps/Apache-Gallery/Manifest b/www-apps/Apache-Gallery/Manifest
new file mode 100644
index 000000000000..22c94c000bef
--- /dev/null
+++ b/www-apps/Apache-Gallery/Manifest
@@ -0,0 +1,7 @@
+MD5 0c95e696234ae2a30445187d871245a4 Apache-Gallery-0.6.ebuild 1451
+MD5 8b71b38122ae994bad9e7e34260a0c2c Apache-Gallery-0.8.ebuild 1476
+MD5 3562592293d7e68204c9f423e565677f ChangeLog 1051
+MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
+MD5 f372bf3342f63c4d3a680051e80b5571 files/digest-Apache-Gallery-0.6 69
+MD5 3c77fe3e38d06f53fca962becfe10d81 files/digest-Apache-Gallery-0.8 69
+MD5 d7306e4a4568b0c242ef3b73d3ad0e4e files/apache-gallery.conf 719
diff --git a/www-apps/Apache-Gallery/files/apache-gallery.conf b/www-apps/Apache-Gallery/files/apache-gallery.conf
new file mode 100644
index 000000000000..364635d512c9
--- /dev/null
+++ b/www-apps/Apache-Gallery/files/apache-gallery.conf
@@ -0,0 +1,23 @@
+
+
+##### Apache::Gallery configuration
+#
+# This is actually a virtual host definition with mod_perl directives
+#
+
+#<VirtualHost 123.123.123.123>
+# ServerName gallery.yourdomain.org
+# DocumentRoot /data/pictures/
+# ErrorLog logs/gallery-error_log
+# TransferLog logs/gallery-access_log
+# PerlSetVar GalleryTemplateDir '/etc/apache/gallery/templates'
+# PerlSetVar GalleryInfo 'Picture Taken => DateTimeOriginal, Flash => Flash'
+# PerlSetVar GallerySizes '640 1024 1600 2272'
+# PerlSetVar GalleryThumbnailSize '100x75'
+# PerlSetVar GalleryCopyrightImage 'htdocs/c.png'
+# <Location />
+# SetHandler perl-script
+# PerlHandler Apache::Gallery
+# </Location>
+#</VirtualHost>
+
diff --git a/www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.6 b/www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.6
new file mode 100644
index 000000000000..dc32649e0bd2
--- /dev/null
+++ b/www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.6
@@ -0,0 +1 @@
+MD5 78efe9884dc242ca50d4cc2e2fca9f44 Apache-Gallery-0.6.tar.gz 66429
diff --git a/www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.8 b/www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.8
new file mode 100644
index 000000000000..751d21f9d580
--- /dev/null
+++ b/www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.8
@@ -0,0 +1 @@
+MD5 c04d7d8edc90982eae68a431077f9413 Apache-Gallery-0.8.tar.gz 77184
diff --git a/www-apps/Apache-Gallery/metadata.xml b/www-apps/Apache-Gallery/metadata.xml
new file mode 100644
index 000000000000..86672fe64c10
--- /dev/null
+++ b/www-apps/Apache-Gallery/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>perl@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <longdescription></longdescription>
+</pkgmetadata>