summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2004-08-18 18:15:42 +0000
committerRenat Lumpau <rl03@gentoo.org>2004-08-18 18:15:42 +0000
commit51116466c97c78172524d8437aba9dadbb8c1255 (patch)
treeb8e1692e0f0776b456d41c2cb6e6a438365ea728 /www-apps/mambo
parentInitial import, closes #60674. (diff)
downloadhistorical-51116466c97c78172524d8437aba9dadbb8c1255.tar.gz
historical-51116466c97c78172524d8437aba9dadbb8c1255.tar.bz2
historical-51116466c97c78172524d8437aba9dadbb8c1255.zip
Initial ebuild
Diffstat (limited to 'www-apps/mambo')
-rw-r--r--www-apps/mambo/ChangeLog10
-rw-r--r--www-apps/mambo/Manifest6
-rw-r--r--www-apps/mambo/files/digest-mambo-4.51
-rw-r--r--www-apps/mambo/files/postinstall-en.txt28
-rw-r--r--www-apps/mambo/files/reconfig55
-rw-r--r--www-apps/mambo/mambo-4.5.ebuild47
-rw-r--r--www-apps/mambo/metadata.xml5
7 files changed, 152 insertions, 0 deletions
diff --git a/www-apps/mambo/ChangeLog b/www-apps/mambo/ChangeLog
new file mode 100644
index 000000000000..cc6c8690326b
--- /dev/null
+++ b/www-apps/mambo/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for www-apps/mambo
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/ChangeLog,v 1.1 2004/08/18 18:15:42 rl03 Exp $
+
+*mambo-4.5 (18 Aug 2004)
+
+ 18 Aug 2004; Renat Lumpau <rl03@gentoo.org> +metadata.xml,
+ +files/postinstall-en.txt, +files/reconfig, +mambo-4.5.ebuild:
+ Initial ebuild (requested in bug #55316)
+
diff --git a/www-apps/mambo/Manifest b/www-apps/mambo/Manifest
new file mode 100644
index 000000000000..940adfe55718
--- /dev/null
+++ b/www-apps/mambo/Manifest
@@ -0,0 +1,6 @@
+MD5 d2fb0c8b01fca26d6d6ecd8d95da5e18 mambo-4.5.ebuild 1108
+MD5 7fcbef17a5edaadd43064d734617917c ChangeLog 395
+MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
+MD5 1d7786882cf944d4456e6e356e2a9cec files/digest-mambo-4.5 74
+MD5 59b39cb8d36aac8cfeff7918ee784531 files/postinstall-en.txt 906
+MD5 2d97c19e7db984a98f4b70f019a6ed32 files/reconfig 1960
diff --git a/www-apps/mambo/files/digest-mambo-4.5 b/www-apps/mambo/files/digest-mambo-4.5
new file mode 100644
index 000000000000..22c3501dd383
--- /dev/null
+++ b/www-apps/mambo/files/digest-mambo-4.5
@@ -0,0 +1 @@
+MD5 abd4055a9fa47860dfb61a6c638c5c73 MamboV4.5-Stable-1.0.9.tar.gz 943850
diff --git a/www-apps/mambo/files/postinstall-en.txt b/www-apps/mambo/files/postinstall-en.txt
new file mode 100644
index 000000000000..b6e8a450ffac
--- /dev/null
+++ b/www-apps/mambo/files/postinstall-en.txt
@@ -0,0 +1,28 @@
+You are almost done!
+
+
+ 1. Restart Apache
+
+ 2. Login on http://YOURHOST and finish the installation. IMPORTANT: the web
+ installer will complain that configuration.php is not writeable. When you
+ are done, create configuration.php in ${MY_INSTALLDIR} and copy the generated
+ configuration into it. Then execute the following:
+ # cd ${MY_INSTALLDIR}
+ # chown apache:apache configuration.php
+ # chmod u+w configuration.php
+
+ 3. (Stolen from
+ http://www.mamboserver.com/MOS_FAQs/Installing_Mambo_Open_Source/Installing_Mambo_Open_Source/
+ , which you should also read)
+
+ CONFIGURE MOS
+
+ You can now launch your browser and point it to your MOS site e.g.
+
+ http://www.mysite.com -> Main Site
+ http://www.mysite.com/administrator -> Admin
+
+ You can log into Admin using the username 'admin' along with the
+ password that was generated or you chose during the web based install.
+
+ Enjoy Mambo!
diff --git a/www-apps/mambo/files/reconfig b/www-apps/mambo/files/reconfig
new file mode 100644
index 000000000000..e614037d725d
--- /dev/null
+++ b/www-apps/mambo/files/reconfig
@@ -0,0 +1,55 @@
+#!/bin/bash
+
+function die {
+ echo $1
+ exit 1
+}
+
+if [ $1 = "start" -o $1 = "install" ]; then
+
+ cd ${VHOST_ROOT} || die
+
+ # default values for db stuff
+ D_DB="mambo"
+ D_HOST="localhost"
+ D_USER="mambo"
+
+ # do we want to start mysqld?
+ /etc/init.d/mysql restart || die "mysql needs to be running"
+
+ echo -n "mysql db name [${D_DB}]: "; read MY_DB
+ if (test -z ${MY_DB}) ; then MY_DB=${D_DB} ; fi
+
+ echo -n "mysql db host [${D_HOST}]: "; read MY_HOST
+ if (test -z ${MY_HOST}) ; then MY_HOST=${D_HOST}; fi
+
+ echo -n "mysql dbuser name [${D_USER}]: "; read MY_USER
+ if (test -z ${MY_USER}) ; then MY_USER=${D_USER} ; fi
+
+ echo -n "mysql dbuser password: "; read mypwd
+ if (test -z ${mypwd}) ; then die "Error: no dbuser password" ; fi
+
+ # privileges
+ echo -n "Please enter login info for user who has grant privileges on ${MY_HOST} [$USER]: "; read adminuser
+ if (test -z ${adminuser}) ; then adminuser="$USER" ; fi
+ if [ "${MY_HOST}" != "localhost" ]; then
+ echo -n "Client address (at db side) [$(hostname -f)]: "; read clientaddr
+ if (test -z ${clientaddr}) ; then clientaddr="$(hostname -f)" ; fi
+ fi
+ # this will be default for localhost
+ if (test -z ${clientaddr}) ; then clientaddr="${MY_HOST}" ; fi
+
+ # if $MY_HOST == localhost, don't specify -h argument, so local socket can be used.
+ host=${MY_HOST/localhost}
+ mysqladmin -u ${MY_USER} ${host:+-h ${host}} -p create ${MY_DB} || die "Error creating database"
+ mysql -u ${adminuser} ${host:+-h ${host}} -p mysql --exec="GRANT SELECT,INSERT,UPDATE,DELETE,INDEX, ALTER,CREATE,DROP,REFERENCES ON ${MY_DB}.* TO ${MY_USER}@${clientaddr} IDENTIFIED BY '${mypwd}'; FLUSH PRIVILEGES;" || {
+ echo "Error running query!"
+ echo
+ echo "Please run it manually on ${host}."
+ echo
+ echo " \$ mysql -u ${adminuser} -p mysql --exec=\"GRANT SELECT,INSERT,UPDATE,DELETE,INDEX, ALTER,CREATE,DROP,REFERENCES ON ${MY_DB}.* TO ${MY_USER}@${clientaddr} IDENTIFIED BY '${mypwd}'; FLUSH PRIVILEGES;\""
+ echo
+}
+else
+ echo $1
+fi
diff --git a/www-apps/mambo/mambo-4.5.ebuild b/www-apps/mambo/mambo-4.5.ebuild
new file mode 100644
index 000000000000..d3787a7b1b67
--- /dev/null
+++ b/www-apps/mambo/mambo-4.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/mambo-4.5.ebuild,v 1.1 2004/08/18 18:15:42 rl03 Exp $
+
+inherit webapp
+
+DESCRIPTION="Mambo is yet another CMS"
+SRC_URI="http://mamboforge.net/frs/download.php/1145/MamboV4.5-Stable-1.0.9.tar.gz"
+HOMEPAGE="http://www.mamboserver.com/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+S=${WORKDIR}
+
+IUSE=""
+
+DEPEND="$DEPEND"
+RDEPEND="dev-db/mysql
+ virtual/php
+ net-www/apache"
+
+pkg_setup () {
+ webapp_pkg_setup
+ einfo "Please make sure that your PHP is compiled with zlib, XML, and MySQL support"
+ sleep 5
+}
+
+src_install () {
+ webapp_src_preinst
+ local files="administrator/backups administrator/components components images media language modules templates uploadfiles"
+
+ cd ${S}
+
+ dodoc documentation/Changelog-4.5
+ rm -rf documentation
+
+ cp -R . ${D}/${MY_HTDOCSDIR}
+
+ for file in ${files}; do
+ webapp_serverowned "${MY_HTDOCSDIR}/${file}"
+ done
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_hook_script ${FILESDIR}/reconfig
+
+ webapp_src_install
+}
diff --git a/www-apps/mambo/metadata.xml b/www-apps/mambo/metadata.xml
new file mode 100644
index 000000000000..95c06f0095bb
--- /dev/null
+++ b/www-apps/mambo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+</pkgmetadata>