summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2004-08-18 20:30:22 +0000
committerRenat Lumpau <rl03@gentoo.org>2004-08-18 20:30:22 +0000
commitb2ca9051309a3bec0d8a901b8cc1851c02b2ce34 (patch)
treed4dba41852a33054c580f19376212c8c0d03cc2b /www-apps/sitebar
parentstable on x86 (diff)
downloadhistorical-b2ca9051309a3bec0d8a901b8cc1851c02b2ce34.tar.gz
historical-b2ca9051309a3bec0d8a901b8cc1851c02b2ce34.tar.bz2
historical-b2ca9051309a3bec0d8a901b8cc1851c02b2ce34.zip
Initial ebuild, bugs #53490 and #29841
Diffstat (limited to 'www-apps/sitebar')
-rw-r--r--www-apps/sitebar/ChangeLog10
-rw-r--r--www-apps/sitebar/Manifest5
-rw-r--r--www-apps/sitebar/files/digest-sitebar-3.2.61
-rw-r--r--www-apps/sitebar/files/postinstall-en.txt2
-rw-r--r--www-apps/sitebar/metadata.xml5
-rw-r--r--www-apps/sitebar/sitebar-3.2.6.ebuild38
6 files changed, 61 insertions, 0 deletions
diff --git a/www-apps/sitebar/ChangeLog b/www-apps/sitebar/ChangeLog
new file mode 100644
index 000000000000..c4770251ede6
--- /dev/null
+++ b/www-apps/sitebar/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for www-apps/sitebar
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/sitebar/ChangeLog,v 1.1 2004/08/18 20:30:22 rl03 Exp $
+
+*sitebar-3.2.6 (18 Aug 2004)
+
+ 18 Aug 2004; Renat Lumpau <rl03@gentoo.org> +metadata.xml,
+ +files/postinstall-en.txt, +sitebar-3.2.6.ebuild:
+ Initial ebuild (bugs #29841 and #53490)
+
diff --git a/www-apps/sitebar/Manifest b/www-apps/sitebar/Manifest
new file mode 100644
index 000000000000..f82abf9cf5d4
--- /dev/null
+++ b/www-apps/sitebar/Manifest
@@ -0,0 +1,5 @@
+MD5 ac5c739a1634c3be3a52134b0bc609a0 ChangeLog 389
+MD5 43c9765ba9203b27aaf986bb14e5dc0c sitebar-3.2.6.ebuild 833
+MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
+MD5 beaa9ebb360d0d2629fad3382282a40c files/postinstall-en.txt 77
+MD5 55c56a38fde4a9d4d2c9cd141259ccba files/digest-sitebar-3.2.6 66
diff --git a/www-apps/sitebar/files/digest-sitebar-3.2.6 b/www-apps/sitebar/files/digest-sitebar-3.2.6
new file mode 100644
index 000000000000..f51798341045
--- /dev/null
+++ b/www-apps/sitebar/files/digest-sitebar-3.2.6
@@ -0,0 +1 @@
+MD5 75b5a681aa7214f435261e1fd54c283e SiteBar-3.2.6.tar.bz2 252480
diff --git a/www-apps/sitebar/files/postinstall-en.txt b/www-apps/sitebar/files/postinstall-en.txt
new file mode 100644
index 000000000000..b1bff6cedafe
--- /dev/null
+++ b/www-apps/sitebar/files/postinstall-en.txt
@@ -0,0 +1,2 @@
+
+Now go to http://yourhost/sitebar/sitebar.php to complete the installation.
diff --git a/www-apps/sitebar/metadata.xml b/www-apps/sitebar/metadata.xml
new file mode 100644
index 000000000000..95c06f0095bb
--- /dev/null
+++ b/www-apps/sitebar/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+</pkgmetadata>
diff --git a/www-apps/sitebar/sitebar-3.2.6.ebuild b/www-apps/sitebar/sitebar-3.2.6.ebuild
new file mode 100644
index 000000000000..4e168c20cdce
--- /dev/null
+++ b/www-apps/sitebar/sitebar-3.2.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/sitebar/sitebar-3.2.6.ebuild,v 1.1 2004/08/18 20:30:22 rl03 Exp $
+
+inherit webapp
+
+DESCRIPTION="The Bookmark Server for Personal and Team Use"
+HOMEPAGE="http://sitebar.sourceforge.net/"
+KEYWORDS="~x86"
+
+IUSE=""
+MY_PN=${PN/sitebar/SiteBar}
+S=${WORKDIR}/${MY_PN}-${PV}
+
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}.tar.bz2"
+
+DEPEND="net-www/apache
+ virtual/php
+ >=dev-db/mysql-3.23"
+LICENSE="GPL-2"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ webapp_src_preinst
+ cd ${S}
+ rm -f readme.txt doc/licence.txt
+ dodoc doc/*
+ rm -rf doc
+ cp -R . ${D}/${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/inc
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}