summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-11-25 15:44:03 +0000
committerJeroen Roovers <jer@gentoo.org>2009-11-25 15:44:03 +0000
commitb9b0bf8c8fe888890bd127795d0caaa47c6a2070 (patch)
tree4cce01358ded17be2624ef69076ee6b061b3fa37 /www-client/opera/opera-10.10.ebuild
parentRelease candidate version bump. (diff)
downloadhistorical-b9b0bf8c8fe888890bd127795d0caaa47c6a2070.tar.gz
historical-b9b0bf8c8fe888890bd127795d0caaa47c6a2070.tar.bz2
historical-b9b0bf8c8fe888890bd127795d0caaa47c6a2070.zip
Remove IUSE=ia32.
Package-Manager: portage-2.2_rc51/cvs/Linux i686
Diffstat (limited to 'www-client/opera/opera-10.10.ebuild')
-rw-r--r--www-client/opera/opera-10.10.ebuild38
1 files changed, 10 insertions, 28 deletions
diff --git a/www-client/opera/opera-10.10.ebuild b/www-client/opera/opera-10.10.ebuild
index c062e85a7f94..9e8d01825ee3 100644
--- a/www-client/opera/opera-10.10.ebuild
+++ b/www-client/opera/opera-10.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-10.10.ebuild,v 1.2 2009/11/23 20:52:46 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-10.10.ebuild,v 1.3 2009/11/25 15:44:03 jer Exp $
EAPI="2"
@@ -27,7 +27,7 @@ QA_PRESTRIPPED="
opt/${PN}/lib/opera/${PV/_pre*}/operapluginwrapper
"
-IUSE="elibc_FreeBSD gnome ia32 qt3 qt-static"
+IUSE="elibc_FreeBSD gnome qt3 qt-static"
MY_LINGUAS="be bg cs da de el en-GB es-ES es-LA et fi fr fr-CA fy hi hr hu id it ja ka ko lt mk nb nl nn pl pt pt-BR ro ru sk sr sv ta te tr uk zh-CN zh-HK zh-TW"
for MY_LINGUA in ${MY_LINGUAS}; do
@@ -38,19 +38,10 @@ O_U="mirror://opera/linux/1010/final/en/"
SRC_URI="
amd64? (
- !ia32? (
- qt-static? ( ${O_U}x86_64/${P}.gcc4-bundled-qt4.x86_64.tar.bz2 )
- !qt-static? (
- qt3? ( ${O_U}x86_64/${P}.gcc4-shared-qt3.x86_64.tar.bz2 )
- !qt3? ( ${O_U}x86_64/${P}.gcc4-qt4.x86_64.tar.bz2 )
- )
- )
- ia32? (
- qt-static? ( ${O_U}i386/${P}.gcc4-bundled-qt4.i386.tar.bz2 )
- !qt-static? (
- qt3? ( ${O_U}i386/shared/${P}.gcc4-shared-qt3.i386.tar.bz2 )
- !qt3? ( ${O_U}i386/${P}.gcc4-qt4.i386.tar.bz2 )
- )
+ qt-static? ( ${O_U}x86_64/${P}.gcc4-bundled-qt4.x86_64.tar.bz2 )
+ !qt-static? (
+ qt3? ( ${O_U}x86_64/${P}.gcc4-shared-qt3.x86_64.tar.bz2 )
+ !qt3? ( ${O_U}x86_64/${P}.gcc4-qt4.x86_64.tar.bz2 )
)
)
ppc? ( ${O_U}ppc/shared/${P}.gcc4-shared-qt3.ppc.tar.bz2 )
@@ -81,19 +72,10 @@ RDEPEND="
x11-libs/libSM
x11-libs/libICE
amd64? (
- ia32? (
- qt-static? ( media-libs/nas )
- !qt-static? (
- qt3? ( =x11-libs/qt-3*[-immqt] )
- !qt3? ( x11-libs/qt-core x11-libs/qt-gui )
- )
- )
- !ia32? (
- qt-static? ( media-libs/nas )
- !qt-static? (
- qt3? ( =x11-libs/qt-3*[-immqt] )
- !qt3? ( x11-libs/qt-core x11-libs/qt-gui )
- )
+ qt-static? ( media-libs/nas )
+ !qt-static? (
+ qt3? ( =x11-libs/qt-3*[-immqt] )
+ !qt3? ( x11-libs/qt-core x11-libs/qt-gui )
)
)
ppc? ( =x11-libs/qt-3*[-immqt] )