summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-07-19 04:53:58 +0000
committerTim Harder <radhermit@gentoo.org>2014-07-19 04:53:58 +0000
commita8153bf857041af4b6eaeb66f1963270f8271bb7 (patch)
tree4f7d16f6c571c5db483230ce5859099cbe473400 /www-client/vimprobable2/vimprobable2-9999.ebuild
parentVersion bump. (diff)
downloadhistorical-a8153bf857041af4b6eaeb66f1963270f8271bb7.tar.gz
historical-a8153bf857041af4b6eaeb66f1963270f8271bb7.tar.bz2
historical-a8153bf857041af4b6eaeb66f1963270f8271bb7.zip
Add savedconfig support (bug #515722).
Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0x4AB3E85B4F064CA3
Diffstat (limited to 'www-client/vimprobable2/vimprobable2-9999.ebuild')
-rw-r--r--www-client/vimprobable2/vimprobable2-9999.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/www-client/vimprobable2/vimprobable2-9999.ebuild b/www-client/vimprobable2/vimprobable2-9999.ebuild
index 7ce232db7586..a50e5f9da8df 100644
--- a/www-client/vimprobable2/vimprobable2-9999.ebuild
+++ b/www-client/vimprobable2/vimprobable2-9999.ebuild
@@ -1,13 +1,18 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/vimprobable2/vimprobable2-9999.ebuild,v 1.3 2013/05/26 09:53:29 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/vimprobable2/vimprobable2-9999.ebuild,v 1.4 2014/07/19 04:53:56 radhermit Exp $
EAPI=5
+inherit toolchain-funcs savedconfig
-inherit toolchain-funcs git-2
-
-EGIT_REPO_URI="git://git.code.sf.net/p/vimprobable/code"
-EGIT_PROJECT="vimprobable"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.code.sf.net/p/vimprobable/code"
+else
+ SRC_URI="mirror://sourceforge/vimprobable/${PN}_${PV}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${PN}
+fi
DESCRIPTION="A minimal web browser that behaves like the Vimperator plugin for Firefox"
HOMEPAGE="http://www.vimprobable.org/"
@@ -23,13 +28,14 @@ DEPEND="${RDEPEND}
dev-lang/perl
virtual/pkgconfig"
-S=${WORKDIR}/${PN}
-
src_prepare() {
tc-export CC
+ restore_config config.h keymap.h
}
src_install() {
dobin ${PN}
doman ${PN}.1 vimprobablerc.5
+
+ save_config config.h keymap.h
}