summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2007-01-16 10:13:26 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2007-01-16 10:13:26 +0000
commit645808af3aaaf93d526e21fde48be36c5df0b499 (patch)
tree9c01cba508484f7b4eedf989e8a4462629bc69b0 /www-servers/nginx
parentppc stable (bug #161956) (diff)
downloadhistorical-645808af3aaaf93d526e21fde48be36c5df0b499.tar.gz
historical-645808af3aaaf93d526e21fde48be36c5df0b499.tar.bz2
historical-645808af3aaaf93d526e21fde48be36c5df0b499.zip
* bump
Package-Manager: portage-2.1.2
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/files/digest-nginx-0.5.73
-rw-r--r--www-servers/nginx/nginx-0.5.7.ebuild86
3 files changed, 96 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index f75dea0a3e06..60a9bdcf52dc 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.128 2007/01/11 08:41:02 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.129 2007/01/16 10:13:25 voxus Exp $
+
+*nginx-0.5.7 (16 Jan 2007)
+
+ 16 Jan 2007; Konstantin V. Arkhipov <voxus@gentoo.org>
+ -nginx-0.5.6.ebuild, +nginx-0.5.7.ebuild:
+ Version bump.
*nginx-0.5.6 (11 Jan 2007)
diff --git a/www-servers/nginx/files/digest-nginx-0.5.7 b/www-servers/nginx/files/digest-nginx-0.5.7
new file mode 100644
index 000000000000..806bacd86220
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.5.7
@@ -0,0 +1,3 @@
+MD5 3f7894241d4a49d451589d5ffcb6d42d nginx-0.5.7.tar.gz 452723
+RMD160 9bb28d61a480bb4f9d7b859bf29432fc39b4d0f2 nginx-0.5.7.tar.gz 452723
+SHA256 b4e9edfe656b33f7494704ede0c9f150df8f665ea373df986853344319bdc3b4 nginx-0.5.7.tar.gz 452723
diff --git a/www-servers/nginx/nginx-0.5.7.ebuild b/www-servers/nginx/nginx-0.5.7.ebuild
new file mode 100644
index 000000000000..9f91e8846d24
--- /dev/null
+++ b/www-servers/nginx/nginx-0.5.7.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.5.7.ebuild,v 1.1 2007/01/16 10:13:25 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl status zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+pkg_setup() {
+ ebegin "Creating nginx user and group"
+ enewgroup nginx
+ enewuser nginx -1 -1 /dev/null nginx
+ eend ${?}
+}
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+ use status && myconf="${myconf} --with-http_stub_status_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ cp ${FILESDIR}/nginx.conf-r3 conf/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/*
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}