summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-09-30 15:01:04 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-09-30 15:01:04 +0000
commitee894654ec47801c8a377db67089f5a8206a992f (patch)
treefaaa4812ce62eabff2fe6c8c4330b260e98943ac /www-servers
parentStable on sparc (diff)
downloadhistorical-ee894654ec47801c8a377db67089f5a8206a992f.tar.gz
historical-ee894654ec47801c8a377db67089f5a8206a992f.tar.bz2
historical-ee894654ec47801c8a377db67089f5a8206a992f.zip
* bump
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/Manifest5
-rw-r--r--www-servers/nginx/files/digest-nginx-0.2.21
-rw-r--r--www-servers/nginx/files/nginx-0.2.2-compile_fix.patch11
-rw-r--r--www-servers/nginx/nginx-0.2.2.ebuild76
5 files changed, 99 insertions, 2 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 1f15d6c98057..4a9abc517aa7 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.43 2005/09/23 21:21:27 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.44 2005/09/30 15:01:04 voxus Exp $
+
+*nginx-0.2.2 (30 Sep 2005)
+
+ 30 Sep 2005; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.2.2.ebuild,
+ +files/nginx-0.2.2-compile_fix.patch:
+ Version bump.
*nginx-0.2.1 (23 Sep 2005)
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index 7529a2a7355b..22820d961e83 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -1,8 +1,11 @@
+MD5 1119c0b07203136bf0a5674f30b4ba1d nginx-0.2.2.ebuild 2019
MD5 3c18bb527b67288a5978c43962bfd4bc nginx-0.2.1.ebuild 1936
-MD5 68b48c66fca0d6c8428ee56a34529ae5 ChangeLog 7679
+MD5 39d2a2f5df529d12d5240018fbda0dec ChangeLog 7839
MD5 822f3c821527e6a34f23a6a92a884766 metadata.xml 220
MD5 62f46895e63da25c83512f589b9e61cb nginx-0.1.45.ebuild 1935
MD5 e8474104898712edc8575c940152bbd3 files/digest-nginx-0.1.45 64
MD5 d8f7e621e098b58848a6b5fb045c49c3 files/nginx 994
+MD5 2a260cbde85f900c8918974c38dfb2af files/nginx-0.2.2-compile_fix.patch 374
MD5 ed882ba7b3d8655035ab7b1df383cb1e files/digest-nginx-0.2.1 63
+MD5 899f68cfe9d9ca8c8b8bc84d7f57a08f files/digest-nginx-0.2.2 63
MD5 fecedd05099122b1f8169152e5bc9462 files/nginx.conf 1400
diff --git a/www-servers/nginx/files/digest-nginx-0.2.2 b/www-servers/nginx/files/digest-nginx-0.2.2
new file mode 100644
index 000000000000..458f0132318d
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.2.2
@@ -0,0 +1 @@
+MD5 6673ac601bbbe3e1604da89d2d621e13 nginx-0.2.2.tar.gz 327407
diff --git a/www-servers/nginx/files/nginx-0.2.2-compile_fix.patch b/www-servers/nginx/files/nginx-0.2.2-compile_fix.patch
new file mode 100644
index 000000000000..a70c0bac200a
--- /dev/null
+++ b/www-servers/nginx/files/nginx-0.2.2-compile_fix.patch
@@ -0,0 +1,11 @@
+--- src/event/ngx_event_openssl.c Fri Sep 30 10:28:02 2005
++++ src/event/ngx_event_openssl.c Fri Sep 30 18:50:23 2005
+@@ -320,7 +320,7 @@
+
+ c = ev->data;
+
+- ngx_log_debug0(NGX_LOG_DEBUG_EVENT, c->log, 0,
++ ngx_log_debug1(NGX_LOG_DEBUG_EVENT, c->log, 0,
+ "ssl handshake handler: %d", ev->write);
+
+ if (ngx_ssl_handshake(c) == NGX_AGAIN) {
diff --git a/www-servers/nginx/nginx-0.2.2.ebuild b/www-servers/nginx/nginx-0.2.2.ebuild
new file mode 100644
index 000000000000..b83bb005ec20
--- /dev/null
+++ b/www-servers/nginx/nginx-0.2.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.2.2.ebuild,v 1.1 2005/09/30 15:01:04 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-compile_fix.patch
+}
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dodir /etc/${PN}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ insinto /etc/${PN}
+ rm conf/nginx.conf
+ doins -r conf/*
+ doins ${FILESDIR}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}