summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-11 00:21:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-11 00:21:53 +0000
commit8e5db827f441e5f0542e27d9fbf78e5f1acfe958 (patch)
tree3d0909bcfae6ca9f546eeb025c41676a9abdcdef /x11-apps
parentClean up old revisions. Make sure libsoup-gnome is in RDEPEND, bug #305423. (diff)
downloadhistorical-8e5db827f441e5f0542e27d9fbf78e5f1acfe958.tar.gz
historical-8e5db827f441e5f0542e27d9fbf78e5f1acfe958.tar.bz2
historical-8e5db827f441e5f0542e27d9fbf78e5f1acfe958.zip
Fix building with libpng14.
Package-Manager: portage-2.2_rc66/cvs/Linux x86_64
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xcursorgen/ChangeLog6
-rw-r--r--x11-apps/xcursorgen/Manifest4
-rw-r--r--x11-apps/xcursorgen/xcursorgen-1.0.3.ebuild14
3 files changed, 19 insertions, 5 deletions
diff --git a/x11-apps/xcursorgen/ChangeLog b/x11-apps/xcursorgen/ChangeLog
index 35fe39fabbff..2d9645c74531 100644
--- a/x11-apps/xcursorgen/ChangeLog
+++ b/x11-apps/xcursorgen/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-apps/xcursorgen
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xcursorgen/ChangeLog,v 1.47 2010/01/23 18:48:57 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xcursorgen/ChangeLog,v 1.48 2010/03/11 00:21:53 ssuominen Exp $
+
+ 11 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ xcursorgen-1.0.3.ebuild:
+ Fix building with libpng14.
23 Jan 2010; Tomáš Chvátal <scarabeus@gentoo.org>
-xcursorgen-1.0.2.ebuild:
diff --git a/x11-apps/xcursorgen/Manifest b/x11-apps/xcursorgen/Manifest
index 252bf0cf3f88..3e2a4c4665b9 100644
--- a/x11-apps/xcursorgen/Manifest
+++ b/x11-apps/xcursorgen/Manifest
@@ -1,4 +1,4 @@
DIST xcursorgen-1.0.3.tar.bz2 99262 RMD160 9b7ac67158c3befcde20a2189134f83185a0b172 SHA1 7df26b371476654dc191c45e7d20ae3a5e0cad87 SHA256 ed5f3ffe881c21ffca85406e5a5f553ed4985cc5e9acdb535f682c33bebac254
-EBUILD xcursorgen-1.0.3.ebuild 499 RMD160 081e636575145e77c0a817e41554558c4bd90e7b SHA1 9182b1844c8a434656e2221e9bbeae0ad5fdedb8 SHA256 7f787c9fec98b72d97000202084eecd6bd33eb317f12cb908bc8adbcbc340f81
-MISC ChangeLog 5577 RMD160 b32687aeed0f5d2cd5909745f3afd7e0972f0ab2 SHA1 0401e8ef24964d1c3cb5f727dd84cb2a8f9d733b SHA256 b7bf882ff7f2c627e07619d2f8b4f5bd118cb161ade8af8208336948b920b3ef
+EBUILD xcursorgen-1.0.3.ebuild 625 RMD160 6cf7c5b840deab478016ac5537f36ff6fcf90036 SHA1 f5603e95377ac61d7c0c542d861d1f893611527d SHA256 1c33695ef28eeab3c9f0a294f858234c67917c223a7ff66c55adcf7fe452eb10
+MISC ChangeLog 5689 RMD160 04baec6444be1f02f315528102d2b7b8322276ef SHA1 c17b42277004819eba59103953f766028007206c SHA256 1a465a1e703f6b77c683cfe481e89b2ec18b434cb350faa8a661d3741b6aa2f1
MISC metadata.xml 156 RMD160 c1274bdccf57603d580de0075ba07a35b7509560 SHA1 6f78f604e3d079d39189b40aaaa1ddb06182ad91 SHA256 5101ab0d4cc8c7125eea733c44e86962769bd77acaf53b69223b9cadcdd29055
diff --git a/x11-apps/xcursorgen/xcursorgen-1.0.3.ebuild b/x11-apps/xcursorgen/xcursorgen-1.0.3.ebuild
index a1c49c4846ad..ed1dacb791dd 100644
--- a/x11-apps/xcursorgen/xcursorgen-1.0.3.ebuild
+++ b/x11-apps/xcursorgen/xcursorgen-1.0.3.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xcursorgen/xcursorgen-1.0.3.ebuild,v 1.9 2010/01/19 18:19:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xcursorgen/xcursorgen-1.0.3.ebuild,v 1.10 2010/03/11 00:21:53 ssuominen Exp $
+EAPI=2
+SNAPSHOT=yes
inherit x-modular
DESCRIPTION="create an X cursor file from a collection of PNG images"
@@ -11,5 +13,13 @@ IUSE=""
RDEPEND="x11-libs/libX11
x11-libs/libXcursor
- =media-libs/libpng-1.2*"
+ >=media-libs/libpng-1.2"
DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's:libpng12:libpng:' \
+ configure.ac || die
+
+ x-modular_src_prepare
+}