summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-18 17:00:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-18 17:00:03 +0000
commit8ddb218c9f2caba8e5e3d813df94fb1247d9a040 (patch)
tree3c4d23f174bc50401f614d7d39fa3d73cde7191f /x11-drivers
parentFixed for amd64 systems and potential security bug (see related bug #189249). (diff)
downloadhistorical-8ddb218c9f2caba8e5e3d813df94fb1247d9a040.tar.gz
historical-8ddb218c9f2caba8e5e3d813df94fb1247d9a040.tar.bz2
historical-8ddb218c9f2caba8e5e3d813df94fb1247d9a040.zip
Bump to 2.2.0. Many thanks to Alessio Cassibba for the ebuilds. Part of #265510
Package-Manager: portage-2.2_rc30/cvs/Linux x86_64
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-virtualbox/ChangeLog9
-rw-r--r--x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.0.ebuild96
-rw-r--r--x11-drivers/xf86-video-virtualbox/ChangeLog10
-rw-r--r--x11-drivers/xf86-video-virtualbox/files/xf86-video-virtualbox-2.2.0-enable-opengl.patch13
-rw-r--r--x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-2.2.0.ebuild111
5 files changed, 237 insertions, 2 deletions
diff --git a/x11-drivers/xf86-input-virtualbox/ChangeLog b/x11-drivers/xf86-input-virtualbox/ChangeLog
index 81578b963389..f43c368997d4 100644
--- a/x11-drivers/xf86-input-virtualbox/ChangeLog
+++ b/x11-drivers/xf86-input-virtualbox/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-input-virtualbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/ChangeLog,v 1.9 2009/03/03 07:38:47 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/ChangeLog,v 1.10 2009/04/18 17:00:03 patrick Exp $
+
+*xf86-input-virtualbox-2.2.0 (18 Apr 2009)
+
+ 18 Apr 2009; Patrick Lauer <patrick@gentoo.org>
+ +xf86-input-virtualbox-2.2.0.ebuild:
+ Bump to 2.2.0. Many thanks to Alessio Cassibba for the ebuilds. Part of
+ #265510
*xf86-input-virtualbox-2.1.4 (03 Mar 2009)
diff --git a/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.0.ebuild b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.0.ebuild
new file mode 100644
index 000000000000..a061c0783364
--- /dev/null
+++ b/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-virtualbox/xf86-input-virtualbox-2.2.0.ebuild,v 1.1 2009/04/18 17:00:03 patrick Exp $
+
+EAPI=2
+
+inherit x-modular eutils
+
+MY_P=VirtualBox-${PV}-OSE
+DESCRIPTION="VirtualBox input driver"
+HOMEPAGE="http://www.virtualbox.org/"
+SRC_URI="http://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hal"
+
+RDEPEND="x11-base/xorg-server
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ >=dev-util/kbuild-0.1.5-r1
+ >=dev-lang/yasm-0.6.2
+ sys-devel/dev86
+ sys-power/iasl
+ x11-proto/inputproto
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+S=${WORKDIR}/${MY_P/-OSE/_OSE}
+
+src_prepare() {
+ # Remove shipped binaries (kBuild,yasm), see bug #232775
+ rm -rf kBuild/bin tools
+
+ # Disable things unused or splitted into separate ebuilds
+ cp "${FILESDIR}/${PN}-2-localconfig" LocalConfig.kmk
+}
+
+src_configure() {
+ # build the user-space tools, warnings are harmless
+ ./configure --nofatal \
+ --disable-xpcom \
+ --disable-sdl-ttf \
+ --disable-pulse \
+ --disable-alsa \
+ --build-headless || die "configure failed"
+ source ./env.sh
+}
+
+src_compile() {
+ for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
+ /src/VBox/Additions/x11/vboxmouse ; do
+ cd "${S}"${each}
+ MAKE="kmk" emake TOOL_YASM_AS=yasm \
+ KBUILD_PATH="${S}/kBuild" \
+ || die "kmk failed"
+ done
+}
+
+src_install() {
+ cd "${S}/out/linux.${ARCH}/release/bin/additions"
+ insinto /usr/lib/xorg/modules/input
+
+ # xorg-server-1.6.x (currently on the official x11 overlay)
+ if has_version ">=x11-base/xorg-server-1.6" ; then
+ newins vboxmouse_drv_16.so vboxmouse_drv.so
+ # xorg-server-1.5.x
+ elif has_version ">=x11-base/xorg-server-1.5" \
+ && has_version "<x11-base/xorg-server-1.6" ; then
+ newins vboxmouse_drv_15.so vboxmouse_drv.so
+ # xorg-server-1.4.x
+ elif has_version ">=x11-base/xorg-server-1.4" \
+ && has_version "<x11-base/xorg-server-1.5" ; then
+ newins vboxmouse_drv_14.so vboxmouse_drv.so
+ # xorg-server-1.3.x
+ else
+ newins vboxmouse_drv_71.so vboxmouse_drv.so
+ fi
+
+ # install hal information file about the mouse driver
+ if use hal; then
+ cd "${S}/src/VBox/Additions/linux/installer"
+ insinto /usr/share/hal/fdi/information/20thirdparty
+ doins 90-vboxguest.fdi
+ fi
+}
+
+pkg_postinst() {
+ elog "You need to edit the file /etc/X11/xorg.conf and set:"
+ elog ""
+ elog " Driver \"vboxmouse\""
+ elog ""
+ elog "in the Core Pointer's InputDevice section (Section \"InputDevice\")"
+ elog ""
+}
diff --git a/x11-drivers/xf86-video-virtualbox/ChangeLog b/x11-drivers/xf86-video-virtualbox/ChangeLog
index f8d73ba5d633..95f276fb4f4d 100644
--- a/x11-drivers/xf86-video-virtualbox/ChangeLog
+++ b/x11-drivers/xf86-video-virtualbox/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-drivers/xf86-video-virtualbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/ChangeLog,v 1.8 2009/03/03 07:22:23 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/ChangeLog,v 1.9 2009/04/18 16:58:34 patrick Exp $
+
+*xf86-video-virtualbox-2.2.0 (18 Apr 2009)
+
+ 18 Apr 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/xf86-video-virtualbox-2.2.0-enable-opengl.patch,
+ +xf86-video-virtualbox-2.2.0.ebuild:
+ Bump to 2.2.0. Many thanks to Alessio Cassibba for the ebuilds. Part of
+ #265510
*xf86-video-virtualbox-2.1.4 (03 Mar 2009)
diff --git a/x11-drivers/xf86-video-virtualbox/files/xf86-video-virtualbox-2.2.0-enable-opengl.patch b/x11-drivers/xf86-video-virtualbox/files/xf86-video-virtualbox-2.2.0-enable-opengl.patch
new file mode 100644
index 000000000000..ad66ff20401d
--- /dev/null
+++ b/x11-drivers/xf86-video-virtualbox/files/xf86-video-virtualbox-2.2.0-enable-opengl.patch
@@ -0,0 +1,13 @@
+--- configure.orig 2009-04-11 19:30:06.000000000 +0200
++++ configure 2009-04-11 20:46:05.000000000 +0200
+@@ -1955,8 +1955,8 @@
+ HEADLESS=1
+ WITH_SDL=0
+ WITH_SDL_TTF=0
+- WITH_X11=0
+- WITH_OPENGL=0
++ WITH_X11=1
++ WITH_OPENGL=1
+ WITH_QT4=0
+ ;;
+ --ose)
diff --git a/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-2.2.0.ebuild b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-2.2.0.ebuild
new file mode 100644
index 000000000000..d9dd3d8695bf
--- /dev/null
+++ b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-2.2.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-2.2.0.ebuild,v 1.1 2009/04/18 16:58:34 patrick Exp $
+
+EAPI=2
+
+inherit x-modular eutils
+
+MY_P=VirtualBox-${PV}-OSE-20090415
+DESCRIPTION="VirtualBox video driver"
+HOMEPAGE="http://www.virtualbox.org/"
+SRC_URI="http://gentoo.zerodev.it/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dri"
+
+RDEPEND="x11-base/xorg-server"
+DEPEND="${RDEPEND}
+ >=dev-util/kbuild-0.1.5-r1
+ >=dev-lang/yasm-0.6.2
+ sys-devel/dev86
+ sys-power/iasl
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xproto
+ x11-libs/libXdmcp
+ x11-libs/libXcomposite
+ x11-libs/libXau
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXext
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2.4.5 )"
+
+S=${WORKDIR}/${MY_P/-OSE-20090415/_OSE}
+
+src_prepare() {
+ # Remove shipped binaries (kBuild,yasm), see bug #232775
+ rm -rf kBuild/bin tools
+
+ # Disable things unused or splitted into separate ebuilds
+ cp "${FILESDIR}/${PN}-2-localconfig" LocalConfig.kmk
+
+ # Ugly hack to build the opengl part of the video driver
+ epatch "${FILESDIR}/${P}-enable-opengl.patch"
+}
+
+src_configure() {
+ # build the user-space tools, warnings are harmless
+ ./configure --nofatal \
+ --disable-xpcom \
+ --disable-sdl-ttf \
+ --disable-pulse \
+ --disable-alsa \
+ --build-headless || die "configure failed"
+ source ./env.sh
+}
+
+src_compile() {
+ for each in /src/VBox/{Runtime,Additions/common/VBoxGuestLib} \
+ /src/VBox/{GuestHost/OpenGL,Additions/x11/x11stubs,Additions/common/crOpenGL} \
+ /src/VBox/Additions/x11/vboxvideo ; do
+ cd "${S}"${each}
+ MAKE="kmk" emake TOOL_YASM_AS=yasm \
+ KBUILD_PATH="${S}/kBuild" \
+ || die "kmk failed"
+ done
+}
+
+src_install() {
+ cd "${S}/out/linux.${ARCH}/release/bin/additions"
+ insinto /usr/lib/xorg/modules/drivers
+
+ # xorg-server-1.6.x (currently on the official x11 overlay)
+ if has_version ">=x11-base/xorg-server-1.6" ; then
+ newins vboxvideo_drv_16.so vboxvideo_drv.so
+ # xorg-server-1.5.x
+ elif has_version ">=x11-base/xorg-server-1.5" \
+ && has_version "<x11-base/xorg-server-1.6" ; then
+ newins vboxvideo_drv_15.so vboxvideo_drv.so
+ # xorg-server-1.4.x
+ elif has_version ">=x11-base/xorg-server-1.4" \
+ && has_version "<x11-base/xorg-server-1.5" ; then
+ newins vboxvideo_drv_14.so vboxvideo_drv.so
+ # xorg-server-1.3.x
+ else
+ newins vboxvideo_drv_13.so vboxvideo_drv.so
+ fi
+
+ # Guest OpenGL driver
+ insinto /usr/lib
+ doins -r VBoxOGL* || die
+
+ if use dri ; then
+ dosym /usr/lib/VBoxOGL.so /usr/lib/dri/vboxvideo_dri.so
+ fi
+}
+
+pkg_postinst() {
+ elog "You need to edit the file /etc/X11/xorg.conf and set:"
+ elog ""
+ elog " Driver \"vboxvideo\""
+ elog ""
+ elog "in the Graphics device section (Section \"Device\")"
+ elog ""
+}